summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2020-06-04 14:54:41 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-06-12 15:59:14 +0300
commitd6d41d248453aa0925ecbee9d896712be4780553 (patch)
tree2ab130f5aa2c075150b49aa42d44993026fb2dc1 /meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb
parentf089ba1b6aff10fcd4e7a6e4b9809e866e0816ff (diff)
downloadopenbmc-d6d41d248453aa0925ecbee9d896712be4780553.tar.xz
meta-quanta: gbs: detect SlimSAS cable presence
Add gpio configuration for SlimSAS cable0~3 and detect cables connected or not (From meta-quanta rev: 09b8cd98a953ef96fabd7bc1c8d090bd02c53d88) Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: Ifee5ebf1a1055943ade8defce6be63b690bea8d2 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb')
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb b/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb
new file mode 100644
index 000000000..74785ef63
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb
@@ -0,0 +1,25 @@
+SUMMARY = "OpenBMC Quanta Detect SAS Cable Service"
+DESCRIPTION = "OpenBMC Quanta Detect SAS Cable Daemon."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+
+DEPENDS += "systemd"
+RDEPENDS_${PN} += "bash"
+
+SRC_URI = " file://detect-sas-cable.sh \
+ file://detect-sas-cable.service \
+ "
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/detect-sas-cable.sh ${D}${bindir}/
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/detect-sas-cable.service ${D}${systemd_system_unitdir}
+}
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "detect-sas-cable.service"