summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/gbs-detect-gpio-present.bb
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2020-07-20 16:02:11 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-23 00:47:08 +0300
commitfd8041ee5efccf77dacc13b3447e527fc57a53e5 (patch)
treec51904a24a14cbaca3cfd8e9b0ee45aa2bd1ae1e /meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/gbs-detect-gpio-present.bb
parent5f2142ef7c0f94cb4c4874432071208c613101f5 (diff)
downloadopenbmc-fd8041ee5efccf77dacc13b3447e527fc57a53e5.tar.xz
meta-quanta: gbs: expose more GPIO signals as IPMI SDR
1. monitor more GPIO signals gpio_net_name / gpio_number: ['SATA0_PRSNT_N']=5 ['HSBP_CABLE_PRSNT_BUF_N']=57 ['FAN_BRD_CABLE_PRSNT_BUF']=58 ['HSBP_P12V_STBY_CABLE_PRSNT']=69 ['PE_SLOT0_PRSNT_N']=120 ['PE_SLOT1_PRSNT_N']=121 2. add these GPIO signals to the sensor YAML config (From meta-quanta rev: de864a90b91c72a9d31a36688d744a12926a57b3) Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: Ie39512763757e222ca386349a4c45af135500d65 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/gbs-detect-gpio-present.bb')
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/gbs-detect-gpio-present.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/gbs-detect-gpio-present.bb b/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/gbs-detect-gpio-present.bb
new file mode 100644
index 000000000..3e1a6d8ac
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-gbs/gbs-detect-gpio-present/gbs-detect-gpio-present.bb
@@ -0,0 +1,25 @@
+SUMMARY = "OpenBMC Quanta Detect Present Service"
+DESCRIPTION = "OpenBMC Quanta Detect Present Daemon."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+
+DEPENDS += "systemd"
+RDEPENDS_${PN} += "bash"
+
+SRC_URI = " file://detect-gpio-present.sh \
+ file://detect-gpio-present.service \
+ "
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/detect-gpio-present.sh ${D}${bindir}/
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/detect-gpio-present.service ${D}${systemd_system_unitdir}
+}
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "detect-gpio-present.service"