summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-gbs
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2020-06-04 14:54:41 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-06-12 15:59:14 +0300
commitd6d41d248453aa0925ecbee9d896712be4780553 (patch)
tree2ab130f5aa2c075150b49aa42d44993026fb2dc1 /meta-quanta/meta-gbs/recipes-gbs
parentf089ba1b6aff10fcd4e7a6e4b9809e866e0816ff (diff)
downloadopenbmc-d6d41d248453aa0925ecbee9d896712be4780553.tar.xz
meta-quanta: gbs: detect SlimSAS cable presence
Add gpio configuration for SlimSAS cable0~3 and detect cables connected or not (From meta-quanta rev: 09b8cd98a953ef96fabd7bc1c8d090bd02c53d88) Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: Ifee5ebf1a1055943ade8defce6be63b690bea8d2 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-gbs')
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/files/detect-sas-cable.service12
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/files/detect-sas-cable.sh45
-rw-r--r--meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb25
3 files changed, 82 insertions, 0 deletions
diff --git a/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/files/detect-sas-cable.service b/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/files/detect-sas-cable.service
new file mode 100644
index 000000000..6575f4fb7
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/files/detect-sas-cable.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Detect SAS Cable Manager
+Wants=phosphor-gpio-presence@.service
+After=phosphor-gpio-presence@.service
+
+[Service]
+ExecStart=/usr/bin/detect-sas-cable.sh
+StandardOutput=syslog
+Type=simple
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/files/detect-sas-cable.sh b/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/files/detect-sas-cable.sh
new file mode 100644
index 000000000..ed02c9023
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/files/detect-sas-cable.sh
@@ -0,0 +1,45 @@
+#!/bin/bash
+
+SERVICE_NAME="xyz.openbmc_project.Inventory.Manager"
+SAS_CABLE_OBJPATH=("/xyz/openbmc_project/inventory/system/chassis/cable/ss_cab0_prsnt"
+"/xyz/openbmc_project/inventory/system/chassis/cable/ss_cab1_prsnt"
+"/xyz/openbmc_project/inventory/system/chassis/cable/ss_cab2_prsnt"
+"/xyz/openbmc_project/inventory/system/chassis/cable/ss_cab3_prsnt")
+INTERFACE_NAME="xyz.openbmc_project.Inventory.Item"
+
+IPMI_LOG_SERVICE="xyz.openbmc_project.Logging.IPMI"
+IPMI_LOG_OBJPATH="/xyz/openbmc_project/Logging/IPMI"
+IPMI_LOG_INTERFACE="xyz.openbmc_project.Logging.IPMI"
+IPMI_LOG_FUNCT="IpmiSelAdd"
+IPMI_LOG_PARA_FORMAT="ssaybq" #5 parameters, s : string, s : string, ay : byte array, b : boolean, y : UINT16
+LOG_ERR="Cable_error(Incorrect_interconnection)"
+LOG_EVENT_DATA="3 0x01 0xff 0xfe"
+LOG_ASSERT_FLAG="true"
+LOG_DEASSERT_FLAG="false"
+LOG_GENID_FLAG="0x0020"
+cable_state=("true" "true" "true" "true")
+
+mapper wait ${SAS_CABLE_OBJPATH[0]}
+mapper wait ${SAS_CABLE_OBJPATH[1]}
+mapper wait ${SAS_CABLE_OBJPATH[2]}
+mapper wait ${SAS_CABLE_OBJPATH[3]}
+
+while true; do
+ for i in {0..3};
+ do
+ boot_status="$(busctl get-property $SERVICE_NAME ${SAS_CABLE_OBJPATH[$i]} $INTERFACE_NAME Present | awk '{print $2}')"
+
+ if [ $boot_status == "false" ] && [ ${cable_state[$i]} == "true" ];then
+ echo "Update cable $(($i+1)) state."
+ cable_state[$i]="false"
+ busctl call $IPMI_LOG_SERVICE $IPMI_LOG_OBJPATH $IPMI_LOG_INTERFACE $IPMI_LOG_FUNCT $IPMI_LOG_PARA_FORMAT $LOG_ERR ${SAS_CABLE_OBJPATH[$i]} $LOG_EVENT_DATA $LOG_ASSERT_FLAG $LOG_GENID_FLAG
+ elif [ $boot_status == "true" ] && [ ${cable_state[$i]} != "true" ];then
+ echo "Update cable $(($i+1)) state."
+ cable_state[$i]="true"
+ busctl call $IPMI_LOG_SERVICE $IPMI_LOG_OBJPATH $IPMI_LOG_INTERFACE $IPMI_LOG_FUNCT $IPMI_LOG_PARA_FORMAT $LOG_ERR ${SAS_CABLE_OBJPATH[$i]} $LOG_EVENT_DATA $LOG_DEASSERT_FLAG $LOG_GENID_FLAG
+ fi
+ done
+ sleep 1
+done
+
+exit 0
diff --git a/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb b/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb
new file mode 100644
index 000000000..74785ef63
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-gbs/detect-sas-cable/gbs-detect-sas-cable.bb
@@ -0,0 +1,25 @@
+SUMMARY = "OpenBMC Quanta Detect SAS Cable Service"
+DESCRIPTION = "OpenBMC Quanta Detect SAS Cable Daemon."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+
+DEPENDS += "systemd"
+RDEPENDS_${PN} += "bash"
+
+SRC_URI = " file://detect-sas-cable.sh \
+ file://detect-sas-cable.service \
+ "
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/detect-sas-cable.sh ${D}${bindir}/
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/detect-sas-cable.service ${D}${systemd_system_unitdir}
+}
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "detect-sas-cable.service"