summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-google
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2021-03-10 11:04:46 +0300
committerBrandon Kim <brandonkim@google.com>2021-04-01 01:52:01 +0300
commitb5eef5151b9292593bfce7fb5ae3d63e1a5671a6 (patch)
tree591f222cd44203b9914519b21143bdec0aabe759 /meta-quanta/meta-gbs/recipes-google
parent38b6831afd7321dd9b95d67e1d4d9ef551933190 (diff)
downloadopenbmc-b5eef5151b9292593bfce7fb5ae3d63e1a5671a6.tar.xz
meta-quanta: gbs: failsafe fan speed control dynamically
1. add acpi-power-state daemon to check the ACPI power states from BIOS 2. set failsafe fan speed at different states - S0_G0_D0: 90% - S5_G2: 40% Note: this item depends on the commit and will add as the patches first in another PR https://gerrit.openbmc-project.xyz/38112 3. add gbs-check-host-state.sh to monitor the power state D-Bus and then trigger to set fan failsafe speed 4. remove gbs-detect-fan-fail service and unused scripts from phosphor-pid-control 5. update read-margin-temp srcrev to avoid nvme temperature sensor failed due to nvme SSD not-present Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: I496dd7bc59076a2b3690e367877d49533855c9fe
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-google')
-rw-r--r--meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-check-host-state.service10
-rw-r--r--meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-check-host-state.sh13
-rw-r--r--meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-ready.target8
-rw-r--r--meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-s0-set-failsafe.service15
-rw-r--r--meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-s5-set-failsafe.service15
-rw-r--r--meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-set-boot-failsafe@.service14
-rw-r--r--meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-set-boot-failsafe.sh35
-rw-r--r--meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-set-failsafe.sh53
-rw-r--r--meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon_%.bbappend43
9 files changed, 206 insertions, 0 deletions
diff --git a/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-check-host-state.service b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-check-host-state.service
new file mode 100644
index 000000000..032fabca5
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-check-host-state.service
@@ -0,0 +1,10 @@
+[Unit]
+Description = Check Host State to set fan failsafe speed
+
+[Service]
+Type=simple
+Restart=on-failure
+ExecStart=/usr/bin/gbs-check-host-state.sh
+
+[Install]
+WantedBy=multi-user.target \ No newline at end of file
diff --git a/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-check-host-state.sh b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-check-host-state.sh
new file mode 100644
index 000000000..1bff18d08
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-check-host-state.sh
@@ -0,0 +1,13 @@
+#!/bin/bash
+
+state="xyz.openbmc_project.State.Chassis.PowerState.Off"
+
+dbus-monitor --system type='signal',interface='org.freedesktop.DBus.Properties',\
+member='PropertiesChanged',arg0namespace='xyz.openbmc_project.State.Chassis' | \
+while read -r line; do
+ grep -q member <<< $line && continue
+ if grep -q $state <<< $line; then
+ echo "Setting failsafe assuming host is off" >&2
+ systemctl start --no-block gbs-host-s5-set-failsafe
+ fi
+done
diff --git a/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-ready.target b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-ready.target
new file mode 100644
index 000000000..7f806cdb8
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-ready.target
@@ -0,0 +1,8 @@
+[Unit]
+Description=Host is ready to be powered on
+Wants=phosphor-ipmi-host.service
+After=phosphor-ipmi-host.service
+Wants=obmc-console@ttyS1.service
+After=obmc-console@ttyS1.service
+After=postcode-7seg@seven_seg_disp_val.service
+RefuseManualStop=yes \ No newline at end of file
diff --git a/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-s0-set-failsafe.service b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-s0-set-failsafe.service
new file mode 100644
index 000000000..263cafaa2
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-s0-set-failsafe.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Increase GBS fan failsafe speed on host kernel entrance
+PartOf=host-s0-state.target
+Requires=phosphor-pid-control.service
+After=phosphor-pid-control.service
+Wants=mapper-wait@-xyz-openbmc_project-settings-fanctrl.service
+After=mapper-wait@-xyz-openbmc_project-settings-fanctrl.service
+
+[Service]
+Type=oneshot
+# 230: 90% duty cycle
+ExecStart=/usr/bin/gbs-set-failsafe.sh 230
+
+[Install]
+WantedBy=host-s0-state.target
diff --git a/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-s5-set-failsafe.service b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-s5-set-failsafe.service
new file mode 100644
index 000000000..2c0f3bccc
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-s5-set-failsafe.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Decrease GBS fan failsafe speed on host shutdown
+PartOf=host-s5-state.target
+Requires=phosphor-pid-control.service
+After=phosphor-pid-control.service
+Wants=mapper-wait@-xyz-openbmc_project-settings-fanctrl.service
+After=mapper-wait@-xyz-openbmc_project-settings-fanctrl.service
+
+[Service]
+Type=oneshot
+# 102: 40% duty cycle
+ExecStart=/usr/bin/gbs-set-failsafe.sh 102
+
+[Install]
+WantedBy=host-s5-state.target
diff --git a/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-set-boot-failsafe@.service b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-set-boot-failsafe@.service
new file mode 100644
index 000000000..c1e28383a
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-host-set-boot-failsafe@.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Set gBMC boot time failsafe
+Wants=mapper-wait@-xyz-openbmc_project-state-chassis%i.service
+After=mapper-wait@-xyz-openbmc_project-state-chassis%i.service
+After=acpi-power-state.service
+Before=gbs-sysinit.service
+
+[Service]
+Type=exec
+ExecStart=/usr/bin/gbs-set-boot-failsafe.sh
+RemainAfterExit=yes
+
+[Install]
+WantedBy=gbs-host-ready.target
diff --git a/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-set-boot-failsafe.sh b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-set-boot-failsafe.sh
new file mode 100644
index 000000000..6580fbe91
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-set-boot-failsafe.sh
@@ -0,0 +1,35 @@
+#!/bin/bash
+# Copyright 2021 Google LLC
+# Copyright 2021 Quanta Computer Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+main() {
+ local pgd_val
+ pgd_val="$(busctl get-property -j xyz.openbmc_project.State.Chassis \
+ /xyz/openbmc_project/state/chassis0 xyz.openbmc_project.State.Chassis \
+ CurrentPowerState | jq -r '.["data"]')"
+
+ if [[ $pgd_val != 'xyz.openbmc_project.State.Chassis.PowerState.On' ]]; then
+ echo "Setting failsafe assuming host is off" >&2
+ systemctl start --no-block gbs-host-s5-set-failsafe
+ else
+ echo "Setting failsafe assuming host is running" >&2
+ systemctl start --no-block gbs-host-s0-set-failsafe
+ fi
+}
+
+# Exit without running main() if sourced
+return 0 2>/dev/null
+
+main "$@"
diff --git a/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-set-failsafe.sh b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-set-failsafe.sh
new file mode 100644
index 000000000..bcd1d2cc2
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon/gbs-set-failsafe.sh
@@ -0,0 +1,53 @@
+#!/bin/bash
+# Copyright 2021 Google LLC
+# Copyright 2021 Quanta Computer Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+
+target_pwm="$1"
+
+if [ -z "$target_pwm" ]; then
+ echo "Target_pwm is not set" >&2
+ exit 1
+fi
+
+zone_num="$(busctl tree xyz.openbmc_project.State.FanCtrl | grep zone | wc -l)"
+result=0
+
+for (( i = 0; i < ${zone_num}; i++ )); do
+ retries=4
+ busctl_error=-1
+
+ while (( retries > 0 )) && (( busctl_error != 0 )); do
+ busctl set-property xyz.openbmc_project.State.FanCtrl /xyz/openbmc_project/settings/fanctrl/zone${i} xyz.openbmc_project.Control.FanSpeed Target t "${target_pwm}"
+ busctl_error=$?
+
+ if (( busctl_error != 0 )); then
+ #Retry setting failsafe. Swampd may be running but zone aren't yet built
+ #so sleep a second to let them be built
+ sleep 1
+ fi
+
+ let retries-=1
+ done
+
+ if (( busctl_error != 0 )); then
+ echo "Failure setting zone${i} fan failsafe to ${target_pwm}" >&2
+ result=$busctl_error
+ else
+ echo "Setting zone${i} fan failsafe to ${target_pwm}"
+ fi
+done
+
+exit $result
diff --git a/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon_%.bbappend b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon_%.bbappend
new file mode 100644
index 000000000..f833b5577
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-google/acpi-power-state/acpi-power-state-daemon_%.bbappend
@@ -0,0 +1,43 @@
+FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
+
+SRC_URI_append_gbs = " \
+ file://gbs-host-s0-set-failsafe.service \
+ file://gbs-host-s5-set-failsafe.service \
+ file://gbs-host-set-boot-failsafe@.service \
+ file://gbs-check-host-state.service \
+ file://gbs-set-boot-failsafe.sh \
+ file://gbs-set-failsafe.sh \
+ file://gbs-check-host-state.sh \
+ file://gbs-host-ready.target \
+ "
+
+RDEPENDS_${PN}_append_gbs = "bash"
+
+CHASSIS_INSTANCE="0"
+
+SYSTEMD_SERVICE_${PN}_append_gbs = " \
+ gbs-host-s0-set-failsafe.service \
+ gbs-host-s5-set-failsafe.service \
+ gbs-host-set-boot-failsafe@${CHASSIS_INSTANCE}.service \
+ gbs-check-host-state.service \
+ gbs-host-ready.target \
+ "
+
+FILES_${PN}_append_gbs = " \
+ ${systemd_system_unitdir}/gbs-host-set-boot-failsafe@.service \
+ "
+
+do_install_append_gbs() {
+ install -d ${D}${bindir}
+
+ install -m 0755 ${WORKDIR}/gbs-set-failsafe.sh ${D}${bindir}/.
+ install -m 0755 ${WORKDIR}/gbs-set-boot-failsafe.sh ${D}${bindir}/.
+ install -m 0755 ${WORKDIR}/gbs-check-host-state.sh ${D}${bindir}/.
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/gbs-host-s0-set-failsafe.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/gbs-host-s5-set-failsafe.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/gbs-host-set-boot-failsafe@.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/gbs-check-host-state.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/gbs-host-ready.target ${D}${systemd_system_unitdir}
+}