summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2021-03-10 11:04:46 +0300
committerBrandon Kim <brandonkim@google.com>2021-04-01 01:52:01 +0300
commitb5eef5151b9292593bfce7fb5ae3d63e1a5671a6 (patch)
tree591f222cd44203b9914519b21143bdec0aabe759 /meta-quanta/meta-gbs/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
parent38b6831afd7321dd9b95d67e1d4d9ef551933190 (diff)
downloadopenbmc-b5eef5151b9292593bfce7fb5ae3d63e1a5671a6.tar.xz
meta-quanta: gbs: failsafe fan speed control dynamically
1. add acpi-power-state daemon to check the ACPI power states from BIOS 2. set failsafe fan speed at different states - S0_G0_D0: 90% - S5_G2: 40% Note: this item depends on the commit and will add as the patches first in another PR https://gerrit.openbmc-project.xyz/38112 3. add gbs-check-host-state.sh to monitor the power state D-Bus and then trigger to set fan failsafe speed 4. remove gbs-detect-fan-fail service and unused scripts from phosphor-pid-control 5. update read-margin-temp srcrev to avoid nvme temperature sensor failed due to nvme SSD not-present Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: I496dd7bc59076a2b3690e367877d49533855c9fe
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-phosphor/fans/phosphor-pid-control_%.bbappend')
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/fans/phosphor-pid-control_%.bbappend14
1 files changed, 4 insertions, 10 deletions
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-quanta/meta-gbs/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
index 4f21d3bcf..25e102c9d 100644
--- a/meta-quanta/meta-gbs/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
+++ b/meta-quanta/meta-gbs/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -1,22 +1,18 @@
FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
-SRC_URI_append_gbs = " file://config-sku.json"
-SRC_URI_append_gbs = " file://fan-table-init.sh"
-SRC_URI_append_gbs = " file://fan-default-speed.sh"
-SRC_URI_append_gbs = " file://phosphor-pid-control.service"
-SRC_URI_append_gbs = " file://fan-reboot-control.service"
+SRC_URI_append_gbs = " file://config-sku.json \
+ file://fan-table-init.sh \
+ file://phosphor-pid-control.service \
+ "
FILES_${PN}_append_gbs = " ${datadir}/swampd/config-sku.json"
-FILES_${PN}_append_gbs = " ${bindir}/fan-default-speed.sh"
FILES_${PN}_append_gbs = " ${bindir}/fan-table-init.sh"
RDEPENDS_${PN} += "bash"
SYSTEMD_SERVICE_${PN}_append_gbs = " phosphor-pid-control.service"
-SYSTEMD_SERVICE_${PN}_append_gbs = " fan-reboot-control.service"
do_install_append_gbs() {
install -d ${D}/${bindir}
- install -m 0755 ${WORKDIR}/fan-default-speed.sh ${D}/${bindir}
install -m 0755 ${WORKDIR}/fan-table-init.sh ${D}/${bindir}
install -d ${D}${datadir}/swampd
@@ -26,6 +22,4 @@ do_install_append_gbs() {
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/phosphor-pid-control.service \
${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/fan-reboot-control.service \
- ${D}${systemd_system_unitdir}
}