summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-phosphor/gpio
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2020-06-04 14:54:41 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-06-12 15:59:14 +0300
commitd6d41d248453aa0925ecbee9d896712be4780553 (patch)
tree2ab130f5aa2c075150b49aa42d44993026fb2dc1 /meta-quanta/meta-gbs/recipes-phosphor/gpio
parentf089ba1b6aff10fcd4e7a6e4b9809e866e0816ff (diff)
downloadopenbmc-d6d41d248453aa0925ecbee9d896712be4780553.tar.xz
meta-quanta: gbs: detect SlimSAS cable presence
Add gpio configuration for SlimSAS cable0~3 and detect cables connected or not (From meta-quanta rev: 09b8cd98a953ef96fabd7bc1c8d090bd02c53d88) Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: Ifee5ebf1a1055943ade8defce6be63b690bea8d2 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-phosphor/gpio')
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-0.conf6
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-1.conf6
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-2.conf6
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-3.conf6
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-gpio-presence@.service.replace14
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend26
6 files changed, 64 insertions, 0 deletions
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-0.conf b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-0.conf
new file mode 100644
index 000000000..e26c8f50e
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-0.conf
@@ -0,0 +1,6 @@
+#The gpio 70 is a real gpio, which is used to
+#store the sas cable 0 present signal
+INVENTORY=/system/chassis/cable/ss_cab0_prsnt
+DEVPATH=/dev/input/event0
+KEY=70
+NAME=ss_cab0_prsnt
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-1.conf b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-1.conf
new file mode 100644
index 000000000..e6a18ee6c
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-1.conf
@@ -0,0 +1,6 @@
+#The gpio 71 is a real gpio, which is used to
+#store the sas cable 1 present signal
+INVENTORY=/system/chassis/cable/ss_cab1_prsnt
+DEVPATH=/dev/input/event0
+KEY=71
+NAME=ss_cab1_prsnt
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-2.conf b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-2.conf
new file mode 100644
index 000000000..490f97f49
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-2.conf
@@ -0,0 +1,6 @@
+#The gpio 72 is a real gpio, which is used to
+#store the sas cable 2 present signal
+INVENTORY=/system/chassis/cable/ss_cab2_prsnt
+DEVPATH=/dev/input/event0
+KEY=72
+NAME=ss_cab2_prsnt
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-3.conf b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-3.conf
new file mode 100644
index 000000000..f3579ab97
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/obmc/gpio/slimsas-cable-3.conf
@@ -0,0 +1,6 @@
+#The gpio 73 is a real gpio, which is used to
+#store the sas cable 3 present signal
+INVENTORY=/system/chassis/cable/ss_cab3_prsnt
+DEVPATH=/dev/input/event0
+KEY=73
+NAME=ss_cab3_prsnt
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-gpio-presence@.service.replace b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-gpio-presence@.service.replace
new file mode 100644
index 000000000..3ab99702f
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-gpio-presence@.service.replace
@@ -0,0 +1,14 @@
+[Unit]
+Description=Phosphor GPIO %I Presence
+Wants=mapper-wait@-xyz-openbmc_project-inventory.service
+After=mapper-wait@-xyz-openbmc_project-inventory.service
+ConditionPathExists=/etc/default/obmc/gpio/slimsas-cable-%i.conf
+StartLimitBurst=10
+
+[Service]
+Restart=on-failure
+EnvironmentFile=/etc/default/obmc/gpio/slimsas-cable-%i.conf
+ExecStart=/usr/bin/phosphor-gpio-presence --path=${DEVPATH} --inventory=${INVENTORY} --key=${KEY} --name=${NAME} --drivers=${DRIVERS} --extra-ifaces=${EXTRA_IFACES}
+
+[Install]
+RequiredBy=multi-user.target
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
new file mode 100644
index 000000000..50974f7ee
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -0,0 +1,26 @@
+inherit obmc-phosphor-systemd
+
+FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
+
+SRC_URI_append_gbs = " file://phosphor-gpio-presence@.service.replace"
+
+TMPL_SLIMSASCABLE = "phosphor-gpio-presence@.service"
+INSTFMT_SLIMSASCABLE = "phosphor-gpio-presence@{0}.service"
+SLIMSASCABLE_TGT = "multi-user.target"
+FMT_SLIMSASCABLE = "../${TMPL_SLIMSASCABLE}:${SLIMSASCABLE_TGT}.requires/${INSTFMT_SLIMSASCABLE}"
+SYSTEMD_ENVIRONMENT_FILE_${PN}_append_gbs +="obmc/gpio/slimsas-cable-0.conf"
+SYSTEMD_ENVIRONMENT_FILE_${PN}_append_gbs +="obmc/gpio/slimsas-cable-1.conf"
+SYSTEMD_ENVIRONMENT_FILE_${PN}_append_gbs +="obmc/gpio/slimsas-cable-2.conf"
+SYSTEMD_ENVIRONMENT_FILE_${PN}_append_gbs +="obmc/gpio/slimsas-cable-3.conf"
+GBS_OBMC_SLIMSAS_CABLE_INSTANCES = "0 1 2 3"
+
+SYSTEMD_LINK_${PN}-presence_append_gbs = " ${@compose_list(d, 'FMT_SLIMSASCABLE', 'GBS_OBMC_SLIMSAS_CABLE_INSTANCES')}"
+
+GBS_SLIMSASCABLE_ENV_FMT = "obmc/gpio/slimsas-cable-{0}.conf"
+
+SYSTEMD_ENVIRONMENT_FILE_${PN}-presence_gbs = " ${@compose_list(d, 'GBS_SLIMSASCABLE_ENV_FMT', 'GBS_OBMC_SLIMSAS_CABLE_INSTANCES')}"
+
+do_install_append_gbs() {
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/phosphor-gpio-presence@.service.replace ${D}${systemd_system_unitdir}/phosphor-gpio-presence@.service
+}