summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-phosphor/leds
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2020-05-19 15:45:08 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-06-08 22:24:36 +0300
commit493aba63eaabb3171a4ce480ec1c613db41f291a (patch)
tree199a35c1a3ee7e79cc0fca4db1affbe1bd0c0967 /meta-quanta/meta-gbs/recipes-phosphor/leds
parentaf693d535558b655f6ef0d2f2f3d3a1c62b4b65e (diff)
downloadopenbmc-493aba63eaabb3171a4ce480ec1c613db41f291a.tar.xz
meta-quanta: gbs: add LED configuration
Set GBS related LED actions in yaml file 1. heartbeat 2. sys boot status (bios post done) 3. attention (identify) 4. bmc fault (kernel panic) 5. NVME SSD locate/fault (From meta-quanta rev: 745df9caeb360ce80c9edaf27dc5600b6646e31a) Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: I1c506687165b60ac29dd6ae7989ded3a5a20c9a7 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-phosphor/leds')
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/leds/gbs-led-manager-config-native.bb19
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/leds/gbs-led-manager-config/led.yaml239
2 files changed, 258 insertions, 0 deletions
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/leds/gbs-led-manager-config-native.bb b/meta-quanta/meta-gbs/recipes-phosphor/leds/gbs-led-manager-config-native.bb
new file mode 100644
index 000000000..03b562002
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-phosphor/leds/gbs-led-manager-config-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor LED Group Management for GBS"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit native
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+# Overwrite the example led layout yaml file prior
+# to building the phosphor-led-manager package
+do_install() {
+ SRC=${S}
+ DEST=${D}${datadir}/phosphor-led-manager
+ install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/leds/gbs-led-manager-config/led.yaml b/meta-quanta/meta-gbs/recipes-phosphor/leds/gbs-led-manager-config/led.yaml
new file mode 100644
index 000000000..411e0d4c6
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-phosphor/leds/gbs-led-manager-config/led.yaml
@@ -0,0 +1,239 @@
+bmc_booted:
+ heartbeat:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+
+enclosure_identify:
+ attention:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+
+enclosure_fault:
+ bmc_fault:
+ Action: 'On'
+ DutyOn: 50
+ Period: 0
+ Priority: 'Blink'
+
+boot_status_inactive:
+ sys_boot_status:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+
+boot_status_standby:
+ sys_boot_status:
+ Action: 'On'
+ Period: 1000
+
+led_u2_0_locate:
+ led_u2_0_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_0_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_1_locate:
+ led_u2_1_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_1_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_2_locate:
+ led_u2_2_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_2_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_3_locate:
+ led_u2_3_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_3_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_4_locate:
+ led_u2_4_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_4_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_5_locate:
+ led_u2_5_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_5_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_6_locate:
+ led_u2_6_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_6_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_7_locate:
+ led_u2_7_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_7_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_8_locate:
+ led_u2_8_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_8_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_9_locate:
+ led_u2_9_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_9_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_10_locate:
+ led_u2_10_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_10_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_11_locate:
+ led_u2_11_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_11_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_12_locate:
+ led_u2_12_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_12_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_13_locate:
+ led_u2_13_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_13_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_14_locate:
+ led_u2_14_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_14_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+led_u2_15_locate:
+ led_u2_15_locate:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+ led_u2_15_fault:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 250
+
+led_u2_0_fault:
+ led_u2_0_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_1_fault:
+ led_u2_1_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_2_fault:
+ led_u2_2_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_3_fault:
+ led_u2_3_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_4_fault:
+ led_u2_4_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_5_fault:
+ led_u2_5_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_6_fault:
+ led_u2_6_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_7_fault:
+ led_u2_7_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_8_fault:
+ led_u2_8_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_9_fault:
+ led_u2_9_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_10_fault:
+ led_u2_10_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_11_fault:
+ led_u2_11_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_12_fault:
+ led_u2_12_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_13_fault:
+ led_u2_13_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_14_fault:
+ led_u2_14_fault:
+ Action: 'On'
+ Period: 1000
+led_u2_15_fault:
+ led_u2_15_fault:
+ Action: 'On'
+ Period: 1000 \ No newline at end of file