summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp/read-margin-temp-wait.sh
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2020-08-03 11:45:23 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-06 01:09:02 +0300
commit92d58324fe407abaef9d4ffb0989f1d13deedadb (patch)
tree3cf7d3142b6c18f1af352106cc517589171c88d5 /meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp/read-margin-temp-wait.sh
parentbd21fb244289e1f8092c3c594f6be9cc10538b5b (diff)
downloadopenbmc-92d58324fe407abaef9d4ffb0989f1d13deedadb.tar.xz
meta-quanta: gbs: add GBS read-margin-temp config
Since read-margin-temp_git.bb will move to meta-quanta/meta-common, add read-margin-temp bbappend file and move read-margin-temp folder from meta-gbs/recipes-phosphor/fans to meta-gbs/recipes-quanta/fans read-margin-temp_git.bb move to meta-quanta/meta-common: https://gerrit.openbmc-project.xyz/c/openbmc/meta-quanta/+/35277 (From meta-quanta rev: 410c3e900f09aa1f2fee6b155d9987b5510859c6) Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: I79ff42570dc9422e3c2e90dd95c5d29b01ec1133 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp/read-margin-temp-wait.sh')
-rw-r--r--meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp/read-margin-temp-wait.sh26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp/read-margin-temp-wait.sh b/meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp/read-margin-temp-wait.sh
new file mode 100644
index 000000000..2e44479f6
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp/read-margin-temp-wait.sh
@@ -0,0 +1,26 @@
+#!/bin/bash
+
+MARGIN_TABLE_FILE="/usr/share/read-margin-temp/config-margin.json"
+
+target_num="$(cat $MARGIN_TABLE_FILE | grep '"target"' | wc -l)"
+
+cpu_hwmon="$(ls -la /sys/class/hwmon | grep f0082000 | head -n 1 | tail -n +1 | cut -d '/' -f 11)"
+
+# replace by the real cpu temperature hwmon path in runtime
+if [[ "$cpu_hwmon" != "" ]]
+then
+ sed -i "s/cpu_hwmon/$cpu_hwmon/g" $MARGIN_TABLE_FILE
+fi
+
+# wait target dbus
+for ((i=0; i<$target_num; i++))
+do
+ line_num=$((i+1))
+ path="$(cat $MARGIN_TABLE_FILE | grep '"target"' | head -n ${line_num} | tail -n +${line_num} | cut -d '"' -f 4)"
+ mapper wait $path
+done
+
+# start read margin temp
+/usr/bin/read-margin-temp &
+
+exit 0