summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gsj/recipes-gsj/gsj-hotswap-change-setting/gsj-hotswap-change-setting.bb
diff options
context:
space:
mode:
authorWilly Tu <wltu@google.com>2021-08-11 01:33:55 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 20:30:35 +0300
commita38b7ccc3fc59b7375d1f317691e3f753e228e0f (patch)
treec3e5d7d6ac7ef21ca7d33bdc0cf25ed381d4d15b /meta-quanta/meta-gsj/recipes-gsj/gsj-hotswap-change-setting/gsj-hotswap-change-setting.bb
parentb96c75046da8f72359d101c813f0694409bbe0d1 (diff)
downloadopenbmc-a38b7ccc3fc59b7375d1f317691e3f753e228e0f.tar.xz
meta-quanta: meta-gsj: Cleanup for Yocto override syntax change
Cleanup with ``` convert-overrides.py meta-quanta/meta-gsj git grep "_[a-z0-9_/-]*[ :]" -- meta-quanta/meta-gsj git grep -l _gsj -- meta-quanta/meta-gsj \ | xargs sed -i 's/_gsj/:gsj/' ``` Note: Need to revert the change to BBFILE_PATTERN and LAYERSERIES_COMPAT. After cleanup ``` $ git grep "_[a-z0-9_/-]*[ :]" -- meta-quanta/meta-gsj/ | grep '.bb' meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend:do_install:append:gsj () { meta-quanta/meta-gsj/recipes-google/ipmi/google-ipmi-sys_%.bbappend:do_install:append:gsj() { meta-quanta/meta-gsj/recipes-gsj/detect-fan-fail/detect-fan-fail.bb:do_install:append:gsj() { meta-quanta/meta-gsj/recipes-gsj/quanta-nvme-powerctrl/quanta-nvme-powerctrl.bb:do_install () { meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend:do_install:append:gsj() { meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend:do_install:append:gsj() { ``` Change-Id: I058371ed32214d665aaaf616a650c2efeaf5be66 Signed-off-by: Willy Tu <wltu@google.com>
Diffstat (limited to 'meta-quanta/meta-gsj/recipes-gsj/gsj-hotswap-change-setting/gsj-hotswap-change-setting.bb')
-rw-r--r--meta-quanta/meta-gsj/recipes-gsj/gsj-hotswap-change-setting/gsj-hotswap-change-setting.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-quanta/meta-gsj/recipes-gsj/gsj-hotswap-change-setting/gsj-hotswap-change-setting.bb b/meta-quanta/meta-gsj/recipes-gsj/gsj-hotswap-change-setting/gsj-hotswap-change-setting.bb
index f9d9a9e47..d88b9a2f1 100644
--- a/meta-quanta/meta-gsj/recipes-gsj/gsj-hotswap-change-setting/gsj-hotswap-change-setting.bb
+++ b/meta-quanta/meta-gsj/recipes-gsj/gsj-hotswap-change-setting/gsj-hotswap-change-setting.bb
@@ -7,10 +7,10 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit systemd
DEPENDS += "systemd"
-RDEPENDS_${PN} += "bash"
+RDEPENDS:${PN} += "bash"
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI_append = " file://gsj-hotswap-change-setting.sh \
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+SRC_URI:append = " file://gsj-hotswap-change-setting.sh \
file://gsj-hotswap-change-setting.service \
"
@@ -23,4 +23,4 @@ do_install() {
}
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "gsj-hotswap-change-setting.service"
+SYSTEMD_SERVICE:${PN} = "gsj-hotswap-change-setting.service"