summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
diff options
context:
space:
mode:
authorHank Liou <Hank.Liou@quantatw.com>2019-07-17 04:57:48 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-19 23:27:50 +0300
commit38e869d755a5387e563c9b286a6b3ab8e925efbe (patch)
tree04b133256743ba1c42bdf2dc72f762ff7e77740a /meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
parenta8ee8ba0cbb8a14a0d72e97b7c135bb70f5f6bfb (diff)
downloadopenbmc-38e869d755a5387e563c9b286a6b3ab8e925efbe.tar.xz
meta-quanta: gsj: Lower fan speed to default duty as booting and rebooting
The fan speed is lowered to 90 duty for thermal issue. (From meta-quanta rev: 39041e2fa1e5b816c09925411081acc30010f782) Signed-off-by: Hank Liou <Hank.Liou@quantatw.com> Change-Id: I5a14320a3687326e710976f8bab9bfa65f3b2865 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend')
-rw-r--r--meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend12
1 files changed, 8 insertions, 4 deletions
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
index 68d6dd454..13d037e41 100644
--- a/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
+++ b/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -2,25 +2,27 @@ FILESEXTRAPATHS_prepend_gsj := "${THISDIR}/${PN}:"
SRC_URI_append_gsj = " file://config-8ssd.json"
SRC_URI_append_gsj = " file://config-2ssd.json"
SRC_URI_append_gsj = " file://fan-control.sh"
-SRC_URI_append_gsj = " file://fan-full-speed.sh"
+SRC_URI_append_gsj = " file://fan-default-speed.sh"
SRC_URI_append_gsj = " file://phosphor-pid-control.service"
SRC_URI_append_gsj = " file://fan-reboot-control.service"
+SRC_URI_append_gsj = " file://fan-boot-control.service"
FILES_${PN}_append_gsj = " ${datadir}/swampd/config-8ssd.json"
FILES_${PN}_append_gsj = " ${datadir}/swampd/config-2ssd.json"
FILES_${PN}_append_gsj = " ${bindir}/fan-control.sh"
-FILES_${PN}_append_gsj = " ${bindir}/fan-full-speed.sh"
+FILES_${PN}_append_gsj = " ${bindir}/fan-default-speed.sh"
inherit systemd
RDEPENDS_${PN} += "bash"
SYSTEMD_SERVICE_${PN}_append_gsj = " phosphor-pid-control.service"
SYSTEMD_SERVICE_${PN}_append_gsj = " fan-reboot-control.service"
+SYSTEMD_SERVICE_${PN}_append_gsj = " fan-boot-control.service"
do_install_append_gsj() {
install -d ${D}/${bindir}
install -m 0755 ${WORKDIR}/fan-control.sh ${D}/${bindir}
- install -m 0755 ${WORKDIR}/fan-full-speed.sh ${D}/${bindir}
+ install -m 0755 ${WORKDIR}/fan-default-speed.sh ${D}/${bindir}
install -d ${D}${datadir}/swampd
install -m 0644 -D ${WORKDIR}/config-8ssd.json \
@@ -33,4 +35,6 @@ do_install_append_gsj() {
${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/fan-reboot-control.service \
${D}${systemd_unitdir}/system
-} \ No newline at end of file
+ install -m 0644 ${WORKDIR}/fan-boot-control.service \
+ ${D}${systemd_unitdir}/system
+}