summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
diff options
context:
space:
mode:
authorWilly Tu <wltu@google.com>2021-08-11 01:33:55 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 20:30:35 +0300
commita38b7ccc3fc59b7375d1f317691e3f753e228e0f (patch)
treec3e5d7d6ac7ef21ca7d33bdc0cf25ed381d4d15b /meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
parentb96c75046da8f72359d101c813f0694409bbe0d1 (diff)
downloadopenbmc-a38b7ccc3fc59b7375d1f317691e3f753e228e0f.tar.xz
meta-quanta: meta-gsj: Cleanup for Yocto override syntax change
Cleanup with ``` convert-overrides.py meta-quanta/meta-gsj git grep "_[a-z0-9_/-]*[ :]" -- meta-quanta/meta-gsj git grep -l _gsj -- meta-quanta/meta-gsj \ | xargs sed -i 's/_gsj/:gsj/' ``` Note: Need to revert the change to BBFILE_PATTERN and LAYERSERIES_COMPAT. After cleanup ``` $ git grep "_[a-z0-9_/-]*[ :]" -- meta-quanta/meta-gsj/ | grep '.bb' meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend:do_install:append:gsj () { meta-quanta/meta-gsj/recipes-google/ipmi/google-ipmi-sys_%.bbappend:do_install:append:gsj() { meta-quanta/meta-gsj/recipes-gsj/detect-fan-fail/detect-fan-fail.bb:do_install:append:gsj() { meta-quanta/meta-gsj/recipes-gsj/quanta-nvme-powerctrl/quanta-nvme-powerctrl.bb:do_install () { meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend:do_install:append:gsj() { meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend:do_install:append:gsj() { ``` Change-Id: I058371ed32214d665aaaf616a650c2efeaf5be66 Signed-off-by: Willy Tu <wltu@google.com>
Diffstat (limited to 'meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend')
-rw-r--r--meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend34
1 files changed, 17 insertions, 17 deletions
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
index 13d037e41..1160fcfc6 100644
--- a/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
+++ b/meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -1,25 +1,25 @@
-FILESEXTRAPATHS_prepend_gsj := "${THISDIR}/${PN}:"
-SRC_URI_append_gsj = " file://config-8ssd.json"
-SRC_URI_append_gsj = " file://config-2ssd.json"
-SRC_URI_append_gsj = " file://fan-control.sh"
-SRC_URI_append_gsj = " file://fan-default-speed.sh"
-SRC_URI_append_gsj = " file://phosphor-pid-control.service"
-SRC_URI_append_gsj = " file://fan-reboot-control.service"
-SRC_URI_append_gsj = " file://fan-boot-control.service"
+FILESEXTRAPATHS:prepend:gsj := "${THISDIR}/${PN}:"
+SRC_URI:append:gsj = " file://config-8ssd.json"
+SRC_URI:append:gsj = " file://config-2ssd.json"
+SRC_URI:append:gsj = " file://fan-control.sh"
+SRC_URI:append:gsj = " file://fan-default-speed.sh"
+SRC_URI:append:gsj = " file://phosphor-pid-control.service"
+SRC_URI:append:gsj = " file://fan-reboot-control.service"
+SRC_URI:append:gsj = " file://fan-boot-control.service"
-FILES_${PN}_append_gsj = " ${datadir}/swampd/config-8ssd.json"
-FILES_${PN}_append_gsj = " ${datadir}/swampd/config-2ssd.json"
-FILES_${PN}_append_gsj = " ${bindir}/fan-control.sh"
-FILES_${PN}_append_gsj = " ${bindir}/fan-default-speed.sh"
+FILES:${PN}:append:gsj = " ${datadir}/swampd/config-8ssd.json"
+FILES:${PN}:append:gsj = " ${datadir}/swampd/config-2ssd.json"
+FILES:${PN}:append:gsj = " ${bindir}/fan-control.sh"
+FILES:${PN}:append:gsj = " ${bindir}/fan-default-speed.sh"
inherit systemd
-RDEPENDS_${PN} += "bash"
+RDEPENDS:${PN} += "bash"
-SYSTEMD_SERVICE_${PN}_append_gsj = " phosphor-pid-control.service"
-SYSTEMD_SERVICE_${PN}_append_gsj = " fan-reboot-control.service"
-SYSTEMD_SERVICE_${PN}_append_gsj = " fan-boot-control.service"
+SYSTEMD_SERVICE:${PN}:append:gsj = " phosphor-pid-control.service"
+SYSTEMD_SERVICE:${PN}:append:gsj = " fan-reboot-control.service"
+SYSTEMD_SERVICE:${PN}:append:gsj = " fan-boot-control.service"
-do_install_append_gsj() {
+do_install:append:gsj() {
install -d ${D}/${bindir}
install -m 0755 ${WORKDIR}/fan-control.sh ${D}/${bindir}
install -m 0755 ${WORKDIR}/fan-default-speed.sh ${D}/${bindir}