summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gsj/recipes-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-09-02 00:17:33 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-09-02 16:19:25 +0300
commite83c22094b7e4970c96bcee273ab08d05bbc0a30 (patch)
tree80cb87a34afb07b7d375b534bb5df68468c2b5a6 /meta-quanta/meta-gsj/recipes-phosphor
parentd97cf9b9ef84cdad2f357164e36b76619e7dc379 (diff)
downloadopenbmc-e83c22094b7e4970c96bcee273ab08d05bbc0a30.tar.xz
meta-phosphor: change systemd.bbclass to match upstream override syntax
Upstream bbclasses changed to typically use the `:${PN}` override syntax, including the SYSTEMD_ variables. Change our systemd.bbclass to do the same for consistency and perform a tree-wide variable replacement. Spot checked by building bletchley and witherspoon and checking some of the SYSTEMD_LINK directives on installed packages under qemu. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I20a9dd809bff8af8759488734f80486c7228c6eb
Diffstat (limited to 'meta-quanta/meta-gsj/recipes-phosphor')
-rw-r--r--meta-quanta/meta-gsj/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend4
-rw-r--r--meta-quanta/meta-gsj/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
index 2fb5443fb..d8e2cb14e 100644
--- a/meta-quanta/meta-gsj/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
+++ b/meta-quanta/meta-gsj/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
@@ -10,11 +10,11 @@ EEPROMS = "${@compose_list(d, 'EEPROMFMT', 'EEPROM_NAMES')}"
EEPROMS_ESCAPED = "${@compose_list(d, 'EEPROM_ESCAPEDFMT', 'EEPROM_NAMES')}"
ENVFMT = "obmc/eeproms/{0}"
-SYSTEMD_ENVIRONMENT_FILE_${PN}:append:gsj := " ${@compose_list(d, 'ENVFMT', 'EEPROMS')}"
+SYSTEMD_ENVIRONMENT_FILE:${PN}:append:gsj := " ${@compose_list(d, 'ENVFMT', 'EEPROMS')}"
TMPL = "obmc-read-eeprom@.service"
TGT = "multi-user.target"
INSTFMT = "obmc-read-eeprom@{0}.service"
FMT = "../${TMPL}:${TGT}.wants/${INSTFMT}"
-SYSTEMD_LINK_${PN}:append:gsj := " ${@compose_list(d, 'FMT', 'EEPROMS_ESCAPED')}"
+SYSTEMD_LINK:${PN}:append:gsj := " ${@compose_list(d, 'FMT', 'EEPROMS_ESCAPED')}"
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend b/meta-quanta/meta-gsj/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
index 4363aa352..a27865239 100644
--- a/meta-quanta/meta-gsj/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
+++ b/meta-quanta/meta-gsj/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
@@ -15,9 +15,9 @@ ITEMSFMT = "ahb/apb/{0}.conf"
ITEMS += "${@compose_list(d, 'ITEMSFMT', 'NAMES')}"
ENVS = "obmc/hwmon/{0}"
-SYSTEMD_ENVIRONMENT_FILE_${PN}:append:gsj = " ${@compose_list(d, 'ENVS', 'ITEMS')}"
+SYSTEMD_ENVIRONMENT_FILE:${PN}:append:gsj = " ${@compose_list(d, 'ENVS', 'ITEMS')}"
# Fan sensors
FITEMS = "pwm-fan-controller@103000.conf"
FENVS = "obmc/hwmon/ahb/apb/{0}"
-SYSTEMD_ENVIRONMENT_FILE_${PN}:append:gsj = " ${@compose_list(d, 'FENVS', 'FITEMS')}"
+SYSTEMD_ENVIRONMENT_FILE:${PN}:append:gsj = " ${@compose_list(d, 'FENVS', 'FITEMS')}"