summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gsj/recipes-quanta
diff options
context:
space:
mode:
authorWilly Tu <wltu@google.com>2021-08-11 01:33:55 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 20:30:35 +0300
commita38b7ccc3fc59b7375d1f317691e3f753e228e0f (patch)
treec3e5d7d6ac7ef21ca7d33bdc0cf25ed381d4d15b /meta-quanta/meta-gsj/recipes-quanta
parentb96c75046da8f72359d101c813f0694409bbe0d1 (diff)
downloadopenbmc-a38b7ccc3fc59b7375d1f317691e3f753e228e0f.tar.xz
meta-quanta: meta-gsj: Cleanup for Yocto override syntax change
Cleanup with ``` convert-overrides.py meta-quanta/meta-gsj git grep "_[a-z0-9_/-]*[ :]" -- meta-quanta/meta-gsj git grep -l _gsj -- meta-quanta/meta-gsj \ | xargs sed -i 's/_gsj/:gsj/' ``` Note: Need to revert the change to BBFILE_PATTERN and LAYERSERIES_COMPAT. After cleanup ``` $ git grep "_[a-z0-9_/-]*[ :]" -- meta-quanta/meta-gsj/ | grep '.bb' meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend:do_install:append:gsj () { meta-quanta/meta-gsj/recipes-google/ipmi/google-ipmi-sys_%.bbappend:do_install:append:gsj() { meta-quanta/meta-gsj/recipes-gsj/detect-fan-fail/detect-fan-fail.bb:do_install:append:gsj() { meta-quanta/meta-gsj/recipes-gsj/quanta-nvme-powerctrl/quanta-nvme-powerctrl.bb:do_install () { meta-quanta/meta-gsj/recipes-phosphor/fans/phosphor-pid-control_%.bbappend:do_install:append:gsj() { meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend:do_install:append:gsj() { ``` Change-Id: I058371ed32214d665aaaf616a650c2efeaf5be66 Signed-off-by: Willy Tu <wltu@google.com>
Diffstat (limited to 'meta-quanta/meta-gsj/recipes-quanta')
-rw-r--r--meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend b/meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend
index a90150b3d..3b1ee1744 100644
--- a/meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend
+++ b/meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend
@@ -1,9 +1,9 @@
-FILESEXTRAPATHS_prepend_gsj := "${THISDIR}/${PN}:"
-SRC_URI_append_gsj = " file://config.txt"
+FILESEXTRAPATHS:prepend:gsj := "${THISDIR}/${PN}:"
+SRC_URI:append:gsj = " file://config.txt"
-FILES_${PN}_append_gsj = " ${datadir}/mac-address/config.txt"
+FILES:${PN}:append:gsj = " ${datadir}/mac-address/config.txt"
-do_install_append_gsj() {
+do_install:append:gsj() {
install -d ${D}${datadir}/mac-address
install -m 0644 -D ${WORKDIR}/config.txt \
${D}${datadir}/mac-address/config.txt