summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gsj
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-06-25 18:34:41 +0300
committerGitHub <noreply@github.com>2021-06-25 18:34:41 +0300
commitc6b1c6ba7a01b7987d65d61c262c44c320193108 (patch)
treec31fba338a65c86741b16e061d66e0e060e3b768 /meta-quanta/meta-gsj
parente7436234669703196c5ed56f33050d2dc19127cd (diff)
parentdefdca82c107f46e980c84bffb1b2c1263522fa0 (diff)
downloadopenbmc-c6b1c6ba7a01b7987d65d61c262c44c320193108.tar.xz
Merge pull request #68 from Intel-BMC/update2021-0.571-0.57
Update
Diffstat (limited to 'meta-quanta/meta-gsj')
-rw-r--r--meta-quanta/meta-gsj/recipes-gsj/mac-address/files/mac-address.service11
-rw-r--r--meta-quanta/meta-gsj/recipes-gsj/mac-address/mac-address.bb34
-rw-r--r--meta-quanta/meta-gsj/recipes-phosphor/network/phosphor-network_%.bbappend1
-rw-r--r--meta-quanta/meta-gsj/recipes-quanta/network/mac-address/mac-address/config.txt (renamed from meta-quanta/meta-gsj/recipes-gsj/mac-address/files/config.txt)0
-rw-r--r--meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend10
5 files changed, 10 insertions, 46 deletions
diff --git a/meta-quanta/meta-gsj/recipes-gsj/mac-address/files/mac-address.service b/meta-quanta/meta-gsj/recipes-gsj/mac-address/files/mac-address.service
deleted file mode 100644
index e18d69493..000000000
--- a/meta-quanta/meta-gsj/recipes-gsj/mac-address/files/mac-address.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Initialize MAC Address
-Before=usb_network.service network-pre.target
-Wants=network-pre.target
-
-[Service]
-Type=oneshot
-ExecStart=/usr/bin/mac-address
-
-[Install]
-WantedBy=multi-user.target \ No newline at end of file
diff --git a/meta-quanta/meta-gsj/recipes-gsj/mac-address/mac-address.bb b/meta-quanta/meta-gsj/recipes-gsj/mac-address/mac-address.bb
deleted file mode 100644
index d9fda7ccb..000000000
--- a/meta-quanta/meta-gsj/recipes-gsj/mac-address/mac-address.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-SRC_URI = "git://github.com/quanta-bmc/mac-address.git;protocol=git"
-SRCREV = "${AUTOREV}"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit autotools pkgconfig
-inherit systemd
-
-DEPENDS += "systemd"
-DEPENDS += "autoconf-archive-native"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI_append = " file://mac-address.service"
-SRC_URI_append = " file://config.txt"
-
-FILES_${PN}_append = " ${datadir}/mac-address/config.txt"
-
-HASHSTYLE = "gnu"
-S = "${WORKDIR}/git"
-CXXFLAGS += "-std=c++17"
-
-do_install_append() {
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/mac-address.service \
- ${D}${systemd_unitdir}/system
-
- install -d ${D}${datadir}/mac-address
- install -m 0644 -D ${WORKDIR}/config.txt \
- ${D}${datadir}/mac-address/config.txt
-}
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} += "mac-address.service"
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/network/phosphor-network_%.bbappend b/meta-quanta/meta-gsj/recipes-phosphor/network/phosphor-network_%.bbappend
deleted file mode 100644
index 730c62d5f..000000000
--- a/meta-quanta/meta-gsj/recipes-phosphor/network/phosphor-network_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-EXTRA_OECONF_gsj += " --disable-link-local-autoconfiguration"
diff --git a/meta-quanta/meta-gsj/recipes-gsj/mac-address/files/config.txt b/meta-quanta/meta-gsj/recipes-quanta/network/mac-address/mac-address/config.txt
index 668b1d485..668b1d485 100644
--- a/meta-quanta/meta-gsj/recipes-gsj/mac-address/files/config.txt
+++ b/meta-quanta/meta-gsj/recipes-quanta/network/mac-address/mac-address/config.txt
diff --git a/meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend b/meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend
new file mode 100644
index 000000000..a90150b3d
--- /dev/null
+++ b/meta-quanta/meta-gsj/recipes-quanta/network/mac-address_%.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS_prepend_gsj := "${THISDIR}/${PN}:"
+SRC_URI_append_gsj = " file://config.txt"
+
+FILES_${PN}_append_gsj = " ${datadir}/mac-address/config.txt"
+
+do_install_append_gsj() {
+ install -d ${D}${datadir}/mac-address
+ install -m 0644 -D ${WORKDIR}/config.txt \
+ ${D}${datadir}/mac-address/config.txt
+}