summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-olympus-nuvoton/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorSamuel Jiang <Samuel.Jiang@quantatw.com>2019-10-18 03:56:58 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-11-18 22:12:20 +0300
commitaa2b3f294df9126d5b6044e7a6e1b64514974a16 (patch)
tree317cc3359a34d76e6f0791f66996941f3b31b065 /meta-quanta/meta-olympus-nuvoton/recipes-bsp/u-boot
parent782fc3530aa3f0f0efbf2217841956c3f301767d (diff)
downloadopenbmc-aa2b3f294df9126d5b6044e7a6e1b64514974a16.tar.xz
meta-quanta: meta-runbmc-nuvoton: rename meta-olympus-nuvoton
For avoid confusing this layer only with RUNBMC module (https://www.opencompute.org/documents/ocp-runbmc-daughterboard-card- design-specification-v1-4-1-pdf) The meta-runbmc-nuvoton will rename meta-olympus-nuvoton. That means the Quanta Olympus product with RUNBMC module which based on Nuvoton SoC. The layer configuration will binding Olympus product hardware design. (From meta-quanta rev: f4a8e7ae48dc788fa7e52f024578c67f164c8620) Change-Id: I6faa1bfbb3b8f033239fea3c41e8b8ed18fc492d Signed-off-by: Samuel Jiang <Samuel.Jiang@quantatw.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-quanta/meta-olympus-nuvoton/recipes-bsp/u-boot')
-rw-r--r--meta-quanta/meta-olympus-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton/fw_env.config24
-rw-r--r--meta-quanta/meta-olympus-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend7
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-quanta/meta-olympus-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton/fw_env.config b/meta-quanta/meta-olympus-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton/fw_env.config
new file mode 100644
index 000000000..0c384273f
--- /dev/null
+++ b/meta-quanta/meta-olympus-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton/fw_env.config
@@ -0,0 +1,24 @@
+# Configuration file for fw_(printenv/setenv) utility.
+# Up to two entries are valid, in this case the redundant
+# environment sector is assumed present.
+# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
+# Futhermore, if the Flash sector size is ommitted, this value is assumed to
+# be the same as the Environment size, which is valid for NOR and SPI-dataflash
+
+# NOR example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+/dev/mtd2 0x0000 0x40000 0x4000
+
+# MTD SPI-dataflash example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+#/dev/mtd5 0x4200 0x4200
+#/dev/mtd6 0x4200 0x4200
+
+# NAND example
+#/dev/mtd0 0x4000 0x4000 0x20000 2
+
+# Block device example
+#/dev/mmcblk0 0xc0000 0x20000
+
+# VFAT example
+#/boot/uboot.env 0x0000 0x4000
diff --git a/meta-quanta/meta-olympus-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend b/meta-quanta/meta-olympus-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend
new file mode 100644
index 000000000..91518decf
--- /dev/null
+++ b/meta-quanta/meta-olympus-nuvoton/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://fw_env.config"
+
+do_install_append () {
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+}