summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-q71l/recipes-phosphor/ipmi
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-23 04:40:54 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-23 19:39:42 +0300
commit194ff4f1f5d44b12e9cb06ddafa6adb20174a13c (patch)
tree823835cd29daf8901a31ac14c7e6534abf199be3 /meta-quanta/meta-q71l/recipes-phosphor/ipmi
parent4feb727cd6b77a68bdaca63e121b378d814f5eaf (diff)
downloadopenbmc-194ff4f1f5d44b12e9cb06ddafa6adb20174a13c.tar.xz
[Subtree] Bring openbmc machines to top level
The new subtree model brings the subtrees up from the openbmc-machines layer. Change-Id: I58a03ae1be374bc79ae1438e65e888375d12d0c0 Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-quanta/meta-q71l/recipes-phosphor/ipmi')
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%.bbappend20
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/bmc2
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/fp2
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/motherboard2
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/pdb2
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-channel-config-native.bb18
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-channel-config/channel.yaml5
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-fru-merge-config-native.bb14
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-inventory-map-native.bb19
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-inventory-map/config.yaml202
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-sensor-map-native.bb18
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-sensor-map/config.yaml523
12 files changed, 827 insertions, 0 deletions
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%.bbappend b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%.bbappend
new file mode 100644
index 000000000..f50949720
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%.bbappend
@@ -0,0 +1,20 @@
+inherit obmc-phosphor-systemd
+
+FILESEXTRAPATHS_prepend_quanta-q71l := "${THISDIR}/${PN}:"
+
+EEPROM_NAMES = "motherboard pdb fp bmc"
+
+EEPROMFMT = "system/chassis/{0}"
+EEPROM_ESCAPEDFMT = "system-chassis-{0}"
+EEPROMS = "${@compose_list(d, 'EEPROMFMT', 'EEPROM_NAMES')}"
+EEPROMS_ESCAPED = "${@compose_list(d, 'EEPROM_ESCAPEDFMT', 'EEPROM_NAMES')}"
+
+ENVFMT = "obmc/eeproms/{0}"
+SYSTEMD_ENVIRONMENT_FILE_${PN}_append_quanta-q71l := " ${@compose_list(d, 'ENVFMT', 'EEPROMS')}"
+
+TMPL = "obmc-read-eeprom@.service"
+TGT = "${SYSTEMD_DEFAULT_TARGET}"
+INSTFMT = "obmc-read-eeprom@{0}.service"
+FMT = "../${TMPL}:${TGT}.wants/${INSTFMT}"
+
+SYSTEMD_LINK_${PN}_append_quanta-q71l := " ${@compose_list(d, 'FMT', 'EEPROMS_ESCAPED')}"
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/bmc b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/bmc
new file mode 100644
index 000000000..04040806b
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/bmc
@@ -0,0 +1,2 @@
+SYSFS_PATH=/sys/bus/i2c/devices/8-0050/eeprom
+FRUID=50
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/fp b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/fp
new file mode 100644
index 000000000..32e3ef7b8
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/fp
@@ -0,0 +1,2 @@
+SYSFS_PATH=/sys/bus/i2c/devices/1-0057/eeprom
+FRUID=57
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/motherboard b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/motherboard
new file mode 100644
index 000000000..b01390ae9
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/motherboard
@@ -0,0 +1,2 @@
+SYSFS_PATH=/sys/bus/i2c/devices/1-0054/eeprom
+FRUID=56
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/pdb b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/pdb
new file mode 100644
index 000000000..a08392130
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/phosphor-ipmi-fru%/obmc/eeproms/system/chassis/pdb
@@ -0,0 +1,2 @@
+SYSFS_PATH=/sys/bus/i2c/devices/7-0052/eeprom
+FRUID=52
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-channel-config-native.bb b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-channel-config-native.bb
new file mode 100644
index 000000000..6eae84570
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-channel-config-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Quanta Q71l IPMI Channel to if_name mapping."
+PR = "r1"
+
+inherit native
+inherit phosphor-ipmi-host
+inherit obmc-phosphor-license
+
+PROVIDES += "virtual/phosphor-ipmi-channel-config"
+
+SRC_URI += "file://channel.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${sensor_datadir}
+ install -d ${DEST}
+ install channel.yaml ${DEST}/channel.yaml
+}
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-channel-config/channel.yaml b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-channel-config/channel.yaml
new file mode 100644
index 000000000..3cc2cd242
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-channel-config/channel.yaml
@@ -0,0 +1,5 @@
+1:
+ ifName: eth0
+2:
+ ifName: eth1
+
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-fru-merge-config-native.bb b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-fru-merge-config-native.bb
new file mode 100644
index 000000000..330cda177
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-fru-merge-config-native.bb
@@ -0,0 +1,14 @@
+inherit native
+inherit obmc-phosphor-license
+
+DEPENDS += "virtual/phosphor-ipmi-fru-inventory"
+PROVIDES += "virtual/phosphor-ipmi-fru-merge-config"
+
+# Put the fru_config in the right place with the right name.
+# Pull the IPMI FRU YAML config to use it in the IPMI HOST YAML.
+do_install_append() {
+ IPMI_FRU_SRC=${datadir}/phosphor-ipmi-fru/config
+ IPMI_HOST_DEST=${D}${datadir}/phosphor-ipmi-host/config
+ install -d ${IPMI_HOST_DEST}
+ cat ${IPMI_FRU_SRC}/config.yaml > ${IPMI_HOST_DEST}/fru_config.yaml
+}
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-inventory-map-native.bb b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-inventory-map-native.bb
new file mode 100644
index 000000000..93706f3e3
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-inventory-map-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Quanta-Q71l IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${config_datadir}
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-inventory-map/config.yaml b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-inventory-map/config.yaml
new file mode 100644
index 000000000..87295213b
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-inventory-map/config.yaml
@@ -0,0 +1,202 @@
+0x56:
+ /system/chassis/motherboard:
+ entityID: 7
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ /system:
+ entityID: 23
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Chassis
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Chassis
+ Model:
+ IPMIFruProperty: Type
+ IPMIFruSection: Chassis
+
+0x50:
+ /system/chassis/motherboard/bmc:
+ entityID: 6
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Decorator.Revision:
+ Version:
+ IPMIFruProperty: FRU File ID
+ IPMIFruSection: Board
+
+0x52:
+ /system/chassis/pdb:
+ entityID: 21
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ Model:
+ IPMIFruProperty: Model Number
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Decorator.Revision:
+ Version:
+ IPMIFruProperty: FRU File ID
+ IPMIFruSection: Board
+
+0x57:
+ /system/chassis/fp:
+ entityID: 2
+ entityInstance: 1
+ interfaces:
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ Model:
+ IPMIFruProperty: Model Number
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Decorator.Revision:
+ Version:
+ IPMIFruProperty: FRU File ID
+ IPMIFruSection: Board
+
+0x20:
+ /system/chassis/motherboard/mezzanine8/memory_riser:
+ entityID: 8
+ entityInstance: 1
+ interfaces: &riser
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ Model:
+ IPMIFruProperty: Model Number
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Decorator.Revision:
+ Version:
+ IPMIFruProperty: FRU File ID
+ IPMIFruSection: Board
+
+0x21:
+ /system/chassis/motherboard/mezzanine7/memory_riser:
+ entityID: 8
+ entityInstance: 2
+ interfaces:
+ <<: *riser
+
+0x22:
+ /system/chassis/motherboard/mezzanine6/memory_riser:
+ entityID: 8
+ entityInstance: 3
+ interfaces:
+ <<: *riser
+
+0x23:
+ /system/chassis/motherboard/mezzanine5/memory_riser:
+ entityID: 8
+ entityInstance: 4
+ interfaces:
+ <<: *riser
+
+0x24:
+ /system/chassis/motherboard/mezzanine4/memory_riser:
+ entityID: 8
+ entityInstance: 5
+ interfaces:
+ <<: *riser
+
+0x25:
+ /system/chassis/motherboard/mezzanine3/memory_riser:
+ entityID: 8
+ entityInstance: 6
+ interfaces:
+ <<: *riser
+
+0x26:
+ /system/chassis/motherboard/mezzanine2/memory_riser:
+ entityID: 8
+ entityInstance: 7
+ interfaces:
+ <<: *riser
+
+0x27:
+ /system/chassis/motherboard/mezzanine1/memory_riser:
+ entityID: 8
+ entityInstance: 8
+ interfaces:
+ <<: *riser
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-sensor-map-native.bb b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-sensor-map-native.bb
new file mode 100644
index 000000000..951a55fb7
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-sensor-map-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Quanta Q71l IPMI to DBus Sensor mapping."
+PR = "r1"
+
+inherit native
+inherit phosphor-ipmi-host
+inherit obmc-phosphor-license
+
+PROVIDES += "virtual/phosphor-ipmi-sensor-inventory"
+
+SRC_URI += "file://config.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${sensor_datadir}
+ install -d ${DEST}
+ install config.yaml ${DEST}/sensor.yaml
+}
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-sensor-map/config.yaml b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-sensor-map/config.yaml
new file mode 100644
index 000000000..fb0ccfcbc
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/ipmi/q71l-ipmi-sensor-map/config.yaml
@@ -0,0 +1,523 @@
+0xD0:
+ sensorType: 0x01
+ path: /xyz/openbmc_project/extsensors/margin/fleeting0
+ sensorReadingType: 0x01
+ multiplierM: 511
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ scale: -3
+ mutability: Mutability::Write|Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0xFF:
+ type: int64_t
+
+0xF0:
+ sensorType: 0x01
+ path: /xyz/openbmc_project/sensors/temperature/temp2_inlet
+ sensorReadingType: 0x01
+ multiplierM: 511
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xF1:
+ sensorType: 0x01
+ path: /xyz/openbmc_project/sensors/temperature/temp1
+ sensorReadingType: 0x01
+ multiplierM: 511
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xF2:
+ sensorType: 0x01
+ path: /xyz/openbmc_project/sensors/temperature/temp3
+ sensorReadingType: 0x01
+ multiplierM: 511
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.DegreesC
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xB0:
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/fan1
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xC0:
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/fan1
+ sensorReadingType: 0x01
+ multiplierM: 1
+ offsetB: 0
+ bExp: 0
+ mutability: Mutability::Write
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Control.FanPwm:
+ Target:
+ Offsets:
+ 0xFF:
+ type: uint64_t
+
+0xB1:
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/fan2
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xC1:
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/fan2
+ sensorReadingType: 0x01
+ multiplierM: 1
+ offsetB: 0
+ bExp: 0
+ mutability: Mutability::Write
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Control.FanPwm:
+ Target:
+ Offsets:
+ 0xFF:
+ type: uint64_t
+
+0xB2:
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/fan3
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xC2:
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/fan3
+ sensorReadingType: 0x01
+ multiplierM: 1
+ offsetB: 0
+ bExp: 0
+ mutability: Mutability::Write
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Control.FanPwm:
+ Target:
+ Offsets:
+ 0xFF:
+ type: uint64_t
+
+0xB3:
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/fan4
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xC3:
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/fan4
+ sensorReadingType: 0x01
+ multiplierM: 1
+ offsetB: 0
+ bExp: 0
+ mutability: Mutability::Write
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Control.FanPwm:
+ Target:
+ Offsets:
+ 0xFF:
+ type: uint64_t
+
+0xB4:
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/fan5
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xB5:
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/fan6
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xB6:
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/fan7
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xB7:
+ sensorType: 0x04
+ path: /xyz/openbmc_project/sensors/fan_tach/fan8
+ sensorReadingType: 0x01
+ multiplierM: 100
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.RPMS
+ scale: 0
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xE0:
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/p3v3_scaled
+ sensorReadingType: 0x01
+ multiplierM: 64
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xE1:
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/p5v_scaled
+ sensorReadingType: 0x01
+ multiplierM: 64
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xE2:
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/p12v_aux_scaled
+ sensorReadingType: 0x01
+ multiplierM: 64
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xE3:
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/p1v1_ssb
+ sensorReadingType: 0x01
+ multiplierM: 64
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xE4:
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/pvcc_cpu0
+ sensorReadingType: 0x01
+ multiplierM: 64
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xE5:
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/pvcc_cpu1
+ sensorReadingType: 0x01
+ multiplierM: 64
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xE6:
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/p3v3_aux_scaled
+ sensorReadingType: 0x01
+ multiplierM: 64
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xE7:
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/p5v_aux_scaled
+ sensorReadingType: 0x01
+ multiplierM: 64
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xE8:
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/pvcc_cpu2
+ sensorReadingType: 0x01
+ multiplierM: 64
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xE9:
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/pvcc_cpu3
+ sensorReadingType: 0x01
+ multiplierM: 64
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xEA:
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/p12v_scaled
+ sensorReadingType: 0x01
+ multiplierM: 64
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t
+
+0xEB:
+ sensorType: 0x02
+ path: /xyz/openbmc_project/sensors/voltage/p3v_vbat
+ sensorReadingType: 0x01
+ multiplierM: 64
+ offsetB: 0
+ bExp: 0
+ unit: xyz.openbmc_project.Sensor.Value.Unit.Volts
+ scale: -3
+ mutability: Mutability::Read
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: readingData
+ interfaces:
+ xyz.openbmc_project.Sensor.Value:
+ Value:
+ Offsets:
+ 0x0:
+ type: int64_t