summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-q71l
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2019-05-09 19:34:18 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-09 23:52:21 +0300
commitf191bfb98753adbf617124f58c726a2ccc288a3c (patch)
treed89944d5f394074d6ef26a826132e1f7577dc08f /meta-quanta/meta-q71l
parent12c92b6f18277ca434e49cb1e9544659a82ba027 (diff)
downloadopenbmc-f191bfb98753adbf617124f58c726a2ccc288a3c.tar.xz
meta-quanta: q71l: drop workbook skeleton
Drop workbook skeleton as it's now obsolete. (From meta-quanta rev: 6b6f78519cff678e0135298e2fccd00193291e81) Signed-off-by: Patrick Venture <venture@google.com> Change-Id: Ie1bd674ed2ec905b9d221447630091f3fc998a32 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-quanta/meta-q71l')
-rw-r--r--meta-quanta/meta-q71l/conf/machine/quanta-q71l.conf5
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/workbook/quanta-q71l-config.bb38
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/workbook/quanta-q71l-config/Quanta-q71l.py48
3 files changed, 0 insertions, 91 deletions
diff --git a/meta-quanta/meta-q71l/conf/machine/quanta-q71l.conf b/meta-quanta/meta-q71l/conf/machine/quanta-q71l.conf
index ef127e967..05ebc8262 100644
--- a/meta-quanta/meta-q71l/conf/machine/quanta-q71l.conf
+++ b/meta-quanta/meta-q71l/conf/machine/quanta-q71l.conf
@@ -23,11 +23,6 @@ FLASH_SIZE = "32768"
# "
# But we don't, and it's ok :D We're pulling in specific packages in an image recipe.
-# This sets up our own Quanta-q71l.py inclusion based on the Zaius.py in the skeleton repo.
-# As something temporarily required.
-VIRTUAL-RUNTIME_skeleton_workbook = "${MACHINE}-config"
-PREFERRED_PROVIDER_virtual/obmc-inventory-data ?= "${VIRTUAL-RUNTIME_skeleton_workbook}"
-
# These are meant to include the inventory config.yaml and so on.
PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-inventory = "q71l-ipmi-inventory-map-native"
PREFERRED_PROVIDER_virtual/phosphor-ipmi-sensor-inventory = "q71l-ipmi-sensor-map-native"
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/workbook/quanta-q71l-config.bb b/meta-quanta/meta-q71l/recipes-phosphor/workbook/quanta-q71l-config.bb
deleted file mode 100644
index e15bbd956..000000000
--- a/meta-quanta/meta-q71l/recipes-phosphor/workbook/quanta-q71l-config.bb
+++ /dev/null
@@ -1,38 +0,0 @@
-SUMMARY = "Quanta Q71l board wiring"
-DESCRIPTION = "Board wiring information for the Quanta Q71l system."
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${QUANTABASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit allarch
-inherit setuptools
-inherit pythonnative
-
-PROVIDES += "virtual/obmc-inventory-data"
-RPROVIDES_${PN} += "virtual-obmc-inventory-data"
-
-DEPENDS += "python"
-
-S = "${WORKDIR}"
-SRC_URI += "file://Quanta-q71l.py"
-
-# the following is unnecessary.
-python() {
- machine = d.getVar('MACHINE', True).capitalize() + '.py'
- d.setVar('_config_in_skeleton', machine)
-}
-
-do_make_setup() {
- cp ${S}/${_config_in_skeleton} \
- ${S}/obmc_system_config.py
- cat <<EOF > ${S}/setup.py
-from distutils.core import setup
-
-setup(name='${BPN}',
- version='${PR}',
- py_modules=['obmc_system_config'],
- )
-EOF
-}
-
-addtask make_setup after do_patch before do_configure
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/workbook/quanta-q71l-config/Quanta-q71l.py b/meta-quanta/meta-q71l/recipes-phosphor/workbook/quanta-q71l-config/Quanta-q71l.py
deleted file mode 100644
index ca7cb2098..000000000
--- a/meta-quanta/meta-q71l/recipes-phosphor/workbook/quanta-q71l-config/Quanta-q71l.py
+++ /dev/null
@@ -1,48 +0,0 @@
-## System states
-## state can change to next state in 2 ways:
-## - a process emits a GotoSystemState signal with state name to goto
-## - objects specified in EXIT_STATE_DEPEND have started
-SYSTEM_STATES = [
- 'BASE_APPS',
- 'BMC_STARTING',
- 'BMC_READY',
- 'HOST_POWERING_ON',
- 'HOST_POWERED_ON',
- 'HOST_BOOTING',
- 'HOST_BOOTED',
- 'HOST_POWERED_OFF',
-]
-
-EXIT_STATE_DEPEND = {
- 'BASE_APPS' : {
- '/xyz/openbmc_poroject/sensors': 0,
- },
- 'BMC_STARTING' : {
- '/xyz/openbmc_project/control/chassis0': 0,
- },
-}
-
-FRU_INSTANCES = {}
-
-# I believe these numbers need to match the yaml file used to create the c++ ipmi map.
-# the devices have types, but I don't believe that factors in here, I think these are
-# just unique IDs.
-ID_LOOKUP = {
- 'FRU' : {},
- # The number at the end needs to match the FRU ID.
- # https://github.com/openbmc/skeleton/blob/master/pysystemmgr/system_manager.py#L143
- # The parameter for it is of type 'y' (unsigned 8-bit integer) presumably decimal?
- 'FRU_STR' : {},
- 'SENSOR' : {},
- 'GPIO_PRESENT' : {}
-}
-
-GPIO_CONFIG = {}
-HWMON_CONFIG = {}
-GPIO_CONFIGS = {}
-
-# Miscellaneous non-poll sensor with system specific properties.
-# The sensor id is the same as those defined in ID_LOOKUP['SENSOR'].
-MISC_SENSORS = {}
-
-# vim: tabstop=8 expandtab shiftwidth=4 softtabstop=4