summaryrefslogtreecommitdiff
path: root/meta-quanta
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-07-10 00:15:49 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-07-10 00:15:49 +0300
commitf24c1e9afc47a421831278b57377951e71494d92 (patch)
treef01c5b14beb4bf31905f769569ed647884491cea /meta-quanta
parent057594a8bb8d062d72244196170c2d78947d318a (diff)
parent31e5d79893f21786cb0635ab3640d50ff6202f6a (diff)
downloadopenbmc-f24c1e9afc47a421831278b57377951e71494d92.tar.xz
Merge tag 'wht-0.66' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-quanta')
-rw-r--r--meta-quanta/conf/layer.conf4
-rw-r--r--meta-quanta/meta-common/recipes-quanta/network/mac-address_git.bb21
-rw-r--r--meta-quanta/meta-common/recipes-quanta/network/usb-network.bb25
-rw-r--r--meta-quanta/meta-common/recipes-quanta/network/usb-network/usb-network.service10
-rw-r--r--meta-quanta/meta-common/recipes-quanta/network/usb-network/usb-network.sh33
-rw-r--r--meta-quanta/meta-gbs/conf/bblayers.conf.sample29
-rw-r--r--meta-quanta/meta-gbs/conf/conf-notes.txt2
-rw-r--r--meta-quanta/meta-gbs/conf/layer.conf10
-rw-r--r--meta-quanta/meta-gbs/conf/local.conf.sample17
-rw-r--r--meta-quanta/meta-gbs/conf/machine/gbs.conf40
-rw-r--r--meta-quanta/meta-gsj/recipes-phosphor/settings/phosphor-settings-manager/time-default.override.yml6
-rw-r--r--meta-quanta/meta-olympus-nuvoton/conf/layer.conf2
12 files changed, 190 insertions, 9 deletions
diff --git a/meta-quanta/conf/layer.conf b/meta-quanta/conf/layer.conf
index f8c3cf485..18308e708 100644
--- a/meta-quanta/conf/layer.conf
+++ b/meta-quanta/conf/layer.conf
@@ -2,8 +2,8 @@
BBPATH .= ":${LAYERDIR}"
# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
+BBFILES += "${LAYERDIR}/meta-common/recipes-*/*/*.bb \
+ ${LAYERDIR}/meta-common/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "quanta-layer"
BBFILE_PATTERN_quanta-layer := "^${LAYERDIR}/"
diff --git a/meta-quanta/meta-common/recipes-quanta/network/mac-address_git.bb b/meta-quanta/meta-common/recipes-quanta/network/mac-address_git.bb
new file mode 100644
index 000000000..5b63e49cb
--- /dev/null
+++ b/meta-quanta/meta-common/recipes-quanta/network/mac-address_git.bb
@@ -0,0 +1,21 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit autotools pkgconfig
+inherit systemd
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/quanta-bmc/mac-address.git;protocol=git"
+SRCREV = "08b87370c56ff69df852eca87391ae46c05d437a"
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "systemd"
+
+FILES_${PN} += "${bindir}/mac-address"
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "mac-address.service"
+
+EXTRA_OECONF = " \
+ SYSTEMD_TARGET="multi-user.target" \
+"
diff --git a/meta-quanta/meta-common/recipes-quanta/network/usb-network.bb b/meta-quanta/meta-common/recipes-quanta/network/usb-network.bb
new file mode 100644
index 000000000..85146aa1f
--- /dev/null
+++ b/meta-quanta/meta-common/recipes-quanta/network/usb-network.bb
@@ -0,0 +1,25 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+SRC_URI_append = " file://usb-network.sh"
+SRC_URI_append = " file://usb-network.service"
+
+inherit systemd
+
+DEPENDS += "systemd"
+RDEPENDS_${PN} += "libsystemd"
+RDEPENDS_${PN} += "bash"
+
+FILES_${PN}_append = " ${sysconfdir_native}/systemd/network/00-bmc-usb0.network"
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -m 0755 ${WORKDIR}/usb-network.sh ${D}/${sbindir}
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/usb-network.service \
+ ${D}${systemd_unitdir}/system
+}
+
+SYSTEMD_SERVICE_${PN}_append = "usb-network.service"
diff --git a/meta-quanta/meta-common/recipes-quanta/network/usb-network/usb-network.service b/meta-quanta/meta-common/recipes-quanta/network/usb-network/usb-network.service
new file mode 100644
index 000000000..917b552c1
--- /dev/null
+++ b/meta-quanta/meta-common/recipes-quanta/network/usb-network/usb-network.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Enable USB Network
+
+[Service]
+Type=oneshot
+ExecStart=/usr/sbin/usb-network.sh
+EnvironmentFile=/usr/share/usb-network/usb-network.conf
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-quanta/meta-common/recipes-quanta/network/usb-network/usb-network.sh b/meta-quanta/meta-common/recipes-quanta/network/usb-network/usb-network.sh
new file mode 100644
index 000000000..444d4aee7
--- /dev/null
+++ b/meta-quanta/meta-common/recipes-quanta/network/usb-network/usb-network.sh
@@ -0,0 +1,33 @@
+#!/bin/bash
+
+cd /sys/kernel/config/usb_gadget
+
+if [ ! -f "g1" ]; then
+ mkdir g1
+ cd g1
+
+ echo 0x1d6b > idVendor # Linux foundation
+ echo 0x0104 > idProduct # Multifunction composite gadget
+ mkdir -p strings/0x409
+ echo "Linux" > strings/0x409/manufacturer
+ echo "Etherned/ECM gadget" > strings/0x409/product
+
+ mkdir -p configs/c.1
+ echo 100 > configs/c.1/MaxPower
+ mkdir -p configs/c.1/strings/0x409
+ echo "ECM" > configs/c.1/strings/0x409/configuration
+
+ mkdir -p functions/ecm.usb0
+ cat /tmp/usb0_dev > functions/ecm.usb0/dev_addr # write device mac address
+ cat /tmp/usb0_host > functions/ecm.usb0/host_addr # write usb mac address
+
+ ln -s functions/ecm.usb0 configs/c.1
+
+ echo "$UDC" > UDC
+
+ rm /tmp/usb0_dev
+ rm /tmp/usb0_host
+
+fi
+
+exit 0
diff --git a/meta-quanta/meta-gbs/conf/bblayers.conf.sample b/meta-quanta/meta-gbs/conf/bblayers.conf.sample
new file mode 100644
index 000000000..541036d81
--- /dev/null
+++ b/meta-quanta/meta-gbs/conf/bblayers.conf.sample
@@ -0,0 +1,29 @@
+# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+LCONF_VERSION = "8"
+
+BBPATH = "${TOPDIR}"
+BBFILES ?= ""
+
+BBLAYERS ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-openembedded/meta-oe \
+ ##OEROOT##/meta-openembedded/meta-networking \
+ ##OEROOT##/meta-openembedded/meta-python \
+ ##OEROOT##/meta-phosphor \
+ ##OEROOT##/meta-nuvoton \
+ ##OEROOT##/meta-google \
+ ##OEROOT##/meta-quanta \
+ ##OEROOT##/meta-quanta/meta-gbs \
+ "
+BBLAYERS_NON_REMOVABLE ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-openembedded/meta-oe \
+ ##OEROOT##/meta-openembedded/meta-networking \
+ ##OEROOT##/meta-openembedded/meta-python \
+ ##OEROOT##/meta-phosphor \
+ ##OEROOT##/meta-nuvoton \
+ ##OEROOT##/meta-google \
+ ##OEROOT##/meta-quanta \
+ ##OEROOT##/meta-quanta/meta-gbs \
+ "
diff --git a/meta-quanta/meta-gbs/conf/conf-notes.txt b/meta-quanta/meta-gbs/conf/conf-notes.txt
new file mode 100644
index 000000000..9b3c01a55
--- /dev/null
+++ b/meta-quanta/meta-gbs/conf/conf-notes.txt
@@ -0,0 +1,2 @@
+Common targets are:
+ obmc-phosphor-image
diff --git a/meta-quanta/meta-gbs/conf/layer.conf b/meta-quanta/meta-gbs/conf/layer.conf
new file mode 100644
index 000000000..ba7f543b6
--- /dev/null
+++ b/meta-quanta/meta-gbs/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "gbs-layer"
+BBFILE_PATTERN_gbs-layer := "^${LAYERDIR}/"
+LAYERSERIES_COMPAT_gbs-layer = "warrior zeus dunfell"
diff --git a/meta-quanta/meta-gbs/conf/local.conf.sample b/meta-quanta/meta-gbs/conf/local.conf.sample
new file mode 100644
index 000000000..02e786914
--- /dev/null
+++ b/meta-quanta/meta-gbs/conf/local.conf.sample
@@ -0,0 +1,17 @@
+MACHINE ??= "gbs"
+DISTRO ?= "openbmc-phosphor"
+PACKAGE_CLASSES ?= "package_rpm"
+SANITY_TESTED_DISTROS_append ?= " *"
+EXTRA_IMAGE_FEATURES = "debug-tweaks"
+USER_CLASSES ?= "buildstats image-mklibs image-prelink"
+PATCHRESOLVE = "noop"
+BB_DISKMON_DIRS = "\
+ STOPTASKS,${TMPDIR},1G,100K \
+ STOPTASKS,${DL_DIR},1G,100K \
+ STOPTASKS,${SSTATE_DIR},1G,100K \
+ STOPTASKS,/tmp,100M,100K \
+ ABORT,${TMPDIR},100M,1K \
+ ABORT,${DL_DIR},100M,1K \
+ ABORT,${SSTATE_DIR},100M,1K \
+ ABORT,/tmp,10M,1K"
+CONF_VERSION = "1"
diff --git a/meta-quanta/meta-gbs/conf/machine/gbs.conf b/meta-quanta/meta-gbs/conf/machine/gbs.conf
new file mode 100644
index 000000000..32dae060f
--- /dev/null
+++ b/meta-quanta/meta-gbs/conf/machine/gbs.conf
@@ -0,0 +1,40 @@
+KMACHINE = "nuvoton"
+KERNEL_DEVICETREE = "${KMACHINE}-npcm730-gbs.dtb"
+
+UBOOT_MACHINE = "PolegSVB_config"
+IGPS_MACHINE = "GBS"
+
+FLASH_SIZE = "32768"
+
+MACHINEOVERRIDES .= ":npcm7xx"
+
+require conf/machine/include/npcm7xx.inc
+require conf/machine/include/obmc-bsp-common.inc
+
+SERIAL_CONSOLES = "115200;ttyS0"
+
+OBMC_MACHINE_FEATURES += "\
+ obmc-phosphor-fan-mgmt \
+ obmc-phosphor-chassis-mgmt \
+ obmc-phosphor-flash-mgmt \
+ obmc-host-ipmi \
+ obmc-host-state-mgmt \
+ obmc-chassis-state-mgmt \
+ obmc-bmc-state-mgmt \
+ "
+
+VIRTUAL-RUNTIME_obmc-host-state-manager = "x86-power-control"
+VIRTUAL-RUNTIME_obmc-chassis-state-manager = "x86-power-control"
+VIRTUAL-RUNTIME_obmc-discover-system-state = "x86-power-control"
+
+PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-gbs-apps"
+PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-gbs-apps"
+PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-gbs-apps"
+PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw = "phosphor-ipmi-kcs"
+PREFERRED_PROVIDER_virtual/phosphor-led-manager-config-native = "gbs-led-manager-config-native"
+
+# Remove unneeded binaries from image
+IMAGE_FEATURES_remove = "obmc-fan-control"
+IMAGE_FEATURES_remove = "obmc-software"
+IMAGE_FEATURES_remove = "obmc-debug-collector"
+IMAGE_FEATURES_remove = "obmc-net-ipmi"
diff --git a/meta-quanta/meta-gsj/recipes-phosphor/settings/phosphor-settings-manager/time-default.override.yml b/meta-quanta/meta-gsj/recipes-phosphor/settings/phosphor-settings-manager/time-default.override.yml
index abb1316c8..0096eeb5c 100644
--- a/meta-quanta/meta-gsj/recipes-phosphor/settings/phosphor-settings-manager/time-default.override.yml
+++ b/meta-quanta/meta-gsj/recipes-phosphor/settings/phosphor-settings-manager/time-default.override.yml
@@ -1,10 +1,4 @@
---
-/xyz/openbmc_project/time/owner:
- - Interface: xyz.openbmc_project.Time.Owner
- Properties:
- TimeOwner:
- Default: Owner::Owners::Host
-
/xyz/openbmc_project/time/sync_method:
- Interface: xyz.openbmc_project.Time.Synchronization
Properties:
diff --git a/meta-quanta/meta-olympus-nuvoton/conf/layer.conf b/meta-quanta/meta-olympus-nuvoton/conf/layer.conf
index 5d5fdb733..28eb35f67 100644
--- a/meta-quanta/meta-olympus-nuvoton/conf/layer.conf
+++ b/meta-quanta/meta-olympus-nuvoton/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "olympus-nuvoton-layer"
BBFILE_PATTERN_olympus-nuvoton-layer := "^${LAYERDIR}/"
-LAYERSERIES_COMPAT_olympus-nuvoton-layer = "warrior zeus"
+LAYERSERIES_COMPAT_olympus-nuvoton-layer = "warrior zeus dunfell"