summaryrefslogtreecommitdiff
path: root/meta-quanta
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2020-08-03 11:45:23 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-06 01:09:02 +0300
commit92d58324fe407abaef9d4ffb0989f1d13deedadb (patch)
tree3cf7d3142b6c18f1af352106cc517589171c88d5 /meta-quanta
parentbd21fb244289e1f8092c3c594f6be9cc10538b5b (diff)
downloadopenbmc-92d58324fe407abaef9d4ffb0989f1d13deedadb.tar.xz
meta-quanta: gbs: add GBS read-margin-temp config
Since read-margin-temp_git.bb will move to meta-quanta/meta-common, add read-margin-temp bbappend file and move read-margin-temp folder from meta-gbs/recipes-phosphor/fans to meta-gbs/recipes-quanta/fans read-margin-temp_git.bb move to meta-quanta/meta-common: https://gerrit.openbmc-project.xyz/c/openbmc/meta-quanta/+/35277 (From meta-quanta rev: 410c3e900f09aa1f2fee6b155d9987b5510859c6) Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: I79ff42570dc9422e3c2e90dd95c5d29b01ec1133 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-quanta')
-rw-r--r--meta-quanta/meta-gbs/recipes-phosphor/fans/read-margin-temp_git.bb37
-rw-r--r--meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp/config-margin.json (renamed from meta-quanta/meta-gbs/recipes-phosphor/fans/read-margin-temp/config-margin.json)0
-rw-r--r--meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp/read-margin-temp-wait.sh (renamed from meta-quanta/meta-gbs/recipes-phosphor/fans/read-margin-temp/read-margin-temp-wait.sh)0
-rw-r--r--meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp_%.bbappend16
4 files changed, 16 insertions, 37 deletions
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/fans/read-margin-temp_git.bb b/meta-quanta/meta-gbs/recipes-phosphor/fans/read-margin-temp_git.bb
deleted file mode 100644
index 525dab223..000000000
--- a/meta-quanta/meta-gbs/recipes-phosphor/fans/read-margin-temp_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-SRC_URI = "git://github.com/quanta-bmc/read-margin-temp.git"
-SRCREV = "1a74891c996725dd4c94397d2588d840da07c548"
-S = "${WORKDIR}/git"
-
-SRC_URI += " file://config-margin.json \
- file://read-margin-temp-wait.sh \
- "
-
-inherit autotools pkgconfig
-inherit meson
-
-DEPENDS += " nlohmann-json"
-DEPENDS += " sdbusplus"
-DEPENDS += " sdbusplus-native"
-DEPENDS += " sdeventplus"
-DEPENDS += " phosphor-dbus-interfaces"
-
-RDEPENDS_${PN} += " bash"
-
-FILES_${PN} = "${bindir}/read-margin-temp"
-FILES_${PN} += " ${bindir}/read-margin-temp-wait.sh"
-FILES_${PN} += " ${datadir}/read-margin-temp/config-margin.json"
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 read-margin-temp ${D}${bindir}
- install -m 0755 ${WORKDIR}/read-margin-temp-wait.sh ${D}/${bindir}
-
- install -d ${D}${datadir}/read-margin-temp
- install -m 0644 -D ${WORKDIR}/config-margin.json \
- ${D}${datadir}/read-margin-temp/config-margin.json
-
-}
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/fans/read-margin-temp/config-margin.json b/meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp/config-margin.json
index 6b73e34b8..6b73e34b8 100644
--- a/meta-quanta/meta-gbs/recipes-phosphor/fans/read-margin-temp/config-margin.json
+++ b/meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp/config-margin.json
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/fans/read-margin-temp/read-margin-temp-wait.sh b/meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp/read-margin-temp-wait.sh
index 2e44479f6..2e44479f6 100644
--- a/meta-quanta/meta-gbs/recipes-phosphor/fans/read-margin-temp/read-margin-temp-wait.sh
+++ b/meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp/read-margin-temp-wait.sh
diff --git a/meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp_%.bbappend b/meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp_%.bbappend
new file mode 100644
index 000000000..b3fc4d221
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-quanta/fans/read-margin-temp_%.bbappend
@@ -0,0 +1,16 @@
+FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
+SRC_URI_append_gbs = " file://config-margin.json \
+ file://read-margin-temp-wait.sh \
+ "
+
+FILES_${PN}_append_gbs = " ${bindir}/read-margin-temp-wait.sh"
+FILES_${PN}_append_gbs = " ${datadir}/read-margin-temp/config-margin.json"
+
+do_install_append_gbs() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/read-margin-temp-wait.sh ${D}${bindir}
+
+ install -d ${D}${datadir}/read-margin-temp
+ install -m 0644 -D ${WORKDIR}/config-margin.json \
+ ${D}${datadir}/read-margin-temp/config-margin.json
+}