summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp/bootfiles
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-07-25 00:09:26 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-25 00:09:35 +0300
commit5d59ec7e23513a3a7f86280a2610ba3d2123f9a1 (patch)
tree7f1fe71b380d77e8d95512cb348d7cc2837a9284 /meta-raspberrypi/recipes-bsp/bootfiles
parentdd7514e7d03128aebba9a6e1b94bb832c93a1c58 (diff)
downloadopenbmc-5d59ec7e23513a3a7f86280a2610ba3d2123f9a1.tar.xz
meta-raspberrypi: subtree update:0d398a3b71..e2c1992955
Christopher Clark (1): rpi-base: add SERIAL_CONSOLES_CHECK to default to SERIAL_CONSOLES Khem Raj (1): userland: Update to 2020-06-24 top commit Pierre-Jean Texier (2): linux-raspberrypi: bump to Linux version 5.4.51 raspberrypi-firmware: update to current HEAD colin (3): conf/machine/include/rpi-base.inc: Added can1 interface to bsp rpi-config_git: Added ENABLE_DUAL_CAN build configuration docs: Added documentation for Pican2 Duo support Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I5e0c26ab7cabb4c931cbfef190b5b4b3ce257fdf
Diffstat (limited to 'meta-raspberrypi/recipes-bsp/bootfiles')
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index d964de5bf..afdbce69d 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -198,8 +198,13 @@ do_deploy() {
echo "dtoverlay=at86rf233,speed=3000000" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
fi
+ # ENABLE DUAL CAN
+ if [ "${ENABLE_DUAL_CAN}" = "1" ]; then
+ echo "# Enable DUAL CAN" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=mcp2515-can1,oscillator=16000000,interrupt=24" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
# ENABLE CAN
- if [ "${ENABLE_CAN}" = "1" ]; then
+ elif [ "${ENABLE_CAN}" = "1" ]; then
echo "# Enable CAN" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
echo "dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
fi