summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-07-10 23:52:35 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-10 23:52:40 +0300
commita16b0ff11065083684154184934b636fa364525d (patch)
tree2b5d620cbad6e6b799ca3f551c73a41c62b3cb52 /meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
parentc1ae9a2bbd217d462d3ca4b1f815c2d7faac2a27 (diff)
downloadopenbmc-a16b0ff11065083684154184934b636fa364525d.tar.xz
meta-raspberrypi: subtree update:a6f1233d52..0d398a3b71
Christopher Clark (1): linux-raspberrypi: bump to 5.4.50 since upstream was force-pushed Leon Anavi (2): rpi-u-boot-scr: Create uboot.env via boot.cmd.in libubootenv_%.bbappend: Add fw_env.config Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I8994cad6a13e2ae6f74c7a0a34061a9c4700a124
Diffstat (limited to 'meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend')
-rw-r--r--meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend b/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
new file mode 100644
index 000000000..22d1bdc4a
--- /dev/null
+++ b/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI_append_rpi = " \
+ file://fw_env.config \
+"
+
+DEPENDS_append_rpi = " rpi-u-boot-scr"
+
+do_install_append_rpi () {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+}