summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-16 17:06:00 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-16 17:06:13 +0300
commit1b9ee2930ed85e998a455a6149e2592a83609443 (patch)
treecc13fad7c07cdcd0532fcfd22482a4c00b558512 /meta-raspberrypi/recipes-bsp
parente42b3e385822fc1b08807a585d4bb2015c823690 (diff)
downloadopenbmc-1b9ee2930ed85e998a455a6149e2592a83609443.tar.xz
meta-raspberrypi: subtree update:a953fc0f9b..e7c856ee7b
Allen Wild (1): conf/machine: add pci to MACHINE_FEATURES for Pi4 Andrei Gherzan (3): pi-bluetooth: Fix signature failures raspberrypi-tools: Update to current HEAD armstubs: Define the new symbols use in Makefile Erik Botö (1): Add support for PiTFT 2.8" with capacitive touch Martin Jansa (1): gstreamer1.0-plugins-base: respect opengl DISTRO_FEATURES when vc4graphics is in MACHINE_FEATURES Pierre-Jean Texier (1): linux-raspberrypi: bump to Linux version 4.19.93 Ricardo Salveti (2): linux-raspberrypi: define kbuild defconfig for rpi cm3 raspberrypi-cm3.conf: drop KBUILD_DEFCONFIG definition Change-Id: Ie923657098eaf9733c7f6f73ee1f888174d44e5f Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-raspberrypi/recipes-bsp')
-rw-r--r--meta-raspberrypi/recipes-bsp/armstubs/armstubs.bb4
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb6
-rw-r--r--meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc6
3 files changed, 13 insertions, 3 deletions
diff --git a/meta-raspberrypi/recipes-bsp/armstubs/armstubs.bb b/meta-raspberrypi/recipes-bsp/armstubs/armstubs.bb
index 4318d9b97..d8f3fe70d 100644
--- a/meta-raspberrypi/recipes-bsp/armstubs/armstubs.bb
+++ b/meta-raspberrypi/recipes-bsp/armstubs/armstubs.bb
@@ -11,6 +11,10 @@ COMPATIBLE_MACHINE = "^rpi$"
S = "${RPITOOLS_S}/armstubs"
+export CC7="${CC}"
+export LD7="${LD}"
+export OBJCOPY7="${OBJCOPY}"
+export OBJDUMP7="${OBJDUMP}"
export CC8="${CC}"
export LD8="${LD}"
export OBJCOPY8="${OBJCOPY}"
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index 160bc16d0..5315676fd 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -20,6 +20,7 @@ INHIBIT_DEFAULT_DEPS = "1"
PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
PITFT22="${@bb.utils.contains("MACHINE_FEATURES", "pitft22", "1", "0", d)}"
PITFT28r="${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "1", "0", d)}"
+PITFT28c="${@bb.utils.contains("MACHINE_FEATURES", "pitft28c", "1", "0", d)}"
PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}"
VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}"
@@ -144,6 +145,11 @@ do_deploy() {
echo "# Enable PITFT28r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
echo "dtoverlay=pitft28-resistive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
fi
+ if [ "${PITFT28c}" = "1" ]; then
+ echo "# Enable PITFT28c display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=pitft28-capacitive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=pitft28-capacitive,touch-swapxy,touch-invx" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
if [ "${PITFT35r}" = "1" ]; then
echo "# Enable PITFT35r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
echo "dtoverlay=pitft35-resistive,rotate=90,speed=42000000,fps=20" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
diff --git a/meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc b/meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc
index a889a47d8..0d4c627cb 100644
--- a/meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc
+++ b/meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc
@@ -1,9 +1,9 @@
-SRCREV ?= "4a335520900ce55e251ac4f420f52bf0b2ab6b1f"
+SRCREV ?= "b0c869bc929587a7e1d20a98e2dc828a24ca396a"
RPITOOLS_SRC_URI ?= "https://github.com/raspberrypi/tools/archive/${SRCREV}.tar.gz"
RPITOOLS_S ?= "${WORKDIR}/tools-${SRCREV}"
SRC_URI = "${RPITOOLS_SRC_URI}"
-SRC_URI[md5sum] = "9d9f3e4887d357cbc5601e61bc538fae"
-SRC_URI[sha256sum] = "7dcb188f14845909573a7ec6522b7ba8de5d3373d06aab0e8852f4c8352d6541"
+SRC_URI[md5sum] = "fd999aad4424088b5e8746a9d946bb56"
+SRC_URI[sha256sum] = "a0a8aff308d9302318442e6bcd2df14cbbb3b633f12ca6b9c43c4ab69bf45bb1"
PV = "0.0+git${SRCREV}"