summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:54:03 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:54:10 +0300
commit26e4beaa6b6010b921ff99c1a3a7be148fbbfcbc (patch)
treeb57004eafa95be87bda454f13e34458f0a01f9f6 /meta-raspberrypi/recipes-bsp
parent7eb438a61ba2d5b3cc7f0ac3fea1ca2e47390529 (diff)
downloadopenbmc-26e4beaa6b6010b921ff99c1a3a7be148fbbfcbc.tar.xz
meta-raspberrypi: subtree update:09a3c11696..3a1fec22c0
Jan-Simon Moeller (1): python3-sense-hat: Switch to using pillow instead of imaging module Jose Quaresma (3): gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin gstreamer1.0-plugins-good: enable rpicamsrc plugin gstreamer1.0-plugins-base: drop custom cppflags Khem Raj (9): linux-raspberrypi: Do not use += with append python3-sense-hat: Move to dynamic-layers layer.conf: Add hardknott (3.3) to acceptable releases linux-raspberrypi_5.4.bb: Update to 5.4.79 raspberrypi-firmware: Update to latest to take 5.4.79 prebuilts userland: Upgrade to latest as of 20201027 raspberrypi-tools: Update to latest on master armstubs: Always use gcc compiler packagegroup-rpi-test: Add python3-sense-hat in a meta-python specific bbappend Madhavan Krishnan (1): libcamera: Enabled camera overlays define based Martin Jansa (3): gstreamer1.0-omx: rename bbappend to match new 1.18.0 version from oe-core layer.conf: Remove older releases from LAYERSERIES_COMPAT Revert "gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin" Ming Liu (1): rpi-u-boot-scr: drop hard-coded 'arm' Paul Barker (9): linux-raspberrypi: Convert dynamic config patching to config fragments sdcard_image-rpi: Drop redundant dependency on rpi-config:do_deploy rpi-cmdline: Move cmdline.txt generation to a separate recipe bootfiles: Use BOOTFILES_DIR_NAME variable rpi-bootfiles: Rename recipe to avoid ambiguity linux-raspberrypi: Remove obsolete kernel versions linux-raspberrypi: Drop unused rpi-kernel-misc config fragment linux-raspberrypi: Merge v5.4 recipe & inc file linux-raspberrypi-dev: Update for testing v5.10.y Trevor Woerner (1): userland: add knob for ALL_APPS Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I90e0cba993e7f5bae2e56f2d40fd2f69211c2648
Diffstat (limited to 'meta-raspberrypi/recipes-bsp')
-rw-r--r--meta-raspberrypi/recipes-bsp/armstubs/armstubs.bb2
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/rpi-bootfiles.bb (renamed from meta-raspberrypi/recipes-bsp/bootfiles/bootfiles.bb)16
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/rpi-cmdline.bb49
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb6
-rw-r--r--meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc6
-rw-r--r--meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc6
-rw-r--r--meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb4
7 files changed, 73 insertions, 16 deletions
diff --git a/meta-raspberrypi/recipes-bsp/armstubs/armstubs.bb b/meta-raspberrypi/recipes-bsp/armstubs/armstubs.bb
index d8f3fe70d..7e389dff5 100644
--- a/meta-raspberrypi/recipes-bsp/armstubs/armstubs.bb
+++ b/meta-raspberrypi/recipes-bsp/armstubs/armstubs.bb
@@ -34,3 +34,5 @@ addtask deploy before do_build after do_install
do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+TOOLCHAIN = "gcc"
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/bootfiles.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-bootfiles.bb
index 80e226d46..f1248eed1 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/bootfiles.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-bootfiles.bb
@@ -9,7 +9,7 @@ include recipes-bsp/common/raspberrypi-firmware.inc
INHIBIT_DEFAULT_DEPS = "1"
-DEPENDS = "rpi-config"
+DEPENDS = "rpi-config rpi-cmdline"
COMPATIBLE_MACHINE = "^rpi$"
@@ -18,26 +18,26 @@ S = "${RPIFW_S}/boot"
PR = "r3"
do_deploy() {
- install -d ${DEPLOYDIR}/${PN}
+ install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}
for i in ${S}/*.elf ; do
- cp $i ${DEPLOYDIR}/${PN}
+ cp $i ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}
done
for i in ${S}/*.dat ; do
- cp $i ${DEPLOYDIR}/${PN}
+ cp $i ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}
done
for i in ${S}/*.bin ; do
- cp $i ${DEPLOYDIR}/${PN}
+ cp $i ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}
done
# Add stamp in deploy directory
- touch ${DEPLOYDIR}/${PN}/${PN}-${PV}.stamp
+ touch ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/${PN}-${PV}.stamp
}
-do_deploy[depends] += "rpi-config:do_deploy"
+do_deploy[depends] += "rpi-config:do_deploy rpi-cmdline:do_deploy"
addtask deploy before do_build after do_install
-do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
+do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-cmdline.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-cmdline.bb
new file mode 100644
index 000000000..97db4e36f
--- /dev/null
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-cmdline.bb
@@ -0,0 +1,49 @@
+SUMMARY = "cmdline.txt file used to boot the kernel on a Raspberry Pi device"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+COMPATIBLE_MACHINE = "^rpi$"
+INHIBIT_DEFAULT_DEPS = "1"
+inherit deploy nopackages
+
+CMDLINE_DWC_OTG ?= "dwc_otg.lpm_enable=0"
+CMDLINE_ROOTFS ?= "root=/dev/mmcblk0p2 rootfstype=ext4 rootwait"
+
+CMDLINE_SERIAL ?= "${@oe.utils.conditional("ENABLE_UART", "1", "console=serial0,115200", "", d)}"
+
+CMDLINE_CMA ?= "${@oe.utils.conditional("RASPBERRYPI_CAMERA_V2", "1", "cma=64M", "", d)}"
+
+CMDLINE_PITFT ?= "${@bb.utils.contains("MACHINE_FEATURES", "pitft", "fbcon=map:10 fbcon=font:VGA8x8", "", d)}"
+
+# Add the kernel debugger over console kernel command line option if enabled
+CMDLINE_KGDB ?= '${@oe.utils.conditional("ENABLE_KGDB", "1", "kgdboc=serial0,115200", "", d)}'
+
+# Disable rpi logo on boot
+CMDLINE_LOGO ?= '${@oe.utils.conditional("DISABLE_RPI_BOOT_LOGO", "1", "logo.nologo", "", d)}'
+
+# You can define CMDLINE_DEBUG as "debug" in your local.conf or distro.conf
+# to enable kernel debugging.
+CMDLINE_DEBUG ?= ""
+
+CMDLINE = " \
+ ${CMDLINE_DWC_OTG} \
+ ${CMDLINE_SERIAL} \
+ ${CMDLINE_ROOTFS} \
+ ${CMDLINE_CMA} \
+ ${CMDLINE_KGDB} \
+ ${CMDLINE_LOGO} \
+ ${CMDLINE_PITFT} \
+ ${CMDLINE_DEBUG} \
+ "
+
+do_compile() {
+ echo "${CMDLINE}" > "${WORKDIR}/cmdline.txt"
+}
+
+do_deploy() {
+ install -d "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
+ install -m 0644 "${WORKDIR}/cmdline.txt" "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
+}
+
+addtask deploy before do_build after do_install
+do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index 9489951ec..e1c330db1 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -178,6 +178,12 @@ do_deploy() {
echo "dtoverlay=${VC4DTBO}" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt
fi
+ # Choose Camera Sensor to be used, default imx219 sensor
+ if [ "${RASPBERRYPI_CAMERA_V2}" = "1" ]; then
+ echo "# Enable Sony RaspberryPi Camera" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt
+ echo "dtoverlay=imx219" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt
+ fi
+
# Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm)
if [ "${WAVESHARE_1024X600_C_2_1}" = "1" ]; then
echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt
diff --git a/meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc b/meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc
index 32cc4807d..649c7ea97 100644
--- a/meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc
+++ b/meta-raspberrypi/recipes-bsp/common/raspberrypi-firmware.inc
@@ -1,9 +1,9 @@
-RPIFW_DATE ?= "20201002"
-SRCREV ?= "11e3c314bc2b64f7d862bac00ff3d9f42f3c5a50"
+RPIFW_DATE ?= "20201123"
+SRCREV ?= "8f13114b9ea29bd004151d4a8afa500b2df721be"
RPIFW_SRC_URI ?= "https://github.com/raspberrypi/firmware/archive/${SRCREV}.tar.gz;downloadfilename=raspberrypi-firmware-${SRCREV}.tar.gz"
RPIFW_S ?= "${WORKDIR}/firmware-${SRCREV}"
SRC_URI = "${RPIFW_SRC_URI}"
-SRC_URI[sha256sum] = "b8c9f5a3e987f418f11526cbf59f6a6c8103e8f5e94bccffb9ef3fd7ae834f98"
+SRC_URI[sha256sum] = "f9be0cc177aae7dddaa0a2967d090ea33a95be9dd519d2eee3bc740af8ffb19e"
PV = "${RPIFW_DATE}"
diff --git a/meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc b/meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc
index 93f9d7ac9..7879c0af5 100644
--- a/meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc
+++ b/meta-raspberrypi/recipes-bsp/common/raspberrypi-tools.inc
@@ -1,9 +1,9 @@
-RPITOOLS_DATE ?= "20200803"
-SRCREV ?= "0c39cb5b5ac9851312a38c54f5aea770d976de7a"
+RPITOOLS_DATE ?= "20201008"
+SRCREV ?= "fc0e73c13865450e95edd046200e42a6e52d8256"
RPITOOLS_SRC_URI ?= "https://github.com/raspberrypi/tools/archive/${SRCREV}.tar.gz;downloadfilename=raspberrypi-tools-${SRCREV}.tar.gz"
RPITOOLS_S ?= "${WORKDIR}/tools-${SRCREV}"
SRC_URI = "${RPITOOLS_SRC_URI}"
-SRC_URI[sha256sum] = "ef56a891eef387d2278e6f9d20b462021faace14aceeb2048b5e5973069c25c0"
+SRC_URI[sha256sum] = "05217b942150830225e8ee04a8f16b8ecc2ffbbe5dd815541b15333f783e805e"
PV = "${RPITOOLS_DATE}"
diff --git a/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb b/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
index 4cb8978e4..9108f7139 100644
--- a/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
+++ b/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
@@ -13,10 +13,10 @@ do_compile() {
sed -e 's/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/' \
-e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/' \
"${WORKDIR}/boot.cmd.in" > "${WORKDIR}/boot.cmd"
- mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
+ mkimage -A ${UBOOT_ARCH} -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
}
-inherit deploy nopackages
+inherit kernel-arch deploy nopackages
do_deploy() {
install -d ${DEPLOYDIR}