summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-06-25 22:23:27 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-06-28 15:35:59 +0300
commita4353c83a2d230d0992feedbf462cc243ab37126 (patch)
tree1424e8661f114308fab76e36aa3485377eb3d830 /meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb
parentfec94c7b8f7adb79e6d63db1a7e88b54eecc1749 (diff)
downloadopenbmc-a4353c83a2d230d0992feedbf462cc243ab37126.tar.xz
meta-raspberrypi: subtree update:ffc402ef5e..17b56ab075
Andreas Müller (1): pi-bluetooth: upgrade 0.1.12 -> 0.1.17 Devendra Tewari (1): Add WM8960 soundcard support Paul Barker (1): rpi-cmdline: Package is machine-specific Pierre-Jean Texier (1): kas: remove 'image-mklibs' from USER_CLASSES list Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I08366a667f191efd45b717be5bd530ae1af782b5
Diffstat (limited to 'meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb')
-rw-r--r--meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb
new file mode 100644
index 000000000..a1eb97fe8
--- /dev/null
+++ b/meta-raspberrypi/recipes-connectivity/pi-bluetooth/pi-bluetooth_0.1.17.bb
@@ -0,0 +1,47 @@
+SUMMARY = "Script to properly configure BT-HCI on Raspberry Pi"
+HOMEPAGE = "https://github.com/RPi-Distro/pi-bluetooth"
+SECTION = "kernel"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "\
+ file://debian/copyright;md5=6af8de3c8ee71f8e91e9b22f84ff2022 \
+"
+
+SRC_URI = "\
+ git://github.com/RPi-Distro/pi-bluetooth \
+ file://0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch \
+"
+SRCREV = "fd4775bf90e037551532fc214a958074830bb80d"
+
+S = "${WORKDIR}/git"
+
+# hciuart.service replaces what was brcm43438.service
+inherit systemd
+SYSTEMD_SERVICE_${PN} = "\
+ hciuart.service \
+ bthelper@.service \
+"
+
+do_install() {
+ install -d ${D}${sysconfdir}/udev/rules.d
+ install -m 0644 ${S}/lib/udev/rules.d/* ${D}${sysconfdir}/udev/rules.d
+
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/usr/bin/bthelper ${D}${bindir}
+ install -m 0755 ${S}/usr/bin/btuart ${D}${bindir}
+
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${S}/debian/pi-bluetooth.bthelper@.service ${D}${systemd_system_unitdir}/bthelper@.service
+ install -m 0644 ${S}/debian/pi-bluetooth.hciuart.service ${D}${systemd_system_unitdir}/hciuart.service
+ fi
+}
+
+FILES_${PN} = "\
+ ${bindir} \
+ ${sysconfdir} \
+ ${systemd_unitdir}/system \
+"
+
+RDEPENDS_${PN} += " \
+ udev-rules-rpi \
+"