summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-03-06 00:21:55 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-03-15 14:02:06 +0300
commit3e34fba3f6b8389074f64203299fa60ec0fc18e1 (patch)
treec863d9d0adf9b551157b9d09c3870bc961038886 /meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb
parent46c2791f2c65f72b001533f3029228b85629aa1b (diff)
downloadopenbmc-3e34fba3f6b8389074f64203299fa60ec0fc18e1.tar.xz
meta-raspberrypi: subtree update:f5fe02c30c..853ccd7440
Chris Laplante (8): python3-adafruit-blinka: add recipe python3-adafruit-circuitpython-busdevice: add recipe python3-adafruit-circuitpython-motor: add recipe python3-adafruit-circuitpython-motorkit: add recipe python3-adafruit-circuitpython-pca9685: add recipe python3-adafruit-circuitpython-register: add recipe python3-adafruit-platformdetect: add recipe python3-adafruit-pureio: add recipe Jose Quaresma (3): gstreamer1.0-omx: drop custom cflags gstreamer1.0-omx: consolidate the append usage and only use one gstreamer1.0-omx: drop config-files-path.patch Khem Raj (2): python3-adafruit-blinka: Make rpi-gpio dependency conditional python3-adafruit-blinka: Delete microcontroller/bcm283x for non arm32 machines Martin Jansa (2): sdcard_image-rpi.bbclass: increase default boot partition size from 40MiB to 48MiB sdcard_image-rpi.bbclass: shorten the default BOOTDD_VOLUME_ID Mike Looijmans (1): overlays: Add "vc4-kms-dsi-7inch.dtbo" Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: If81a2227cc45daf24cd0b2466651658bb1b71eb0
Diffstat (limited to 'meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb')
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb
new file mode 100644
index 000000000..f35d48cf2
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "CircuitPython helper library for DC & Stepper Motor FeatherWing, Shield, and Pi Hat kits."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_MotorKit"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ad4a8854b39ad474755ef1aea813bac"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_MotorKit.git"
+SRCREV = "8c1462b4129b21f6db156d1517abb017bb74b982"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS_${PN} += " \
+ python3-adafruit-blinka \
+ python3-adafruit-circuitpython-busdevice \
+ python3-adafruit-circuitpython-motor \
+ python3-adafruit-circuitpython-pca9685 \
+ python3-adafruit-circuitpython-register \
+ python3-core \
+"