summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-03-02 22:06:48 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-03-02 22:06:48 +0300
commit9600a7403ba2848c8751280077503a3e0f2f3481 (patch)
tree996726918f255cc9686dec34628fab410ac8f550 /meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
parentb11bad1ba28f79c08266efb9cc265d89103e5939 (diff)
parent5ec7af7413906b500cce396255bde69c9770f6d8 (diff)
downloadopenbmc-9600a7403ba2848c8751280077503a3e0f2f3481.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb')
-rw-r--r--meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb b/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
new file mode 100644
index 000000000..fcce88f83
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "A module to control Raspberry Pi GPIO channels"
+HOMEPAGE = "https://sourceforge.net/projects/raspberry-gpio-python/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=9b95630a648966b142f1a0dcea001cb7"
+
+PYPI_PACKAGE = "RPi.GPIO"
+inherit pypi distutils3
+
+SRC_URI += "file://0001-Remove-nested-functions.patch"
+SRC_URI[md5sum] = "777617f9dea9a1680f9af43db0cf150e"
+SRC_URI[sha256sum] = "7424bc6c205466764f30f666c18187a0824077daf20b295c42f08aea2cb87d3f"
+
+COMPATIBLE_MACHINE = "^rpi$"