summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-graphics/mesa
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-12-12 01:26:08 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-12-12 01:26:09 +0300
commit12e5ffbbbaa05790d387750fadff4a2bf74e4f93 (patch)
tree33e837c0cb125fcb3264a7416927233a2f0ea961 /meta-raspberrypi/recipes-graphics/mesa
parent10fa14942b9cb27780f9496382107516639208b4 (diff)
downloadopenbmc-12e5ffbbbaa05790d387750fadff4a2bf74e4f93.tar.xz
meta-raspberrypi: subtree update:3a1fec22c0..4b89f63699
Aaron Shaw (1): linux-firmware-rpidistro: Added firmware for BCM43456 Khem Raj (3): mesa-gl: Enable swrast dri backend for rpi/userland userland: Fix weston build with userland graphics libglu: Fix build with userland graphics Tobias Off (1): linux-firmware-rpidistro: Missing link to firmware causes wifi not working on raspberrypi zero w Trevor Woerner (1): userland: fix invalid packageconfig Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I06d2fbef19f827ffcbb485c60935b9a8c373e1c4
Diffstat (limited to 'meta-raspberrypi/recipes-graphics/mesa')
-rw-r--r--meta-raspberrypi/recipes-graphics/mesa/libglu_%.bbappend3
-rw-r--r--meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend2
2 files changed, 5 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-graphics/mesa/libglu_%.bbappend b/meta-raspberrypi/recipes-graphics/mesa/libglu_%.bbappend
new file mode 100644
index 000000000..56ff4213a
--- /dev/null
+++ b/meta-raspberrypi/recipes-graphics/mesa/libglu_%.bbappend
@@ -0,0 +1,3 @@
+# when using userland graphic KHR/khrplatform.h is provided by userland but virtual/libgl is provided by mesa-gl where
+# we explicitly delete KHR/khrplatform.h since its already coming from userland package
+DEPENDS_append_rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'userland', d)}"
diff --git a/meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend b/meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend
index 08ec1c59a..84cd479af 100644
--- a/meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend
+++ b/meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend
@@ -1,6 +1,8 @@
PACKAGECONFIG_append_rpi = " gbm"
PROVIDES_append_rpi = " virtual/libgbm"
+DRIDRIVERS_append_rpi = ",swrast"
+
do_install_append_rpi() {
rm -rf ${D}${includedir}/KHR/khrplatform.h
}