summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-05-15 22:19:14 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-05-21 23:43:47 +0300
commit062316f13d6e9d71a14724e293241b6258c63876 (patch)
treeaaf7deae114e1498f8b9eaabeba5e88b38938f71 /meta-raspberrypi/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch
parent1fe918a07084c878d72cf8a7d1707f6598cc438f (diff)
downloadopenbmc-062316f13d6e9d71a14724e293241b6258c63876.tar.xz
meta-raspberrypi: subtree update:05c86e3160..6f85d3f665
Bartłomiej Burdukiewicz (1): linux-raspberrypi_5.4.bb: Update to latest Drew Moseley (1): raspberrypi3: Switch to vc4-fkms-v3d. Fabio Berton (1): rpi-u-boot-scr: Set u-boot-default-script as provider Khem Raj (20): rpio: Use python3 during build gstreamer1.0-plugins-base: Adjust for meson conversion mesa: Fix patch fuzz linux-raspberrypi: Fix building selftest/bpf oeqa: Add rpi specific kernel dmesg parser linux-raspberrypi: Get PMU fixes on top of 4.19.108 qtbase: Append userland to rdeps iff vc4graphics is not enabled qtbase: Drop xkb packageconfig userland: Update to 20200316 snapshot userland: Fix build with gcc10 rpi-base: Drop old dtbo names linux-raspberrypi: Add recipes for kernel 5.4 linux-raspberrypi_5.4.bb: Update to latest and fix build with binutils 2.34 linux-raspberrypi_5.4.bb: Enable powersave options in kconfig linux-raspberrypi_5.4.bb: Backport the patch to use CHECK macro instead of RET_IF linux-raspberrypi_5.4.bb: Update to latest linux-firmware-rpidistro: Upgrade to 20190114-1+rpt6 psplash: Do not define ALTERNATIVE_PRIORITY for non-existing provider linux-raspberrypi_5.4.bb: Update to latest linux-raspberrypi_5.4.bb: Update to 5.4.35 Leon Anavi (3): docs/extra-build-config.md: Auto-load I2C modules rpi-base.inc: Add kernel modules to all images rpi-base.inc: Include modules if I2C is enaled Madhavan Krishnan (1): gstreamer: Fix the compilation issue in meta multimedia image Martin Jansa (7): userland: add pkg-config for openmaxil and add virtual/libomxil to PROVIDES gstreamer1.0-plugins-base: adapt to gstreamer1.0 now using meson gstreamer1.0-omx: let virtual/libomxil dependency to pull userland omxplayer: respect virtual/libomxil packagegroup-rpi-test: include bigbuckbunny in RRECOMMENDS_${PN} only with meta-multimedia packagegroup-rpi-test: use MACHINE_ARCH linux-raspberrypi: fix perf build with latest binutils Orne Brocaar (1): rpi-base.conf: add disable-bt.dtbo and miniuart-bt.dtbo overlays. Pierre-Jean Texier (17): kas-poky-rpi: add kas file rpi-base.inc: use wic.bz2 for all rpi machines by default linux-raspberrypi: bump to Linux version 4.19.97 raspberrypi-firmware: bump to version 20200205 linux-raspberrypi: bump to Linux version 4.19.102 linux-raspberrypi: bump to Linux version 4.19.105 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.108 raspberrypi-firmware: update to current HEAD layer.conf: add dunfell to compat layer raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.113 README.md: add status badge for raspberrypi4 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.115 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.120 rkhan467 (1): mesa: querying dma_buf modifiers for specific formats Change-Id: I956a7aedff5028fa3af56b101ecaad17b3ff64e0 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-raspberrypi/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch')
-rw-r--r--meta-raspberrypi/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch32
1 files changed, 15 insertions, 17 deletions
diff --git a/meta-raspberrypi/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch b/meta-raspberrypi/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch
index 8ce9090c1..9b0dd21eb 100644
--- a/meta-raspberrypi/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch
+++ b/meta-raspberrypi/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch
@@ -1,7 +1,7 @@
-From 7432d49ddca97b34e402d0108221d34ec69bcd66 Mon Sep 17 00:00:00 2001
+From 21dba61f098020d1143289017841ca76995618d4 Mon Sep 17 00:00:00 2001
From: Tomeu Vizoso <tomeu.vizoso@collabora.com>
Date: Tue, 1 Oct 2013 13:19:20 +0200
-Subject: [PATCH 02/19] wayland: Add support for the Wayland winsys
+Subject: [PATCH] wayland: Add support for the Wayland winsys
* Adds EGL_WL_bind_wayland_display extension
* Adds wayland-egl library
@@ -23,7 +23,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
CMakeLists.txt | 11 +
README.md | 4 +
buildme | 10 +-
- .../linux/apps/raspicam/CMakeLists.txt | 2 +-
+ .../linux/apps/raspicam/CMakeLists.txt | 3 +-
interface/khronos/CMakeLists.txt | 54 +++-
interface/khronos/common/khrn_client.c | 15 ++
interface/khronos/common/khrn_client.h | 10 +
@@ -49,7 +49,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
interface/vmcs_host/vc_vchi_dispmanx.h | 15 ++
interface/wayland/dispmanx.xml | 123 +++++++++
makefiles/cmake/Wayland.cmake | 72 +++++
- 30 files changed, 1257 insertions(+), 99 deletions(-)
+ 30 files changed, 1258 insertions(+), 99 deletions(-)
create mode 100644 interface/khronos/common/linux/khrn_wayland.c
copy interface/{vmcs_host/vc_vchi_dispmanx.h => khronos/common/linux/khrn_wayland.h} (56%)
create mode 100644 interface/khronos/ext/egl_wayland.c
@@ -69,10 +69,10 @@ index 63570f1..1459436 100644
*.mkv
+*~
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index cfc8ae5..673a5ad 100644
+index d8ba238..8c5bf5f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -24,6 +24,17 @@ include(makefiles/cmake/global_settings.cmake)
+@@ -20,6 +20,17 @@ include(makefiles/cmake/global_settings.cmake)
include(makefiles/cmake/arm-linux.cmake)
include(makefiles/cmake/vmcs.cmake)
@@ -103,7 +103,7 @@ index 404e4d4..97a6b8f 100644
+
+$ BUILD_WAYLAND=1 ./buildme.
diff --git a/buildme b/buildme
-index cee90a6..d1d76a7 100755
+index 9e2d405..7b8c0d6 100755
--- a/buildme
+++ b/buildme
@@ -17,6 +17,10 @@ fi
@@ -133,15 +133,16 @@ index cee90a6..d1d76a7 100755
if [ "$1" != "" ]; then
diff --git a/host_applications/linux/apps/raspicam/CMakeLists.txt b/host_applications/linux/apps/raspicam/CMakeLists.txt
-index f7db21e..73997b7 100644
+index 656a9a0..4b0a888 100644
--- a/host_applications/linux/apps/raspicam/CMakeLists.txt
+++ b/host_applications/linux/apps/raspicam/CMakeLists.txt
-@@ -54,7 +54,7 @@ add_executable(raspividyuv ${COMMON_SOURCES} RaspiVidYUV.c)
+@@ -59,7 +59,8 @@ add_executable(raspivid ${COMMON_SOURCES} RaspiVid.c)
+ add_executable(raspividyuv ${COMMON_SOURCES} RaspiVidYUV.c)
set (MMAL_LIBS mmal_core mmal_util mmal_vc_client)
-
--target_link_libraries(raspistill ${MMAL_LIBS} vcos bcm_host brcmGLESv2 brcmEGL m dl)
-+target_link_libraries(raspistill ${MMAL_LIBS} vcos bcm_host brcmGLESv2 brcmEGL m dl ${WAYLAND_SERVER_LIBRARIES} ${WAYLAND_CLIENT_LIBRARIES})
+-target_link_libraries(raspistill ${MMAL_LIBS} vcos bcm_host ${EGL_LIBS} m dl)
++
++target_link_libraries(raspistill ${MMAL_LIBS} vcos bcm_host ${EGL_LIBS} m dl ${WAYLAND_SERVER_LIBRARIES} ${WAYLAND_CLIENT_LIBRARIES})
target_link_libraries(raspiyuv ${MMAL_LIBS} vcos bcm_host)
target_link_libraries(raspivid ${MMAL_LIBS} vcos bcm_host)
target_link_libraries(raspividyuv ${MMAL_LIBS} vcos bcm_host)
@@ -1551,7 +1552,7 @@ index 0000000..8bafc15
+Libs: -L${libdir} -lwayland-egl
+Cflags: -I${includedir}
diff --git a/interface/vmcs_host/CMakeLists.txt b/interface/vmcs_host/CMakeLists.txt
-index a157db1..55b6ace 100755
+index 4a914a7..c202204 100755
--- a/interface/vmcs_host/CMakeLists.txt
+++ b/interface/vmcs_host/CMakeLists.txt
@@ -7,13 +7,24 @@
@@ -1582,8 +1583,8 @@ index a157db1..55b6ace 100755
+add_library(vchostif ${VCHOSTIF_SOURCE})
+
#add_library(bufman vc_vchi_bufman.c )
+ set(INSTALL_TARGETS vchostif)
- # OpenMAX/IL component service
diff --git a/interface/vmcs_host/vc_dispmanx.h b/interface/vmcs_host/vc_dispmanx.h
index 37fdae1..fe3619a 100755
--- a/interface/vmcs_host/vc_dispmanx.h
@@ -1893,6 +1894,3 @@ index 0000000..ad90d30
+ list(APPEND ${_sources} "${_server_header}")
+ set(${_sources} ${${_sources}} PARENT_SCOPE)
+endfunction()
---
-2.22.0
-