summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-07-25 00:09:26 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-25 00:09:35 +0300
commit5d59ec7e23513a3a7f86280a2610ba3d2123f9a1 (patch)
tree7f1fe71b380d77e8d95512cb348d7cc2837a9284 /meta-raspberrypi/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch
parentdd7514e7d03128aebba9a6e1b94bb832c93a1c58 (diff)
downloadopenbmc-5d59ec7e23513a3a7f86280a2610ba3d2123f9a1.tar.xz
meta-raspberrypi: subtree update:0d398a3b71..e2c1992955
Christopher Clark (1): rpi-base: add SERIAL_CONSOLES_CHECK to default to SERIAL_CONSOLES Khem Raj (1): userland: Update to 2020-06-24 top commit Pierre-Jean Texier (2): linux-raspberrypi: bump to Linux version 5.4.51 raspberrypi-firmware: update to current HEAD colin (3): conf/machine/include/rpi-base.inc: Added can1 interface to bsp rpi-config_git: Added ENABLE_DUAL_CAN build configuration docs: Added documentation for Pican2 Duo support Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I5e0c26ab7cabb4c931cbfef190b5b4b3ce257fdf
Diffstat (limited to 'meta-raspberrypi/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch')
-rw-r--r--meta-raspberrypi/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch47
1 files changed, 25 insertions, 22 deletions
diff --git a/meta-raspberrypi/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch b/meta-raspberrypi/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch
index b99576966..59fc366e7 100644
--- a/meta-raspberrypi/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch
+++ b/meta-raspberrypi/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch
@@ -1,17 +1,17 @@
-From d2fd39ea43f948feba34e895600afd801e03691f Mon Sep 17 00:00:00 2001
+From 3b568db9460c0359e8bda8256aa2161e5aafe07c Mon Sep 17 00:00:00 2001
From: Tomeu Vizoso <tomeu.vizoso@collabora.com>
Date: Tue, 1 Oct 2013 13:19:20 +0200
-Subject: [PATCH] wayland: Add Wayland example
+Subject: [PATCH 03/21] wayland: Add Wayland example
---
.../linux/apps/hello_pi/CMakeLists.txt | 1 +
+ .../linux/apps/hello_pi/Makefile | 2 +
.../hello_pi/hello_wayland/CMakeLists.txt | 8 +
.../hello_pi/hello_wayland/Djenne_128_128.raw | 3 +
.../apps/hello_pi/hello_wayland/Makefile | 5 +
.../hello_wayland/cube_texture_and_coords.h | 100 +++
.../apps/hello_pi/hello_wayland/triangle.c | 666 ++++++++++++++++++
- .../linux/apps/hello_pi/rebuild.sh | 3 +-
- 7 files changed, 785 insertions(+), 1 deletion(-)
+ 7 files changed, 785 insertions(+)
create mode 100644 host_applications/linux/apps/hello_pi/hello_wayland/CMakeLists.txt
create mode 100644 host_applications/linux/apps/hello_pi/hello_wayland/Djenne_128_128.raw
create mode 100644 host_applications/linux/apps/hello_pi/hello_wayland/Makefile
@@ -30,6 +30,24 @@ index b28a94a..2849fad 100644
if(BUILD_FONT)
set(VGFONT_SRCS libs/vgfont/font.c libs/vgfont/vgft.c libs/vgfont/graphics.c)
+diff --git a/host_applications/linux/apps/hello_pi/Makefile b/host_applications/linux/apps/hello_pi/Makefile
+index 4c2b2ef..d2b2555 100644
+--- a/host_applications/linux/apps/hello_pi/Makefile
++++ b/host_applications/linux/apps/hello_pi/Makefile
+@@ -24,6 +24,7 @@ apps: libs/ilclient/libilclient.a libs/vgfont/libvgfont.a libs/revision/librevis
+ $(MAKE) -C hello_teapot
+ $(MAKE) -C hello_fft
+ $(MAKE) -C hello_mmal_encode
++ $(MAKE) -C hello_wayland
+
+ clean:
+ $(MAKE) -C libs/ilclient clean
+@@ -43,4 +44,5 @@ clean:
+ $(MAKE) -C hello_teapot clean
+ $(MAKE) -C hello_fft clean
+ $(MAKE) -C hello_mmal_encode clean
++ $(MAKE) -C hello_wayland clean
+
diff --git a/host_applications/linux/apps/hello_pi/hello_wayland/CMakeLists.txt b/host_applications/linux/apps/hello_pi/hello_wayland/CMakeLists.txt
new file mode 100644
index 0000000..9a2f75c
@@ -843,21 +861,6 @@ index 0000000..1a7bfc4
+ return 0;
+}
+
-diff --git a/host_applications/linux/apps/hello_pi/rebuild.sh b/host_applications/linux/apps/hello_pi/rebuild.sh
-index 8225dd5..0be6ce7 100755
---- a/host_applications/linux/apps/hello_pi/rebuild.sh
-+++ b/host_applications/linux/apps/hello_pi/rebuild.sh
-@@ -14,6 +14,7 @@ make -C hello_videocube clean
- make -C hello_teapot clean
- make -C hello_fft clean
- make -C hello_mmal_encode clean
-+make -C hello_wayland clean
-
- make -C libs/ilclient
- make -C libs/vgfont
-@@ -31,4 +32,4 @@ make -C hello_videocube
- make -C hello_teapot
- make -C hello_fft
- make -C hello_mmal_encode
--
-+make -C hello_wayland
+--
+2.27.0
+