summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-05-15 22:19:14 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-05-21 23:43:47 +0300
commit062316f13d6e9d71a14724e293241b6258c63876 (patch)
treeaaf7deae114e1498f8b9eaabeba5e88b38938f71 /meta-raspberrypi/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch
parent1fe918a07084c878d72cf8a7d1707f6598cc438f (diff)
downloadopenbmc-062316f13d6e9d71a14724e293241b6258c63876.tar.xz
meta-raspberrypi: subtree update:05c86e3160..6f85d3f665
Bartłomiej Burdukiewicz (1): linux-raspberrypi_5.4.bb: Update to latest Drew Moseley (1): raspberrypi3: Switch to vc4-fkms-v3d. Fabio Berton (1): rpi-u-boot-scr: Set u-boot-default-script as provider Khem Raj (20): rpio: Use python3 during build gstreamer1.0-plugins-base: Adjust for meson conversion mesa: Fix patch fuzz linux-raspberrypi: Fix building selftest/bpf oeqa: Add rpi specific kernel dmesg parser linux-raspberrypi: Get PMU fixes on top of 4.19.108 qtbase: Append userland to rdeps iff vc4graphics is not enabled qtbase: Drop xkb packageconfig userland: Update to 20200316 snapshot userland: Fix build with gcc10 rpi-base: Drop old dtbo names linux-raspberrypi: Add recipes for kernel 5.4 linux-raspberrypi_5.4.bb: Update to latest and fix build with binutils 2.34 linux-raspberrypi_5.4.bb: Enable powersave options in kconfig linux-raspberrypi_5.4.bb: Backport the patch to use CHECK macro instead of RET_IF linux-raspberrypi_5.4.bb: Update to latest linux-firmware-rpidistro: Upgrade to 20190114-1+rpt6 psplash: Do not define ALTERNATIVE_PRIORITY for non-existing provider linux-raspberrypi_5.4.bb: Update to latest linux-raspberrypi_5.4.bb: Update to 5.4.35 Leon Anavi (3): docs/extra-build-config.md: Auto-load I2C modules rpi-base.inc: Add kernel modules to all images rpi-base.inc: Include modules if I2C is enaled Madhavan Krishnan (1): gstreamer: Fix the compilation issue in meta multimedia image Martin Jansa (7): userland: add pkg-config for openmaxil and add virtual/libomxil to PROVIDES gstreamer1.0-plugins-base: adapt to gstreamer1.0 now using meson gstreamer1.0-omx: let virtual/libomxil dependency to pull userland omxplayer: respect virtual/libomxil packagegroup-rpi-test: include bigbuckbunny in RRECOMMENDS_${PN} only with meta-multimedia packagegroup-rpi-test: use MACHINE_ARCH linux-raspberrypi: fix perf build with latest binutils Orne Brocaar (1): rpi-base.conf: add disable-bt.dtbo and miniuart-bt.dtbo overlays. Pierre-Jean Texier (17): kas-poky-rpi: add kas file rpi-base.inc: use wic.bz2 for all rpi machines by default linux-raspberrypi: bump to Linux version 4.19.97 raspberrypi-firmware: bump to version 20200205 linux-raspberrypi: bump to Linux version 4.19.102 linux-raspberrypi: bump to Linux version 4.19.105 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.108 raspberrypi-firmware: update to current HEAD layer.conf: add dunfell to compat layer raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.113 README.md: add status badge for raspberrypi4 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.115 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 4.19.120 rkhan467 (1): mesa: querying dma_buf modifiers for specific formats Change-Id: I956a7aedff5028fa3af56b101ecaad17b3ff64e0 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-raspberrypi/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch')
-rw-r--r--meta-raspberrypi/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta-raspberrypi/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch b/meta-raspberrypi/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch
index 1e6075118..6e2f658d4 100644
--- a/meta-raspberrypi/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch
+++ b/meta-raspberrypi/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch
@@ -1,7 +1,7 @@
-From 407ab0ed315b4c7b49d1a1dd3777d5af8e0b7e66 Mon Sep 17 00:00:00 2001
+From 6172dbb6fd7cf821471d721569abe9a0de0d869d Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sat, 2 Apr 2016 10:37:24 -0700
-Subject: [PATCH 11/19] build shared library for vchostif
+Subject: [PATCH] build shared library for vchostif
Fixes #149
@@ -11,7 +11,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/interface/vmcs_host/CMakeLists.txt b/interface/vmcs_host/CMakeLists.txt
-index ae52495..369758b 100755
+index 16d3184..e54f046 100755
--- a/interface/vmcs_host/CMakeLists.txt
+++ b/interface/vmcs_host/CMakeLists.txt
@@ -15,7 +15,7 @@ set(VCHOSTIF_SOURCE
@@ -22,7 +22,4 @@ index ae52495..369758b 100755
+add_library(vchostif SHARED ${VCHOSTIF_SOURCE})
#add_library(bufman vc_vchi_bufman.c )
-
---
-2.22.0
-
+ set(INSTALL_TARGETS vchostif)