summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-graphics/userland/files/0023-hello_pi-optionally-build-wayland-specific-app.patch
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:54:03 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:54:10 +0300
commit26e4beaa6b6010b921ff99c1a3a7be148fbbfcbc (patch)
treeb57004eafa95be87bda454f13e34458f0a01f9f6 /meta-raspberrypi/recipes-graphics/userland/files/0023-hello_pi-optionally-build-wayland-specific-app.patch
parent7eb438a61ba2d5b3cc7f0ac3fea1ca2e47390529 (diff)
downloadopenbmc-26e4beaa6b6010b921ff99c1a3a7be148fbbfcbc.tar.xz
meta-raspberrypi: subtree update:09a3c11696..3a1fec22c0
Jan-Simon Moeller (1): python3-sense-hat: Switch to using pillow instead of imaging module Jose Quaresma (3): gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin gstreamer1.0-plugins-good: enable rpicamsrc plugin gstreamer1.0-plugins-base: drop custom cppflags Khem Raj (9): linux-raspberrypi: Do not use += with append python3-sense-hat: Move to dynamic-layers layer.conf: Add hardknott (3.3) to acceptable releases linux-raspberrypi_5.4.bb: Update to 5.4.79 raspberrypi-firmware: Update to latest to take 5.4.79 prebuilts userland: Upgrade to latest as of 20201027 raspberrypi-tools: Update to latest on master armstubs: Always use gcc compiler packagegroup-rpi-test: Add python3-sense-hat in a meta-python specific bbappend Madhavan Krishnan (1): libcamera: Enabled camera overlays define based Martin Jansa (3): gstreamer1.0-omx: rename bbappend to match new 1.18.0 version from oe-core layer.conf: Remove older releases from LAYERSERIES_COMPAT Revert "gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin" Ming Liu (1): rpi-u-boot-scr: drop hard-coded 'arm' Paul Barker (9): linux-raspberrypi: Convert dynamic config patching to config fragments sdcard_image-rpi: Drop redundant dependency on rpi-config:do_deploy rpi-cmdline: Move cmdline.txt generation to a separate recipe bootfiles: Use BOOTFILES_DIR_NAME variable rpi-bootfiles: Rename recipe to avoid ambiguity linux-raspberrypi: Remove obsolete kernel versions linux-raspberrypi: Drop unused rpi-kernel-misc config fragment linux-raspberrypi: Merge v5.4 recipe & inc file linux-raspberrypi-dev: Update for testing v5.10.y Trevor Woerner (1): userland: add knob for ALL_APPS Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I90e0cba993e7f5bae2e56f2d40fd2f69211c2648
Diffstat (limited to 'meta-raspberrypi/recipes-graphics/userland/files/0023-hello_pi-optionally-build-wayland-specific-app.patch')
-rw-r--r--meta-raspberrypi/recipes-graphics/userland/files/0023-hello_pi-optionally-build-wayland-specific-app.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-graphics/userland/files/0023-hello_pi-optionally-build-wayland-specific-app.patch b/meta-raspberrypi/recipes-graphics/userland/files/0023-hello_pi-optionally-build-wayland-specific-app.patch
new file mode 100644
index 000000000..642ee86c5
--- /dev/null
+++ b/meta-raspberrypi/recipes-graphics/userland/files/0023-hello_pi-optionally-build-wayland-specific-app.patch
@@ -0,0 +1,28 @@
+From 5f4324a0008c2e8e1f511432f98bf85c9fffd35c Mon Sep 17 00:00:00 2001
+From: Trevor Woerner <twoerner@gmail.com>
+Date: Fri, 27 Nov 2020 03:18:50 -0500
+Subject: [PATCH] hello_pi: optionally build wayland-specific app
+
+Only build the wayland-specific hello_pi app when building for wayland.
+
+Upstream-status: inappropriate [the wayland example is not part of upstream]
+Signed-off-by: Trevor Woerner <twoerner@gmail.com>
+---
+ host_applications/linux/apps/hello_pi/CMakeLists.txt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/host_applications/linux/apps/hello_pi/CMakeLists.txt b/host_applications/linux/apps/hello_pi/CMakeLists.txt
+index 2849fad..7de3265 100644
+--- a/host_applications/linux/apps/hello_pi/CMakeLists.txt
++++ b/host_applications/linux/apps/hello_pi/CMakeLists.txt
+@@ -25,7 +25,9 @@ add_subdirectory(hello_encode)
+ add_subdirectory(hello_jpeg)
+ add_subdirectory(hello_videocube)
+ add_subdirectory(hello_teapot)
+-add_subdirectory(hello_wayland)
++if (BUILD_WAYLAND)
++ add_subdirectory(hello_wayland)
++endif()
+
+ if(BUILD_FONT)
+ set(VGFONT_SRCS libs/vgfont/font.c libs/vgfont/vgft.c libs/vgfont/graphics.c)