summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-06-02 22:47:56 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-06-07 18:15:22 +0300
commita99e9b62f0adc374f48844dc94b4bb41d6a04c90 (patch)
treea779032b8f13a9df563ec3d6bffba083a442882c /meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
parent56f3fd50cbc38581fb53a68268cf531576d5c7ef (diff)
downloadopenbmc-a99e9b62f0adc374f48844dc94b4bb41d6a04c90.tar.xz
meta-raspberrypi: subtree update:8cffbf5e85..ffc402ef5e
Andrei Gherzan (1): layer.conf: Define LAYERDEPENDS Changqing Li (1): 99-com.rules: fix error invalid substitution type Khem Raj (2): linux-firmware-rpidistro: Update to 20190114-1+rpt11 bluez-firmware-rpidistro: Update to 1.2-4+rpt8 Martin Jansa (3): linux-raspberrypi: allow to change the yocto-kernel-cache branch with LINUX_RPI_KMETA_BRANCH linux-raspberrypi-dev: drop protocol=git and add LINUX_RPI_KMETA_BRANCH linux-raspberrypi-dev: use static SRCREV when not selected with PREFERRED_PROVIDER_virtual/kernel Pierre-Jean Texier (1): rpi-base: make SPLASH overridable from outside SCVready (1): rpi-config: comment updated matt-hammond-bbc (1): libva: Fix for when using `userland` sss22213 (1): recipes-bsp: Add support for Raspberry Pi HD quality camera Change-Id: I631fa1d4c12b9f91d5044712b6c2e712fcebd98b Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb')
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb14
1 files changed, 10 insertions, 4 deletions
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
index ff8ce7993..0dfa4519f 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
@@ -7,15 +7,21 @@ python __anonymous() {
LINUX_VERSION ?= "5.10.y"
LINUX_RPI_BRANCH ?= "rpi-5.10.y"
+LINUX_RPI_KMETA_BRANCH ?= "yocto-5.10"
-SRCREV_machine = "${AUTOREV}"
-SRCREV_meta = "${AUTOREV}"
+# Set default SRCREVs. Both the machine and meta SRCREVs are statically set
+# to the as in 5.10 recipe, and hence prevent network access during parsing. If
+# linux-yocto-dev is the preferred provider, they will be overridden to
+# AUTOREV in following anonymous python routine and resolved when the
+# variables are finalized.
+SRCREV_machine ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-raspberrypi-dev", "${AUTOREV}", "89399e6e7e33d6260a954603ca03857df594ffd3", d)}'
+SRCREV_meta ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-raspberrypi-dev", "${AUTOREV}", "a19886b00ea7d874fdd60d8e3435894bb16e6434", d)}'
KMETA = "kernel-meta"
SRC_URI = " \
- git://github.com/raspberrypi/linux.git;name=machine;protocol=git;branch=${LINUX_RPI_BRANCH} \
- git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=master;destsuffix=${KMETA} \
+ git://github.com/raspberrypi/linux.git;name=machine;branch=${LINUX_RPI_BRANCH} \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${LINUX_RPI_KMETA_BRANCH};destsuffix=${KMETA} \
file://powersave.cfg \
file://android-drivers.cfg \
"