summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-kernel/linux
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-08-21 23:56:44 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-21 23:56:46 +0300
commit9d7e0aa351ef830384ea15f50f9ed0a9cf5ededd (patch)
tree4fa64f01f7aa5eecc7b8907dd42c97b42f7d821c /meta-raspberrypi/recipes-kernel/linux
parent472de4c08d44f1c8ebf6975961a98cc2eeef698e (diff)
downloadopenbmc-9d7e0aa351ef830384ea15f50f9ed0a9cf5ededd.tar.xz
meta-raspberrypi: subtree update:e2c1992955..cc6074c660
Andrei Gherzan (1): sdcard_image-rpi.bbclass: Fix when RPI_SDIMG_EXTRA_DEPENDS not defined Christopher Clark (2): sdcard_image-rpi.bbclass: enable extensible inclusion into boot docs/extra-build-config.md: document vars to add to boot partition Fabio Berton (1): u-boot: Move fw_env.config to u-boot append Jakub Luzny (2): rpi-config: Add CAN_OSCILLATOR variable to set mcp2515 crystal frequency docs/extra-build-config.md: Document CAN_OSCILLATOR variable Jeff Ithier (1): Generalize the naming of the bootfiles deploy directory Martin Jansa (1): linux-raspberrypi-5.4: bump SRCREV to latest to fix perf build Pierre-Jean Texier (3): rpi-default-versions: Switch defaults to 5.4 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to revision 4b945d5 Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I50eca26a801bfe014d3cea271f0cb91e7b653445
Diffstat (limited to 'meta-raspberrypi/recipes-kernel/linux')
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc4
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
index 3c3a8e534..f7dee7700 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
@@ -131,10 +131,10 @@ do_compile_append() {
do_deploy_append() {
# Deploy cmdline.txt
- install -d ${DEPLOYDIR}/bcm2835-bootfiles
+ install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}
PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
if [ ${PITFT} = "1" ]; then
PITFT_PARAMS="fbcon=map:10 fbcon=font:VGA8x8"
fi
- echo "${CMDLINE}${PITFT_PARAMS}" > ${DEPLOYDIR}/bcm2835-bootfiles/cmdline.txt
+ echo "${CMDLINE}${PITFT_PARAMS}" > ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/cmdline.txt
}
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
index e039c088a..7fea9dd55 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
@@ -1,7 +1,7 @@
-LINUX_VERSION ?= "5.4.51"
+LINUX_VERSION ?= "5.4.58"
LINUX_RPI_BRANCH ?= "rpi-5.4.y"
-SRCREV = "95a969f451f6ed61029741411c1c9aa44023e465"
+SRCREV = "4592a094787fa6a2ac1e95e96abfe4d7124dbb3a"
require linux-raspberrypi_5.4.inc