summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-kernel
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-10-16 18:13:56 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-10-16 18:13:58 +0300
commit5c4154ffa5fc7b63c57a909685a06a90a5b9c82c (patch)
tree158744d30b9970af4a50ecd384e511a8af77fb1c /meta-raspberrypi/recipes-kernel
parenta9ff2b33c004367b3dbded5d54d7a272ed76f68f (diff)
downloadopenbmc-5c4154ffa5fc7b63c57a909685a06a90a5b9c82c.tar.xz
meta-raspberrypi: subtree update:0e9c32c816..6f85611576
Alex Gonzalez (1): linux-raspberrypi: Only deploy cmdline.txt for the main kernel Khem Raj (7): linux-firmware-rpidistro: Update to 20190114-1+rpt8 linux-raspberrypi_5.4.bb: Update to 5.4.69 raspberrypi-firmware: Update to 20201002 snapshot raspberrypi-tools: Update to latest snapshot as of 20200803 oeqa: Add 5.4 specific error messages to ignore list rpi-default-settings: Replace default parselogs with parselogs_rpi layer.conf: Add gatesgarth to LAYERSERIES_COMPAT Madhavan Krishnan (1): libcamera: Define packageconfig to enable rpi pipeline Martin Jansa (2): linux-raspberrypi-5.4: bump SRCREV to fix raspberrypi3-64 builds python3-rtimu: don't use trailing slash in S Murat Kilivan (1): linux-raspberrypi_5.4.bb: Add kernel-cache source Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I906081b851f3733a52c1899fe2b4e835021f6419
Diffstat (limited to 'meta-raspberrypi/recipes-kernel')
-rw-r--r--meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb9
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc14
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb5
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc5
4 files changed, 22 insertions, 11 deletions
diff --git a/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb b/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
index 833f8f68a..99afde848 100644
--- a/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
+++ b/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
@@ -35,8 +35,8 @@ NO_GENERIC_LICENSE[WHENCE] = "WHENCE"
SRC_URI = "git://github.com/RPi-Distro/firmware-nonfree"
-SRCREV = "616fc2dd4df421e3974179d9e46d45e7006aeb28"
-PV = "20190114-1+rpt6"
+SRCREV = "98e815735e2c805d65994ccc608f399595b74438"
+PV = "20190114-1+rpt8"
S = "${WORKDIR}/git"
@@ -59,6 +59,11 @@ do_install() {
for fw in brcmfmac43430-sdio brcmfmac43455-sdio ; do
install -m 0644 brcm/${fw}.* ${D}${nonarch_base_libdir}/firmware/brcm/
done
+ # add compat links. Fixes errors like
+ # brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt failed with error -2
+ ln -s brcmfmac43455-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt
+ ln -s brcmfmac43455-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt
+ ln -s brcmfmac43430-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43430-sdio.raspberrypi,3-model-b.txt
}
PACKAGES = "\
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
index f7dee7700..3219a231f 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
@@ -130,11 +130,13 @@ do_compile_append() {
}
do_deploy_append() {
- # Deploy cmdline.txt
- install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}
- PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
- if [ ${PITFT} = "1" ]; then
- PITFT_PARAMS="fbcon=map:10 fbcon=font:VGA8x8"
+ # Deploy cmdline.txt only for the main kernel package
+ if [ ${KERNEL_PACKAGE_NAME} = "kernel" ]; then
+ install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}
+ PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
+ if [ ${PITFT} = "1" ]; then
+ PITFT_PARAMS="fbcon=map:10 fbcon=font:VGA8x8"
+ fi
+ echo "${CMDLINE}${PITFT_PARAMS}" > ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/cmdline.txt
fi
- echo "${CMDLINE}${PITFT_PARAMS}" > ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/cmdline.txt
}
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
index 594694cba..e057c3a74 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
@@ -1,7 +1,8 @@
-LINUX_VERSION ?= "5.4.64"
+LINUX_VERSION ?= "5.4.69"
LINUX_RPI_BRANCH ?= "rpi-5.4.y"
-SRCREV = "65caf603f3b1c43f4c92939f7fbb7149e054f486"
+SRCREV_machine = "31d364af258ff9754a1a9c7d8ea532da962797bd"
+SRCREV_meta = "5d52d9eea95fa09d404053360c2351b2b91b323b"
require linux-raspberrypi_5.4.inc
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc
index 232f8a97d..9e8934a70 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc
@@ -1,7 +1,10 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:"
+KMETA = "kernel-meta"
+
SRC_URI = " \
- git://github.com/raspberrypi/linux.git;branch=${LINUX_RPI_BRANCH} \
+ git://github.com/raspberrypi/linux.git;name=machine;branch=${LINUX_RPI_BRANCH} \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.4;destsuffix=${KMETA} \
"
SRC_URI_remove = "file://rpi-kernel-misc.cfg"