summaryrefslogtreecommitdiff
path: root/meta-raspberrypi
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-10 15:51:21 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-10 15:51:21 +0300
commitf76da5003a03ef7d361f05d121731c74fa732fda (patch)
tree2388530a54bcd2a23ae4786525a60dbed5af6b8f /meta-raspberrypi
parentae9284a744c1bfe1b5e90ffb742a37877c2f4776 (diff)
downloadopenbmc-f76da5003a03ef7d361f05d121731c74fa732fda.tar.xz
meta-raspberrypi: subtree update:d34e054d51..afc43769e4
Chris Laplante (2): bcm2835-bootfiles: tighten up dep on rpi-config sdcard_image-rpi.bbclass: make the dep on rpi-config:do_deploy explicit Florin Sarbu (1): linux-firmware-rpidistro_git: Update wifi firmware Change-Id: I8386a0c7fcae9f52b254e9b413ead8e017e379a9 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-raspberrypi')
-rw-r--r--meta-raspberrypi/classes/sdcard_image-rpi.bbclass1
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb2
-rw-r--r--meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro/0001-brcmfmac43455-sdio.txt-Follow-raspbian-change-for-bo.patch39
-rw-r--r--meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb17
4 files changed, 7 insertions, 52 deletions
diff --git a/meta-raspberrypi/classes/sdcard_image-rpi.bbclass b/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
index dc625a310..d3447689a 100644
--- a/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
+++ b/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
@@ -55,6 +55,7 @@ do_image_rpi_sdimg[depends] = " \
dosfstools-native:do_populate_sysroot \
virtual/kernel:do_deploy \
${IMAGE_BOOTLOADER}:do_deploy \
+ rpi-config:do_deploy \
${@bb.utils.contains('MACHINE_FEATURES', 'armstub', 'armstubs:do_deploy', '' ,d)} \
${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot:do_deploy', '',d)} \
${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'rpi-u-boot-scr:do_deploy', '',d)} \
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb b/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
index 0d636f046..bbaf61906 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
@@ -34,6 +34,8 @@ do_deploy() {
touch ${DEPLOYDIR}/${PN}/${PN}-${PV}.stamp
}
+do_deploy[depends] += "rpi-config:do_deploy"
+
addtask deploy before do_build after do_install
do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
diff --git a/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro/0001-brcmfmac43455-sdio.txt-Follow-raspbian-change-for-bo.patch b/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro/0001-brcmfmac43455-sdio.txt-Follow-raspbian-change-for-bo.patch
deleted file mode 100644
index 1ad0fd1b2..000000000
--- a/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro/0001-brcmfmac43455-sdio.txt-Follow-raspbian-change-for-bo.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From c9d4f263131cb8e62597e0a296968b5cdbfe0019 Mon Sep 17 00:00:00 2001
-From: Andrei Gherzan <andrei@gherzan.ro>
-Date: Thu, 27 Jun 2019 20:49:10 +0100
-Subject: [PATCH] brcmfmac43455-sdio.txt: Follow raspbian change for
- boardflags3
-
-Without this change the WiFi interface on RPi4 never comes up. Also the
-upstream repository doesn't include this change. It is only (as far as I
-know) part of the raspberrypi deb repository with the following
-changelog:
-
-firmware-nonfree (1:20190114-1+rpt2) buster; urgency=medium
- * Update brcmfmac43455-sdio.txt
- - Update boardflags3
- -- Serge Schneider <serge@raspberrypi.org> Thu, 18 Apr 2019 14:35:34
-+0100
-
-Upstream-status: Pending
-Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
----
- brcm/brcmfmac43455-sdio.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/brcm/brcmfmac43455-sdio.txt b/brcm/brcmfmac43455-sdio.txt
-index 54d9321..6801286 100644
---- a/brcm/brcmfmac43455-sdio.txt
-+++ b/brcm/brcmfmac43455-sdio.txt
-@@ -21,7 +21,7 @@ btc_mode=1
- # bit1 for btcoex
- boardflags=0x00480201
- boardflags2=0x40800000
--boardflags3=0x48200100
-+boardflags3=0x44200100
- phycal_tempdelta=15
- rxchain=1
- txchain=1
---
-2.17.1
-
diff --git a/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb b/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
index 39ffbf54b..2bc55223b 100644
--- a/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
+++ b/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
@@ -25,7 +25,7 @@ LICENSE = "\
"
LIC_FILES_CHKSUM = "\
file://LICENCE.broadcom_bcm43xx;md5=3160c14df7228891b868060e1951dfbc \
- file://WHENCE;md5=a9c2c217f513c20e1d16b384b3e2c12d \
+ file://WHENCE;md5=7b12b2224438186e4c97c4c7f3a5cc28 \
"
# These are not common licenses, set NO_GENERIC_LICENSE for them
@@ -33,11 +33,9 @@ LIC_FILES_CHKSUM = "\
NO_GENERIC_LICENSE[Firmware-broadcom_bcm43xx-rpidistro] = "LICENCE.broadcom_bcm43xx"
NO_GENERIC_LICENSE[WHENCE] = "WHENCE"
-SRC_URI = " \
- git://github.com/RPi-Distro/firmware-nonfree \
- file://0001-brcmfmac43455-sdio.txt-Follow-raspbian-change-for-bo.patch \
- "
-SRCREV = "b518de45ced519e8f7a499f4778100173402ae43"
+SRC_URI = "git://github.com/RPi-Distro/firmware-nonfree"
+
+SRCREV = "f0ad1a42b051aa9da1d9e1dc606dd68ec2f163a5"
PV = "0.0+git${SRCPV}"
S = "${WORKDIR}/git"
@@ -46,13 +44,6 @@ inherit allarch
CLEANBROKEN = "1"
-do_unpack_append() {
- bb.build.exec_func('do_clean_pc', d)
-}
-do_clean_pc() {
- rm -rf ${S}/.pc
-}
-
do_compile() {
:
}