summaryrefslogtreecommitdiff
path: root/meta-security/meta-parsec
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
commitd73e39703a0260c8911cb439b579e1c2bada4b20 (patch)
tree4fa9f965ae954c587ab773ecaced6b8f8e18d359 /meta-security/meta-parsec
parent6f106a0a4ce15fe0678d4ffefd572e6978c72597 (diff)
parent6d8c5d2c6204714ca6b7a43f04348162b683cdbc (diff)
downloadopenbmc-d73e39703a0260c8911cb439b579e1c2bada4b20.tar.xz
Merge tag '0.75' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-security/meta-parsec')
-rw-r--r--meta-security/meta-parsec/README.md8
-rw-r--r--meta-security/meta-parsec/conf/layer.conf4
-rw-r--r--meta-security/meta-parsec/recipes-parsec/parsec-service/parsec-service_0.7.0.bb10
3 files changed, 11 insertions, 11 deletions
diff --git a/meta-security/meta-parsec/README.md b/meta-security/meta-parsec/README.md
index a2736b694..24958ac0a 100644
--- a/meta-security/meta-parsec/README.md
+++ b/meta-security/meta-parsec/README.md
@@ -53,7 +53,7 @@ other layers needed. e.g.:
To include the Parsec service into your image add following into the
local.conf:
- IMAGE_INSTALL_append = " parsec-service"
+ IMAGE_INSTALL:append = " parsec-service"
The Parsec service will be deployed into the image built with all the supported
providers and with the default config file from the Parsec repository:
@@ -86,7 +86,7 @@ Manual testing with runqemu
This layer also contains a recipe for pasec-tool which can be used for
manual testing of the Parsec service:
- IMAGE_INSTALL_append += " parsec-tools"
+ IMAGE_INSTALL:append += " parsec-tools"
There are a series of Parsec Demo videos showing how to use parsec-tool
to test the Parsec service base functionality:
@@ -103,7 +103,7 @@ enabled. No changes required for manual testing.
The Software HSM can be used for manual testing of the provider by
including it into your test image:
- IMAGE_INSTALL_append += " softhsm"
+ IMAGE_INSTALL:append += " softhsm"
Inside the running VM:
- Stop Parsec
@@ -134,7 +134,7 @@ systemctl start parsec
The IBM Software TPM service can be used for manual testing of the provider by
including it into your test image:
- IMAGE_INSTALL_append += " ibmswtpm2 tpm2-tools libtss2 libtss2-tcti-mssim"
+ IMAGE_INSTALL:append += " ibmswtpm2 tpm2-tools libtss2 libtss2-tcti-mssim"
Inside the running VM:
- Stop Parsec
diff --git a/meta-security/meta-parsec/conf/layer.conf b/meta-security/meta-parsec/conf/layer.conf
index 2d4aa12fb..2eeb71b0f 100644
--- a/meta-security/meta-parsec/conf/layer.conf
+++ b/meta-security/meta-parsec/conf/layer.conf
@@ -8,7 +8,7 @@ BBFILE_COLLECTIONS += "parsec-layer"
BBFILE_PATTERN_parsec-layer = "^${LAYERDIR}/"
BBFILE_PRIORITY_parsec-layer = "5"
-LAYERSERIES_COMPAT_parsec-layer = "hardknott gatesgarth"
+LAYERSERIES_COMPAT_parsec-layer = "honister"
-LAYERDEPENDS_parsec-layer = "core rust-layer clang-layer tpm-layer"
+LAYERDEPENDS_parsec-layer = "core clang-layer tpm-layer"
BBLAYERS_LAYERINDEX_NAME_parsec-layer = "meta-parsec"
diff --git a/meta-security/meta-parsec/recipes-parsec/parsec-service/parsec-service_0.7.0.bb b/meta-security/meta-parsec/recipes-parsec/parsec-service/parsec-service_0.7.0.bb
index d57a43a5a..5f7a99b42 100644
--- a/meta-security/meta-parsec/recipes-parsec/parsec-service/parsec-service_0.7.0.bb
+++ b/meta-security/meta-parsec/recipes-parsec/parsec-service/parsec-service_0.7.0.bb
@@ -15,7 +15,7 @@ DEPENDS = "tpm2-tss clang-native"
CARGO_BUILD_FLAGS += " --features all-providers,cryptoki/generate-bindings,tss-esapi/generate-bindings"
inherit systemd
-SYSTEMD_SERVICE_${PN} = "parsec.service"
+SYSTEMD_SERVICE:${PN} = "parsec.service"
inherit update-rc.d
INITSCRIPT_NAME = "parsec"
@@ -24,7 +24,7 @@ INITSCRIPT_NAME = "parsec"
# The file should also be included into SRC_URI then
PARSEC_CONFIG ?= "${S}/config.toml"
-do_install_append () {
+do_install:append () {
# Binaries
install -d -m 700 -o parsec -g parsec "${D}${libexecdir}/parsec"
install -m 700 -o parsec -g parsec "${WORKDIR}/build/target/${CARGO_TARGET_SUBDIR}/parsec" ${D}${libexecdir}/parsec/parsec
@@ -52,10 +52,10 @@ do_install_append () {
inherit useradd
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "-r -g parsec -s /bin/false -d ${localstatedir}/lib/parsec parsec"
-GROUPADD_PARAM_${PN} = "-r parsec"
+USERADD_PARAM:${PN} = "-r -g parsec -s /bin/false -d ${localstatedir}/lib/parsec parsec"
+GROUPADD_PARAM:${PN} = "-r parsec"
-FILES_${PN} += " \
+FILES:${PN} += " \
${sysconfdir}/parsec/config.toml \
${libexecdir}/parsec/parsec \
${systemd_unitdir}/system/parsec.service \