summaryrefslogtreecommitdiff
path: root/meta-security/meta-tpm/recipes-tpm/pcr-extend
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-12-17 04:11:34 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-01-09 02:21:44 +0300
commit1a4b7ee28bf7413af6513fb45ad0d0736048f866 (patch)
tree79f6d8ea698cab8f2eaf4f54b793d2ca7a1451ce /meta-security/meta-tpm/recipes-tpm/pcr-extend
parent5b9ede0403237c7dace972affa65cf64a1aadd0e (diff)
downloadopenbmc-1a4b7ee28bf7413af6513fb45ad0d0736048f866.tar.xz
reset upstream subtrees to yocto 2.6
Reset the following subtrees on thud HEAD: poky: 87e3a9739d meta-openembedded: 6094ae18c8 meta-security: 31dc4e7532 meta-raspberrypi: a48743dc36 meta-xilinx: c42016e2e6 Also re-apply backports that didn't make it into thud: poky: 17726d0 systemd-systemctl-native: handle Install wildcards meta-openembedded: 4321a5d libtinyxml2: update to 7.0.1 042f0a3 libcereal: Add native and nativesdk classes e23284f libcereal: Allow empty package 030e8d4 rsyslog: curl-less build with fmhttp PACKAGECONFIG 179a1b9 gtest: update to 1.8.1 Squashed OpenBMC subtree compatibility updates: meta-aspeed: Brad Bishop (1): aspeed: add yocto 2.6 compatibility meta-ibm: Brad Bishop (1): ibm: prepare for yocto 2.6 meta-ingrasys: Brad Bishop (1): ingrasys: set layer compatibility to yocto 2.6 meta-openpower: Brad Bishop (1): openpower: set layer compatibility to yocto 2.6 meta-phosphor: Brad Bishop (3): phosphor: set layer compatibility to thud phosphor: libgpg-error: drop patches phosphor: react to fitimage artifact rename Ed Tanous (4): Dropbear: upgrade options for latest upgrade yocto2.6: update openssl options busybox: remove upstream watchdog patch systemd: Rebase CONFIG_CGROUP_BPF patch Change-Id: I7b1fe71cca880d0372a82d94b5fd785323e3a9e7 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-security/meta-tpm/recipes-tpm/pcr-extend')
-rw-r--r--meta-security/meta-tpm/recipes-tpm/pcr-extend/files/fix_openssl11_build.patch45
-rw-r--r--meta-security/meta-tpm/recipes-tpm/pcr-extend/pcr-extend_git.bb3
2 files changed, 47 insertions, 1 deletions
diff --git a/meta-security/meta-tpm/recipes-tpm/pcr-extend/files/fix_openssl11_build.patch b/meta-security/meta-tpm/recipes-tpm/pcr-extend/files/fix_openssl11_build.patch
new file mode 100644
index 000000000..cf2d43780
--- /dev/null
+++ b/meta-security/meta-tpm/recipes-tpm/pcr-extend/files/fix_openssl11_build.patch
@@ -0,0 +1,45 @@
+Enable building with openssl 1.1
+
+Upstream-Status: Pending
+Signed-off-by: Armin Kuster <akuster808@gmail.com>
+
+Index: git/src/pcr-extend.c
+===================================================================
+--- git.orig/src/pcr-extend.c
++++ git/src/pcr-extend.c
+@@ -118,7 +118,7 @@ dump_buf (FILE *file, char *buf, size_t
+ static unsigned char*
+ sha1_file (FILE *file, unsigned int *hash_len)
+ {
+- EVP_MD_CTX ctx = { 0 };
++ EVP_MD_CTX *ctx = EVP_MD_CTX_new();
+ unsigned char *buf = NULL, *hash = NULL;
+ size_t num_read = 0;
+
+@@ -127,7 +127,7 @@ sha1_file (FILE *file, unsigned int *has
+ perror ("malloc:\n");
+ goto sha1_fail;
+ }
+- if (EVP_DigestInit (&ctx, EVP_sha1 ()) == 0) {
++ if (EVP_DigestInit (ctx, EVP_sha1 ()) == 0) {
+ ERR_print_errors_fp (stderr);
+ goto sha1_fail;
+ }
+@@ -135,7 +135,7 @@ sha1_file (FILE *file, unsigned int *has
+ num_read = fread (buf, 1, BUF_SIZE, file);
+ if (num_read <= 0)
+ break;
+- if (EVP_DigestUpdate (&ctx, buf, num_read) == 0) {
++ if (EVP_DigestUpdate (ctx, buf, num_read) == 0) {
+ ERR_print_errors_fp (stderr);
+ goto sha1_fail;
+ }
+@@ -149,7 +149,7 @@ sha1_file (FILE *file, unsigned int *has
+ perror ("calloc of hash buffer:\n");
+ goto sha1_fail;
+ }
+- if (EVP_DigestFinal (&ctx, hash, hash_len) == 0) {
++ if (EVP_DigestFinal (ctx, hash, hash_len) == 0) {
+ ERR_print_errors_fp (stderr);
+ goto sha1_fail;
+ }
diff --git a/meta-security/meta-tpm/recipes-tpm/pcr-extend/pcr-extend_git.bb b/meta-security/meta-tpm/recipes-tpm/pcr-extend/pcr-extend_git.bb
index 0cc4f6370..f8347b7f1 100644
--- a/meta-security/meta-tpm/recipes-tpm/pcr-extend/pcr-extend_git.bb
+++ b/meta-security/meta-tpm/recipes-tpm/pcr-extend/pcr-extend_git.bb
@@ -9,7 +9,8 @@ DEPENDS = "libtspi"
PV = "0.1+git${SRCPV}"
SRCREV = "c02ad8f628b3d99f6d4c087b402fe31a40ee6316"
-SRC_URI = "git://github.com/flihp/pcr-extend.git "
+SRC_URI = "git://github.com/flihp/pcr-extend.git \
+ file://fix_openssl11_build.patch "
inherit autotools