summaryrefslogtreecommitdiff
path: root/meta-security/recipes-forensic
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-14 20:05:37 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-23 04:26:31 +0300
commiteb8dc40360f0cfef56fb6947cc817a547d6d9bc6 (patch)
treede291a73dc37168da6370e2cf16c347d1eba9df8 /meta-security/recipes-forensic
parent9c3cf826d853102535ead04cebc2d6023eff3032 (diff)
downloadopenbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.tar.xz
[Subtree] Removing import-layers directory
As part of the move to subtrees, need to bring all the import layers content to the top level. Change-Id: I4a163d10898cbc6e11c27f776f60e1a470049d8f Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-security/recipes-forensic')
-rw-r--r--meta-security/recipes-forensic/afflib/afflib_3.6.6.bb30
-rw-r--r--meta-security/recipes-forensic/afflib/files/configure_rm_ms_flags.patch18
-rw-r--r--meta-security/recipes-forensic/libewf/files/gcc5_fix.patch22
-rw-r--r--meta-security/recipes-forensic/libewf/libewf_20140608.bb24
-rw-r--r--meta-security/recipes-forensic/sleuth/files/fix_host_poison.patch23
-rw-r--r--meta-security/recipes-forensic/sleuth/sleuthkit_4.1.3.bb31
6 files changed, 148 insertions, 0 deletions
diff --git a/meta-security/recipes-forensic/afflib/afflib_3.6.6.bb b/meta-security/recipes-forensic/afflib/afflib_3.6.6.bb
new file mode 100644
index 000000000..a826d1d10
--- /dev/null
+++ b/meta-security/recipes-forensic/afflib/afflib_3.6.6.bb
@@ -0,0 +1,30 @@
+SUMMARY = "The Advanced Forensic Format (AFF) is on-disk format for storing computer forensic information."
+HOMEPAGE = "http://www.afflib.org/"
+LICENSE = " BSD-4-Clause & CPL-1.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d1b2c6d0d6908f45d143ef6380727828"
+
+DEPENDS = " zlib ncurses readline openssl libgcrypt"
+
+SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/universe/a/${BPN}/${BPN}_${PV}.orig.tar.gz;name=orig \
+ http://archive.ubuntu.com/ubuntu/pool/universe/a/${BPN}/${BPN}_${PV}-1.1.diff.gz;name=dpatch \
+ file://configure_rm_ms_flags.patch \
+ "
+
+SRC_URI[orig.md5sum] = "b7ff4d2945882018eb1536cad182ad01"
+SRC_URI[orig.sha256sum] = "19cacfd558dc00e11975e820e3c4383b52aabbd5ca081d27bb7994a035d2f4ad"
+SRC_URI[dpatch.md5sum] = "171e871024545b487589e6c85290576f"
+SRC_URI[dpatch.sha256sum] = "db632e254ee51a1e4328cd4449d414eff4795053d4e36bfa8e0020fcb4085cdd"
+
+inherit autotools-brokensep pkgconfig
+
+CPPFLAGS = "-I${STAGING_INCDIR}"
+LDFLAGS = "-L${STAGING_LIBDIR}"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[curl] = "--with-curl=${STAGING_LIBDIR}, --without-curl, curl"
+PACKAGECONFIG[expat] = "--with-expat=${STAGING_LIBDIR}, --without-expat, expat"
+PACKAGECONFIG[fuse] = "--enable-fuse=yes, --enable-fuse=no, fuse"
+PACKAGECONFIG[python] = "--enable-python=yes, --enable-python=no, python"
+
+EXTRA_OECONF += "--enable-s3=no CPPFLAGS=-I${STAGING_INCDIR} LDFLAGS=-L${STAGING_LIBDIR}"
+EXTRA_OEMAKE += "CPPFLAGS='${CPPFLAGS}' LDFLAGS='-L${STAGING_LIBDIR} -I${STAGING_INCDIR}'"
diff --git a/meta-security/recipes-forensic/afflib/files/configure_rm_ms_flags.patch b/meta-security/recipes-forensic/afflib/files/configure_rm_ms_flags.patch
new file mode 100644
index 000000000..ac335001b
--- /dev/null
+++ b/meta-security/recipes-forensic/afflib/files/configure_rm_ms_flags.patch
@@ -0,0 +1,18 @@
+Upstream-Status: Inappropriate [configuration]
+
+remove ms lib options when cross compiling
+
+Signed-Off-By: Armin Kuster <akuster808@gmail.com>
+
+Index: configure.ac
+===================================================================
+--- a.orig/configure.ac
++++ a/configure.ac
+@@ -47,7 +47,6 @@ if test x"${cross_compiling}" = "xno" ;
+ AC_MSG_NOTICE([ LDFLAGS = ${LDFLAGS} ])
+ else
+ AC_MSG_NOTICE([Cross Compiling --- will not update CPPFALGS or LDFLAGS with /usr/local, /opt/local or /sw])
+- LIBS="$LIBS -lws2_32 -lgdi32"
+ fi
+
+ if test -r /bin/uname.exe ; then
diff --git a/meta-security/recipes-forensic/libewf/files/gcc5_fix.patch b/meta-security/recipes-forensic/libewf/files/gcc5_fix.patch
new file mode 100644
index 000000000..0881f25c7
--- /dev/null
+++ b/meta-security/recipes-forensic/libewf/files/gcc5_fix.patch
@@ -0,0 +1,22 @@
+Upstream Status: pending
+
+Don't use inline with gcc 5.0
+
+fixes:
+undefined reference to `libuna_unicode_character_size_to_utf8'
+
+Signed-off-by: Armin Kuster <akuster808@gmail.com>
+
+Index: libuna/libuna_inline.h
+===================================================================
+--- a/libuna/libuna_inline.h
++++ b/libuna/libuna_inline.h
+@@ -27,7 +27,7 @@
+ #if defined( _MSC_VER )
+ #define LIBUNA_INLINE _inline
+
+-#elif defined( __BORLANDC__ ) || defined( __clang__ )
++#elif defined( __BORLANDC__ ) || defined( __clang__ ) || ( __GNUC__ > 4 )
+ #define LIBUNA_INLINE /* inline */
+
+ #else
diff --git a/meta-security/recipes-forensic/libewf/libewf_20140608.bb b/meta-security/recipes-forensic/libewf/libewf_20140608.bb
new file mode 100644
index 000000000..f7dce1296
--- /dev/null
+++ b/meta-security/recipes-forensic/libewf/libewf_20140608.bb
@@ -0,0 +1,24 @@
+SUMMARY = "library with support for Expert Witness Compression Format"
+LICENSE = "LGPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=58c39b26c0549f8e1bb4122173f474cd"
+
+DEPENDS = "virtual/gettext libtool"
+
+SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/universe/libe/${BPN}/${BPN}_${PV}.orig.tar.gz;name=orig \
+ file://gcc5_fix.patch \
+ "
+SRC_URI[orig.md5sum] = "fdf615f23937fad8e02b60b9e3e5fb35"
+SRC_URI[orig.sha256sum] = "d14030ce6122727935fbd676d0876808da1e112721f3cb108564a4d9bf73da71"
+
+inherit autotools-brokensep pkgconfig gettext
+
+PACKAGECONFIG ??= "zlib ssl bz2"
+PACKAGECONFIG[zlib] = "--with-zlib, --without-zlib, zlib, zlib"
+PACKAGECONFIG[bz2] = "--with-bzip2, --without-bzip2, bzip2, bzip2"
+PACKAGECONFIG[ssl] = "--with-openssl, --without-openssl, openssl, openssl"
+PACKAGECONFIG[fuse] = "--with-libfuse, --without-libfuse, fuse"
+PACKAGECONFIG[python] = "--enable-python, --disable-python, python"
+
+EXTRA_OECONF += "--with-gnu-ld --disable-rpath"
+
+RDEPENDS_${PN} += " util-linux-libuuid"
diff --git a/meta-security/recipes-forensic/sleuth/files/fix_host_poison.patch b/meta-security/recipes-forensic/sleuth/files/fix_host_poison.patch
new file mode 100644
index 000000000..03b1fb9e7
--- /dev/null
+++ b/meta-security/recipes-forensic/sleuth/files/fix_host_poison.patch
@@ -0,0 +1,23 @@
+Upstream-Status: Inappropriate [configuration]
+
+Don't use host include or lib paths in *FLAGS
+
+Signed-off-by: Armin Kuster <akuster808@gmail.com>
+
+Index: configure.ac
+===================================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -84,12 +84,6 @@ AX_PTHREAD([
+ LDFLAGS="$LDFLAGS $PTHREAD_CFLAGS"
+ CC="$PTHREAD_CC"],[])
+
+-dnl Not all compilers include /usr/local in the include and link path
+-if test -d /usr/local/include; then
+- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+- LDFLAGS="$LDFLAGS -L/usr/local/lib"
+-fi
+-
+ dnl Add enable/disable option
+ AC_ARG_ENABLE([java],
+ [AS_HELP_STRING([--disable-java], [Do not build the java bindings or jar file])])
diff --git a/meta-security/recipes-forensic/sleuth/sleuthkit_4.1.3.bb b/meta-security/recipes-forensic/sleuth/sleuthkit_4.1.3.bb
new file mode 100644
index 000000000..ba335f3c3
--- /dev/null
+++ b/meta-security/recipes-forensic/sleuth/sleuthkit_4.1.3.bb
@@ -0,0 +1,31 @@
+SUMMARY = "The Sleuth Kit (TSK) is a library and collection of command line tools that allow you to investigate disk images."
+HOMEPAGE = "http://www.sleuthkit.org/sleuthkit/"
+LICENSE = "IPL-1.0 & GPLv2 & CPL-1.0"
+LIC_FILES_CHKSUM = "file://licenses/GNU-COPYING;startline=4;endline=5;md5=475b4784903850b579dc6e6310bd5f08\
+ file://licenses/IBM-LICENSE;startline=1;endline=2;md5=1fc3300388b0d6e6216825dd89c2e3a2\
+ file://licenses/cpl1.0.txt;startline=1;endline=2;md5=9e58c878202c73a4e3ed4be72598fb92"
+
+DEPENDS = "libtool"
+
+SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/universe/s/${BPN}/${BPN}_${PV}.orig.tar.gz;name=orig \
+ file://fix_host_poison.patch \
+ "
+SRC_URI[orig.md5sum] = "139a12f06952d8a40bbe07884994cf5d"
+SRC_URI[orig.sha256sum] = "67f9d2a31a8884d58698d6122fc1a1bfa9bf238582bde2b49228ec9b899f0327"
+
+inherit autotools-brokensep pkgconfig gettext
+
+PACKAGECONFIG ??= "aff zlib ewf"
+PACKAGECONFIG[aff] = "--with-afflib=${STAGING_DIR_HOST}/usr, --without-afflib, afflib"
+PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_DIR_HOST}/usr, --without-zlib, zlib"
+PACKAGECONFIG[ewf] = "--with-libewf=${STAGING_DIR_HOST}/usr, --without-libewf, libewf"
+
+#--with-gnu-ld
+EXTRA_OECONF += "--enable-static=no --disable-java LIBS='-L${STAGING_LIBDIR}' LDFLAGS='-L${STAGING_LIBDIR}' CPPFLAGS='-I${STAGING_INCDIR}'"
+
+# Avoid QA Issue: No GNU_HASH in the elf binary
+INSANE_SKIP_${PN} = "ldflags"
+
+FILES_${PN} += " ${datadir}/tsk"
+
+RDEPENDS_${PN} += " perl"