summaryrefslogtreecommitdiff
path: root/meta-security/recipes-kernel/lkrg/lkrg-module_0.9.0.bb
diff options
context:
space:
mode:
authorjmbills <jasonm.bills@yahoo.com>2021-06-02 20:10:10 +0300
committerGitHub <noreply@github.com>2021-06-02 20:10:10 +0300
commite7436234669703196c5ed56f33050d2dc19127cd (patch)
tree704eb802dc7b987411a0e44d128bdd8978745d8c /meta-security/recipes-kernel/lkrg/lkrg-module_0.9.0.bb
parent2ac88c6ae92b615338771db8a4fcbef91bee0947 (diff)
parent2a64b8ae9b952b18b4aef38cb7c41ce6dba16c50 (diff)
downloadopenbmc-e7436234669703196c5ed56f33050d2dc19127cd.tar.xz
Merge pull request #67 from Intel-BMC/update2021-0.521-0.52
Update
Diffstat (limited to 'meta-security/recipes-kernel/lkrg/lkrg-module_0.9.0.bb')
-rw-r--r--meta-security/recipes-kernel/lkrg/lkrg-module_0.9.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-security/recipes-kernel/lkrg/lkrg-module_0.9.0.bb b/meta-security/recipes-kernel/lkrg/lkrg-module_0.9.0.bb
new file mode 100644
index 000000000..dbc195d35
--- /dev/null
+++ b/meta-security/recipes-kernel/lkrg/lkrg-module_0.9.0.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Linux Kernel Runtime Guard"
+DESCRIPTION="LKRG performs runtime integrity checking of the Linux \
+kernel and detection of security vulnerability exploits against the kernel."
+SECTION = "security"
+HOMEPAGE = "https://www.openwall.com/lkrg/"
+LICENSE = "GPLv2"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d931f44a1f4be309bcdac742d7ed92f9"
+
+DEPENDS = "virtual/kernel elfutils"
+
+SRC_URI = "https://www.openwall.com/lkrg/lkrg-${PV}.tar.gz \
+ file://makefile_cleanup.patch "
+
+SRC_URI[sha256sum] = "a997e4d98962c359f3af163bbcfa38a736d2a50bfe35c15065b74cb57f8742bf"
+
+S = "${WORKDIR}/lkrg-${PV}"
+
+inherit module kernel-module-split
+
+MAKE_TARGETS = "modules"
+
+MODULE_NAME = "p_lkrg"
+
+module_do_install() {
+ install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
+ install -m 0644 ${MODULE_NAME}.ko \
+ ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
+}
+
+RPROVIDES_${PN} += "kernel-module-lkrg"
+
+COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"