summaryrefslogtreecommitdiff
path: root/meta-security/recipes-mac/AppArmor/files/crosscompile_perl_bindings.patch
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-04-15 23:11:05 +0300
committerEd Tanous <ed.tanous@intel.com>2019-04-15 23:11:05 +0300
commita75bff085ba9443315222231c42692745e5781e9 (patch)
treee1aa422babae0dffc866af076a0274ff26c2c4b2 /meta-security/recipes-mac/AppArmor/files/crosscompile_perl_bindings.patch
parent3e809d0d5cf96c18c5720d1b6b3b53e9f4c0cfae (diff)
parent6d4bcf0a75b2a6055055c9ad8ed6b93599082385 (diff)
downloadopenbmc-a75bff085ba9443315222231c42692745e5781e9.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into intel
Diffstat (limited to 'meta-security/recipes-mac/AppArmor/files/crosscompile_perl_bindings.patch')
-rw-r--r--meta-security/recipes-mac/AppArmor/files/crosscompile_perl_bindings.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-security/recipes-mac/AppArmor/files/crosscompile_perl_bindings.patch b/meta-security/recipes-mac/AppArmor/files/crosscompile_perl_bindings.patch
new file mode 100644
index 000000000..ef55de717
--- /dev/null
+++ b/meta-security/recipes-mac/AppArmor/files/crosscompile_perl_bindings.patch
@@ -0,0 +1,25 @@
+Upstream-Status: Inappropriate [configuration]
+
+As we're cross-compiling here we need to override CC/LD that MakeMaker has
+stuck in the generated Makefile with our cross tools. In this case, linking is
+done via the compiler rather than the linker directly so pass in CC not LD
+here.
+
+Signed-Off-By: Tom Rini <trini@konsulko.com>
+
+--- a/libraries/libapparmor/swig/perl/Makefile.am.orig 2017-06-13 19:04:43.296676212 -0400
++++ b/libraries/libapparmor/swig/perl/Makefile.am 2017-06-13 19:05:03.488676693 -0400
+@@ -16,11 +16,11 @@
+
+ LibAppArmor.so: libapparmor_wrap.c Makefile.perl
+ if test ! -f libapparmor_wrap.c; then cp $(srcdir)/libapparmor_wrap.c . ; fi
+- $(MAKE) -fMakefile.perl
++ $(MAKE) -fMakefile.perl CC='$(CC)' LD='$(CC)'
+ if test $(top_srcdir) != $(top_builddir) ; then rm -f libapparmor_wrap.c ; fi
+
+ install-exec-local: Makefile.perl
+- $(MAKE) -fMakefile.perl install_vendor
++ $(MAKE) -fMakefile.perl install_vendor CC='$(CC)' LD='$(CC)'
+
+ # sadly there is no make uninstall for perl
+ #uninstall-local: Makefile.perl