summaryrefslogtreecommitdiff
path: root/meta-security/recipes-security/checksec/checksec_2.1.0.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-01 22:21:06 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-01 22:21:07 +0300
commit49e29a10ccf9979817e7c40b903e7c7925ab2e5c (patch)
treee425e17846a1bbe48def05d872841610568584cd /meta-security/recipes-security/checksec/checksec_2.1.0.bb
parent0f291cce3faf2fd387c0db8f04bd2f9f4187f6df (diff)
downloadopenbmc-49e29a10ccf9979817e7c40b903e7c7925ab2e5c.tar.xz
meta-security: subtree update:6d399b34ab..30ea7a89dc
Adrian Bunk (2): xmlsec1: Remove, moved to meta-oe libenv-perl: Remove, moved to meta-perl Armin Kuster (3): apparmor: fix RDPENDS apparmor: update to 2.13.3 integrity-image: IMA_EVM_KEY_DIR has no affect, remove Qi.Chen@windriver.com (2): ecryptfs-utils: remove openssl PACKAGECONFIG ecryptfs-utils: fix race condition in do_install Yuan Chao (2): python-scapy: upgrade 2.4.2 -> 2.4.3 checksec: upgrade 1.11.1 -> 2.1.0 Change-Id: I888703dc3a3df6fa0da471e1d112f9d88dcdc44b Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-security/recipes-security/checksec/checksec_2.1.0.bb')
-rw-r--r--meta-security/recipes-security/checksec/checksec_2.1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-security/recipes-security/checksec/checksec_2.1.0.bb b/meta-security/recipes-security/checksec/checksec_2.1.0.bb
new file mode 100644
index 000000000..5c6528e48
--- /dev/null
+++ b/meta-security/recipes-security/checksec/checksec_2.1.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Linux system security checks"
+DESCRIPTION = "The checksec script is designed to test what standard Linux OS and PaX security features are being used."
+SECTION = "security"
+LICENSE = "BSD"
+HOMEPAGE="https://github.com/slimm609/checksec.sh"
+
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=93fddcca19f6c897871f9b5f9a035f4a"
+
+SRCREV = "04582bad41589ad479ca8b1f0170ed317475b5a5"
+SRC_URI = "git://github.com/slimm609/checksec.sh"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/checksec ${D}${bindir}
+}
+
+RDEPENDS_${PN} = "bash openssl-bin"