summaryrefslogtreecommitdiff
path: root/meta-security/recipes-security/fscryptctl/fscryptctl_1.0.0.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-04-19 22:02:49 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-04-19 22:02:49 +0300
commit36caa12533da01d4319c5ffe7613711a0ec7dea7 (patch)
tree591c2077bb14cfd9d23893d32cca71fa7a01bc9c /meta-security/recipes-security/fscryptctl/fscryptctl_1.0.0.bb
parent12bef3e1bf292dec5ac15af9fb41e86f7bcfb0cb (diff)
parent3cec7f5a630c1ddcad058eb76e1f732a5fa20d59 (diff)
downloadopenbmc-36caa12533da01d4319c5ffe7613711a0ec7dea7.tar.xz
Merge tag '0.45' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-security/recipes-security/fscryptctl/fscryptctl_1.0.0.bb')
-rw-r--r--meta-security/recipes-security/fscryptctl/fscryptctl_1.0.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-security/recipes-security/fscryptctl/fscryptctl_1.0.0.bb b/meta-security/recipes-security/fscryptctl/fscryptctl_1.0.0.bb
new file mode 100644
index 000000000..440b4e34c
--- /dev/null
+++ b/meta-security/recipes-security/fscryptctl/fscryptctl_1.0.0.bb
@@ -0,0 +1,27 @@
+SUMMARY = "low-level tool handling Linux filesystem encryption"
+DESCIPTION = "fscryptctl is a low-level tool written in C that handles raw keys and manages \
+policies for Linux filesystem encryption (https://lwn.net/Articles/639427). \
+For a tool that presents a higher level interface and manages metadata, key \
+generation, key wrapping, PAM integration, and passphrase hashing, see \
+fscrypt (https://github.com/google/fscrypt)."
+HOMEPAGE = "https://github.com/google/fscryptctl"
+SECTION = "base"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRCREV = "56b898c896240328adef7407090215abbe9ee03d"
+SRC_URI = "git://github.com/google/fscryptctl.git"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ oe_runmake DESTDIR=${D}${bindir} install
+}
+
+RRECOMMENDS_${PN} += "\
+ keyutils \
+ kernel-module-cbc \
+ kernel-module-cts \
+ kernel-module-ecb \
+ kernel-module-xts \
+"