summaryrefslogtreecommitdiff
path: root/meta-xilinx/meta-microblaze/recipes-devtools/gcc/gcc-source_10.%.bbappend
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-10-16 18:11:54 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-10-16 18:11:54 +0300
commita9ff2b33c004367b3dbded5d54d7a272ed76f68f (patch)
treea3c47ab3a1b1af411639ea6221a680f5f3cb490d /meta-xilinx/meta-microblaze/recipes-devtools/gcc/gcc-source_10.%.bbappend
parent9129b24a007278f4002886e4734bc217603f14ce (diff)
downloadopenbmc-a9ff2b33c004367b3dbded5d54d7a272ed76f68f.tar.xz
reset meta-xilinx subtree on master HEAD(874b9cee5e)
Change-Id: Ic0716e95ff53e7d63c54dc5fce6ee42fc99ed424
Diffstat (limited to 'meta-xilinx/meta-microblaze/recipes-devtools/gcc/gcc-source_10.%.bbappend')
-rw-r--r--meta-xilinx/meta-microblaze/recipes-devtools/gcc/gcc-source_10.%.bbappend63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta-xilinx/meta-microblaze/recipes-devtools/gcc/gcc-source_10.%.bbappend b/meta-xilinx/meta-microblaze/recipes-devtools/gcc/gcc-source_10.%.bbappend
new file mode 100644
index 000000000..79b895fc5
--- /dev/null
+++ b/meta-xilinx/meta-microblaze/recipes-devtools/gcc/gcc-source_10.%.bbappend
@@ -0,0 +1,63 @@
+# Add MicroBlaze Patches (only when using MicroBlaze)
+FILESEXTRAPATHS_append_microblaze := ":${THISDIR}/gcc-10"
+
+SRC_URI_append_microblaze = " \
+ file://0001-LOCAL-Testsuite-builtins-tests-require-fpic.patch \
+ file://0002-LOCAL-Quick-fail-g-.dg-opt-memcpy1.C.patch \
+ file://0003-LOCAL-Testsuite-explicitly-add-fivopts-for-tests-tha.patch \
+ file://0004-LOCAL-For-dejagnu-static-testing-on-qemu-suppress-wa.patch \
+ file://0005-Patch-testsuite-Add-MicroBlaze-to-target-supports-fo.patch \
+ file://0006-Patch-testsuite-Update-MicroBlaze-strings-test.patch \
+ file://0007-Patch-testsuite-Allow-MicroBlaze-.weakext-pattern-in.patch \
+ file://0008-Patch-testsuite-Add-MicroBlaze-to-check_profiling_av.patch \
+ file://0009-Patch-microblaze-Fix-atomic-side-effects.patch \
+ file://0010-Patch-microblaze-Fix-atomic-boolean-return-value.patch \
+ file://0011-Patch-microblaze-Fix-the-Microblaze-crash-with-msmal.patch \
+ file://0012-Patch-microblaze-Added-ashrsi3_with_size_opt.patch \
+ file://0013-Patch-microblaze-Use-bralid-for-profiler-calls.patch \
+ file://0014-Patch-microblaze-Disable-fivopts-by-default.patch \
+ file://0015-Patch-microblaze-Removed-moddi3-routinue.patch \
+ file://0016-Patch-microblaze-Add-INIT_PRIORITY-support.patch \
+ file://0017-Patch-microblaze-Add-optimized-lshrsi3.patch \
+ file://0018-Patch-microblaze-Reducing-Stack-space-for-arguments.patch \
+ file://0019-Patch-microblaze-Add-cbranchsi4_reg.patch \
+ file://0020-Patch-microblaze-Inline-Expansion-of-fsqrt-builtin.patch \
+ file://0021-Patch-OPT-Update-heuristics-for-loop-invariant-for-a.patch \
+ file://0022-PATCH-microblaze.md-Improve-adddi3-and-subdi3-insn-d.patch \
+ file://0023-Patch-microblaze-Update-ashlsi3-movsf-patterns.patch \
+ file://0024-Patch-microblaze-8-stage-pipeline-for-microblaze.patch \
+ file://0025-Patch-rtl-Optimization-Better-register-pressure-esti.patch \
+ file://0026-Patch-microblaze-Correct-the-const-high-double-immed.patch \
+ file://0027-Fix-microblaze-Fix-internal-compiler-error-with-msma.patch \
+ file://0028-patch-microblaze-Fix-the-calculation-of-high-word-in.patch \
+ file://0029-Patch-microblaze-Add-new-bit-field-instructions.patch \
+ file://0030-Patch-microblaze-Fix-bug-in-MB-version-calculation.patch \
+ file://0031-Fixing-the-issue-with-the-builtin_alloc.patch \
+ file://0032-Patch-Microblaze-update-in-constraints-for-bitfield-.patch \
+ file://0033-Patch-Microblaze-Removed-fsqrt-generation-for-double.patch \
+ file://0034-Intial-commit-of-64-bit-Microblaze.patch \
+ file://0035-Intial-commit-for-64bit-MB-sources.patch \
+ file://0036-re-arrangement-of-the-compare-branches.patch \
+ file://0037-Patch-Microblaze-previous-commit-broke-the-handling-.patch \
+ file://0038-Patch-Microblaze-Support-of-multilibs-with-m64.patch \
+ file://0039-Fix-various-issues.patch \
+ file://0040-Fixed-below-issues.patch \
+ file://0041-Fix-various.patch \
+ file://0042-Fixed-the-issue-in-the-delay-slot-with-swap-instruct.patch \
+ file://0043-Fixed-the-load-store-issue-with-the-32bit-arith-libr.patch \
+ file://0044-extending-the-Dwarf-support-to-64bit-Microblaze.patch \
+ file://0045-fixing-the-typo-errors-in-umodsi3-file.patch \
+ file://0046-fixing-the-32bit-LTO-related-issue9-1014024.patch \
+ file://0047-Fixed-the-missing-stack-adjustment-in-prologue-of-mo.patch \
+ file://0048-Patch-Microblaze-corrected-SPN-for-dlong-instruction.patch \
+ file://0049-fixing-the-long-long-long-mingw-toolchain-issue.patch \
+ file://0050-Fix-the-MB-64-bug-of-handling-QI-objects.patch \
+ file://0051-Patch-Microblaze-Check-the-possibiity-of-peephole2-o.patch \
+ file://0052-Patch-MicroBlaze-fixed-typos-in-mul-div-and-mod-asse.patch \
+ file://0053-Patch-microblaze-MB-64-removal-of-barrel-shift-instr.patch \
+ file://0054-Patch-microblaze-Add-TARGET_OPTION_OPTIMIZATION-and-.patch \
+ file://0055-Added-new-MB-64-single-register-arithmetic-instructi.patch \
+ file://0056-Patch-MicroBlaze-Added-support-for-64-bit-Immediate-.patch \
+ file://0057-Patch-microblaze-Fix-Compiler-crash-with-freg-struct.patch \
+ file://0058-microblaze-Avoid-UINTPTR_TYPE-macro-redefinition.patch \
+"