summaryrefslogtreecommitdiff
path: root/meta-xilinx/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-12-12 01:25:29 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-12-12 01:25:34 +0300
commit10fa14942b9cb27780f9496382107516639208b4 (patch)
treef4b195505178e47c4b21ece7b3a898d9402b2daa /meta-xilinx/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc
parent6d8913e6c02e578d4e41b7fe88113f4e4822992d (diff)
downloadopenbmc-10fa14942b9cb27780f9496382107516639208b4.tar.xz
meta-xilinx: subtree update:569f52f275..b3e37df5d9
Mark Hatle (11): meta-microblaze: Move gcc patch that was missed in the prior work Uprev standalone toolchain bbappends pmu-firmware: Latest toolchain always treats 'assert' as a macro binutils: update to early gatesgarth version gdb: update to early gatesgarth version gcc: update to early gatesgarth version newlib: update to early gatesgarth version machine/aarch64-tc.conf: Fix incorrect ilp32 pkgarch libgcc.bbappend: Clear empty lib directory newlib: Upstream now disabled builtin symbols gdb: Fix on-target GDB compilation Sai Hari Chandana Kalluri (5): linux-xlnx_2020.2: Fix previous git cherry-pick xrt: Remove stale patch to fix endian issues with latest version of boost opencl-clhpp, ocl-icd: Remove recipes from meta-xilinx esw.bbclass: Remove trailing / after S Remove recipe bbappends pointing to older versions Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I18b028388a5b55a49ef135b98290228fa797e38d
Diffstat (limited to 'meta-xilinx/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc')
-rw-r--r--meta-xilinx/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc83
1 files changed, 51 insertions, 32 deletions
diff --git a/meta-xilinx/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc b/meta-xilinx/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc
index 906ef4dbe..4ba5d98cf 100644
--- a/meta-xilinx/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc
+++ b/meta-xilinx/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc
@@ -5,35 +5,54 @@ LTTNGUST_microblaze = ""
FILESEXTRAPATHS_append := ":${THISDIR}/gdb"
SRC_URI_append_microblaze = " \
- file://0001-sim-Allow-microblaze-architecture.patch \
- file://0002-Add-wdc.ext.clear-and-wdc.ext.flush-insns.patch \
- file://0004-Disable-the-warning-message-for-eh_frame_hdr.patch \
- file://0005-Fix-relaxation-of-assembler-resolved-references.patch \
- file://0006-microblaze-Fixup-debug_loc-sections-after-linker-rel.patch \
- file://0007-upstream-change-to-garbage-collection-sweep-causes-m.patch \
- file://0008-Fix-bug-in-TLSTPREL-Relocation.patch \
- file://0009-Added-Address-extension-instructions.patch \
- file://0010-Add-new-bit-field-instructions.patch \
- file://0011-fixing-the-imm-bug.patch \
- file://0015-intial-commit-of-MB-64-bit.patch \
- file://0016-MB-X-initial-commit.patch \
- file://0017-Patch-Microblaze-negl-instruction-is-overriding-rsub.patch \
- file://0018-Added-relocations-for-MB-X.patch \
- file://0019-Update-MB-x.patch \
- file://0020-Various-fixes.patch \
- file://0021-Adding-new-relocation-to-support-64bit-rodata.patch \
- file://0022-fixing-the-.bss-relocation-issue.patch \
- file://0023-Fixed-the-bug-in-the-R_MICROBLAZE_64_NONE-relocation.patch \
- file://0025-Patch-Microblaze-Binutils-security-check-is-causing-.patch \
- file://0026-fixing-the-long-long-long-mingw-toolchain-issue.patch \
- file://0027-Added-support-to-new-arithmetic-single-register-inst.patch \
- file://0028-Patch-MicroBlaze-double-imml-generation-for-64-bit-v.patch \
- file://0033-Fix-various-compile-warnings.patch \
- file://0034-Add-initial-port-of-linux-gdbserver.patch \
- file://0035-Initial-port-of-core-reading-support.patch \
- file://0036-Fix-debug-message-when-register-is-unavailable.patch \
- file://0037-microblaze-Add-build_gdbserver-yes-to-top-level-conf.patch \
- file://0038-Initial-support-for-native-gdb.patch \
- file://0039-Fixing-the-issues-related-to-GDB-7.12.patch \
- file://0040-Patch-microblaze-Adding-64-bit-MB-support.patch \
- "
+ file://0001-Add-wdc.ext.clear-and-wdc.ext.flush-insns.patch \
+ file://0003-Disable-the-warning-message-for-eh_frame_hdr.patch \
+ file://0004-LOCAL-Fix-relaxation-of-assembler-resolved-reference.patch \
+ file://0005-upstream-change-to-garbage-collection-sweep-causes-m.patch \
+ file://0006-Fix-bug-in-TLSTPREL-Relocation.patch \
+ file://0007-Added-Address-extension-instructions.patch \
+ file://0008-fixing-the-MAX_OPCODES-to-correct-value.patch \
+ file://0009-Add-new-bit-field-instructions.patch \
+ file://0010-fixing-the-imm-bug.patch \
+ file://0014-intial-commit-of-MB-64-bit.patch \
+ file://0015-MB-X-initial-commit.patch \
+ file://0016-Patch-Microblaze-negl-instruction-is-overriding-rsub.patch \
+ file://0017-Added-relocations-for-MB-X.patch \
+ file://0018-Fixed-MB-x-relocation-issues.patch \
+ file://0019-Fixing-the-branch-related-issues.patch \
+ file://0020-Fixed-address-computation-issues-with-64bit-address.patch \
+ file://0021-Adding-new-relocation-to-support-64bit-rodata.patch \
+ file://0022-fixing-the-.bss-relocation-issue.patch \
+ file://0023-Fixed-the-bug-in-the-R_MICROBLAZE_64_NONE-relocation.patch \
+ file://0025-fixing-the-long-long-long-mingw-toolchain-issue.patch \
+ file://0026-Added-support-to-new-arithmetic-single-register-inst.patch \
+ file://0027-Patch-MicroBlaze-double-imml-generation-for-64-bit-v.patch \
+ file://0032-ld-emulparams-elf64microblaze-Fix-emulation-generati.patch \
+ file://0033-Add-initial-port-of-linux-gdbserver-add-gdb_proc_ser.patch \
+ file://0034-Initial-port-of-core-reading-support-Added-support-f.patch \
+ file://0035-Fix-debug-message-when-register-is-unavailable.patch \
+ file://0036-revert-master-rebase-changes-to-gdbserver.patch \
+ file://0037-revert-master-rebase-changes-to-gdbserver-previous-c.patch \
+ file://0038-microblaze-Add-build_gdbserver-yes-to-top-level-conf.patch \
+ file://0039-Initial-support-for-native-gdb.patch \
+ file://0040-Fixing-the-issues-related-to-GDB-7.12-added-all-the-.patch \
+ file://0041-Adding-64-bit-MB-support-Added-new-architecture-to-M.patch \
+ file://0042-porting-GDB-for-linux.patch \
+ file://0043-Binutils-security-check-is-causing-build-error-for-w.patch \
+ file://0044-Correcting-the-register-names-from-slr-shr-to-rslr-r.patch \
+ file://0045-Removing-the-header-gdb_assert.h-from-MB-target-file.patch \
+ file://0046-bfd-cpu-microblaze.c-Enhance-disassembler.patch \
+ file://0047-bfd-elf64-microblaze.c-Fix-build-failures.patch \
+ file://0048-bfd-elf-microblaze.c-Remove-obsolete-entries.patch \
+ file://0049-bfd-elf64-microblaze.c-Resolve-various-compiler-warn.patch \
+ file://0050-opcodes-microblaze-dis.c-Fix-compile-warnings.patch \
+ file://0051-gdb-microblaze-tdep.c-Remove-unused-functions.patch \
+ file://0052-sim-Allow-microblaze-architecture.patch \
+ file://0053-gdb-Fix-microblaze-target-compilation.patch \
+ "
+
+#
+## file://0048-bfd-gas-Use-standard-method-to-set-the-machine-arch.patch \
+## file://0052-opcodes-microblaze-opc.h-Expand-the-size-to-int-to-d.patch \
+## file://0053-opcodes-microblaze-opc.h-MIN_IMML-is-too-large.patch \
+#