summaryrefslogtreecommitdiff
path: root/meta-xilinx/meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2020.2.bb
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:53:16 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:53:21 +0300
commit7eb438a61ba2d5b3cc7f0ac3fea1ca2e47390529 (patch)
treef3aee6c10811ebe6196859c998bd78d8dad36589 /meta-xilinx/meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2020.2.bb
parenta59e4ee570958d218c22cd0513fbaefcf4a27563 (diff)
downloadopenbmc-7eb438a61ba2d5b3cc7f0ac3fea1ca2e47390529.tar.xz
meta-xilinx: subtree update:874b9cee5e..569f52f275
Jaewon Lee (1): xilinx-board.inc: Introducing inc file to add BOARD/BOARD_VARIANT Madhurkiran Harikrishnan (2): weston.ini: Do not set hard requirement for input devices libmali-xlnx: Update the mali userspace libraries to 2020.2 Mark Hatle (2): libmali-xlnx: Fix the package arch Various: Packages using libGL may need to be declared SOC_VARIANT_ARCH Raju Kumar Pothuraju (1): versal-generic.conf:zynqmp-generic.conf: Add MACHINE_ESSENTIAL_EXTRA_RDEPENDS variable only for specific machines. Sai Hari Chandana Kalluri (7): Add meta-python2 in bblayers.conf xrt_git.bb: Replace deprecated boost macros perf: Fix compilation issues Fix perf variable definition and libtraceevent with binutils. The above errors are fixed by including the following patches to the kernel tree: 0001-libtraceevent-Fix-build-with-binutils-2.35.patch 0001-perf-bench-Share-some-global-variables-to-fix-build-.patch 0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch 0001-perf-tests-bp_account-Make-global-variable-static.patch opencv_3.4.3: Remove support for opencv 3.4 Update commit id and branch for components for 2020.2 release update XILINX_VER_MAIN to 2020.2 bootgen: Update commit id for 2020.2 release Sandeep Gundlupet Raju (1): kernel-module-dp: Add support for Xilinx DP drivers Vishal Sagar (1): kernel-module-hdmi: Update commit id and license md5sum for 2020.2 ch vamshi krishna (3): updating xrt commit id updating final XRT commit id for 2020.2 updating XRT/Zocl commit id for 2020.2 rbramand (1): ] CR-1076958 Put libxrt libs softlinks in the main package Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I4c6b12024c4d07388334e29177417e34fe6dea87
Diffstat (limited to 'meta-xilinx/meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2020.2.bb')
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2020.2.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2020.2.bb b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2020.2.bb
new file mode 100644
index 000000000..6a2ca7cc4
--- /dev/null
+++ b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2020.2.bb
@@ -0,0 +1,48 @@
+SUMMARY = "KC705 Pre-built Bitstream"
+DESCRIPTION = "A Pre-built bitstream for the KC705, which is capable of booting a Linux system."
+HOMEPAGE = "http://www.xilinx.com"
+SECTION = "bsp"
+
+# The BSP package does not include any license information.
+LICENSE = "Proprietary"
+LICENSE_FLAGS = "xilinx"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+
+COMPATIBLE_MACHINE = "kc705-microblazeel"
+
+inherit deploy
+inherit xilinx-fetch-restricted
+
+BSP_NAME = "xilinx-kc705"
+BSP_FILE = "${BSP_NAME}-v${PV}-final.bsp"
+SRC_URI = "https://www.xilinx.com/member/forms/download/xef.html?filename=${BSP_FILE};downloadfilename=${BSP_FILE}"
+SRC_URI[md5sum] = "5c0365a8a26cc27b4419aa1d7dd82351"
+SRC_URI[sha256sum] = "a909a91a37a9925ee2f972ccb10f986a26ff9785c1a71a483545a192783bf773"
+
+PROVIDES = "virtual/bitstream"
+
+FILES_${PN} += "/boot/download.bit"
+
+INHIBIT_DEFAULT_DEPS = "1"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+# deps needed to extract content from the .bsp file
+DEPENDS += "tar-native gzip-native"
+
+do_compile() {
+ # Extract the bitstream into workdir
+ tar -xf ${WORKDIR}/${BSP_FILE} ${BSP_NAME}-axi-full-${PV}/pre-built/linux/images/download.bit -C ${S}
+ # move the bit file to ${S}/ as it is in a subdir in the tar file
+ for i in $(find -type f -name download.bit); do mv $i ${S}; done
+}
+
+do_install() {
+ install -D ${S}/download.bit ${D}/boot/download.bit
+}
+
+do_deploy () {
+ install -D ${S}/download.bit ${DEPLOYDIR}/download.bit
+}
+
+addtask deploy before do_build after do_install
+