summaryrefslogtreecommitdiff
path: root/meta-xilinx/meta-xilinx-bsp/recipes-devtools/qemu/qemu-devicetrees.inc
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-10-26 14:47:53 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-10-27 00:08:02 +0300
commitb6d590af3f28f1737ff681ed0ed94d812878962c (patch)
tree59cdd5c1003468ef563cd0b4d0426cf38d04f715 /meta-xilinx/meta-xilinx-bsp/recipes-devtools/qemu/qemu-devicetrees.inc
parent7bf39c061342ec43d4fe59d041858515a5afca92 (diff)
downloadopenbmc-b6d590af3f28f1737ff681ed0ed94d812878962c.tar.xz
meta-xilinx: remove subtree
The meta-xilinx layer was used for a now-deleted EVB. Neither the EVB nor the meta-xilinx layer have been updated for the Yocto override syntax change and the meta-xilinx still doesn't have a hardknott or honister branch (or corresponding support). I've asked the Xilinx maintainer back in May on when a hardknott version would be supported and I was told "about a month from now". I followed up in August and was told "work is in progress". As of today there are still zero commits in meta-xilinx since January 2021. As such, I do not believe this layer is well-maintained and we have no specific use for it anymore. Remove it until someone finds a good reason to include it and the upstream shows signs of life. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Id14ea55db2ac2779edf42e63cb57ad7d25172ad5
Diffstat (limited to 'meta-xilinx/meta-xilinx-bsp/recipes-devtools/qemu/qemu-devicetrees.inc')
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-devtools/qemu/qemu-devicetrees.inc40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-devtools/qemu/qemu-devicetrees.inc b/meta-xilinx/meta-xilinx-bsp/recipes-devtools/qemu/qemu-devicetrees.inc
deleted file mode 100644
index 8e752921a..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-devtools/qemu/qemu-devicetrees.inc
+++ /dev/null
@@ -1,40 +0,0 @@
-SUMMARY = "Xilinx's hardware device trees required for QEMU"
-HOMEPAGE = "https://github.com/xilinx/qemu-devicetrees/"
-LICENSE = "BSD"
-DEPENDS += "dtc-native"
-
-inherit deploy
-
-LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=27;md5=7348b6cbcae69912cb1dee68d6c68d99"
-
-PV = "xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI_append = " file://0001-Makefile-Use-python3-instead-of-python.patch"
-
-BRANCH ?= ""
-REPO ?= "git://github.com/Xilinx/qemu-devicetrees.git;protocol=https"
-
-BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
-SRC_URI = "${REPO};${BRANCHARG}"
-
-S = "${WORKDIR}/git"
-
-# Don't need to do anything
-do_install() {
- :
-}
-
-do_deploy() {
- # single-arch dtbs
- for DTS_FILE in ${S}/LATEST/SINGLE_ARCH/*.dtb; do
- install -Dm 0644 $DTS_FILE ${DEPLOYDIR}/qemu-hw-devicetrees/$(basename $DTS_FILE .dtb).dtb
- done
-
- # multi-arch dtbs
- for DTS_FILE in ${S}/LATEST/MULTI_ARCH/*.dtb; do
- install -Dm 0644 $DTS_FILE ${DEPLOYDIR}/qemu-hw-devicetrees/multiarch/$(basename $DTS_FILE .dtb).dtb
- done
-}
-
-addtask deploy after do_install