summaryrefslogtreecommitdiff
path: root/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx/0001-libtraceevent-Fix-build-with-binutils-2.35.patch
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:53:16 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:53:21 +0300
commit7eb438a61ba2d5b3cc7f0ac3fea1ca2e47390529 (patch)
treef3aee6c10811ebe6196859c998bd78d8dad36589 /meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx/0001-libtraceevent-Fix-build-with-binutils-2.35.patch
parenta59e4ee570958d218c22cd0513fbaefcf4a27563 (diff)
downloadopenbmc-7eb438a61ba2d5b3cc7f0ac3fea1ca2e47390529.tar.xz
meta-xilinx: subtree update:874b9cee5e..569f52f275
Jaewon Lee (1): xilinx-board.inc: Introducing inc file to add BOARD/BOARD_VARIANT Madhurkiran Harikrishnan (2): weston.ini: Do not set hard requirement for input devices libmali-xlnx: Update the mali userspace libraries to 2020.2 Mark Hatle (2): libmali-xlnx: Fix the package arch Various: Packages using libGL may need to be declared SOC_VARIANT_ARCH Raju Kumar Pothuraju (1): versal-generic.conf:zynqmp-generic.conf: Add MACHINE_ESSENTIAL_EXTRA_RDEPENDS variable only for specific machines. Sai Hari Chandana Kalluri (7): Add meta-python2 in bblayers.conf xrt_git.bb: Replace deprecated boost macros perf: Fix compilation issues Fix perf variable definition and libtraceevent with binutils. The above errors are fixed by including the following patches to the kernel tree: 0001-libtraceevent-Fix-build-with-binutils-2.35.patch 0001-perf-bench-Share-some-global-variables-to-fix-build-.patch 0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch 0001-perf-tests-bp_account-Make-global-variable-static.patch opencv_3.4.3: Remove support for opencv 3.4 Update commit id and branch for components for 2020.2 release update XILINX_VER_MAIN to 2020.2 bootgen: Update commit id for 2020.2 release Sandeep Gundlupet Raju (1): kernel-module-dp: Add support for Xilinx DP drivers Vishal Sagar (1): kernel-module-hdmi: Update commit id and license md5sum for 2020.2 ch vamshi krishna (3): updating xrt commit id updating final XRT commit id for 2020.2 updating XRT/Zocl commit id for 2020.2 rbramand (1): ] CR-1076958 Put libxrt libs softlinks in the main package Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I4c6b12024c4d07388334e29177417e34fe6dea87
Diffstat (limited to 'meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx/0001-libtraceevent-Fix-build-with-binutils-2.35.patch')
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx/0001-libtraceevent-Fix-build-with-binutils-2.35.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx/0001-libtraceevent-Fix-build-with-binutils-2.35.patch b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx/0001-libtraceevent-Fix-build-with-binutils-2.35.patch
new file mode 100644
index 000000000..25bc9f5b3
--- /dev/null
+++ b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx/0001-libtraceevent-Fix-build-with-binutils-2.35.patch
@@ -0,0 +1,39 @@
+From c2fd34d4311033120fa502aa8bd4723cdeee0103 Mon Sep 17 00:00:00 2001
+From: Ben Hutchings <ben@decadent.org.uk>
+Date: Sat, 25 Jul 2020 02:06:23 +0100
+Subject: [PATCH] libtraceevent: Fix build with binutils 2.35
+
+commit 39efdd94e314336f4acbac4c07e0f37bdc3bef71 upstream.
+
+In binutils 2.35, 'nm -D' changed to show symbol versions along with
+symbol names, with the usual @@ separator. When generating
+libtraceevent-dynamic-list we need just the names, so strip off the
+version suffix if present.
+
+Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
+Tested-by: Salvatore Bonaccorso <carnil@debian.org>
+Reviewed-by: Steven Rostedt <rostedt@goodmis.org>
+Cc: linux-trace-devel@vger.kernel.org
+Cc: stable@vger.kernel.org
+Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
+Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
+---
+ tools/lib/traceevent/plugins/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/lib/traceevent/plugins/Makefile b/tools/lib/traceevent/plugins/Makefile
+index f440989..23c3535 100644
+--- a/tools/lib/traceevent/plugins/Makefile
++++ b/tools/lib/traceevent/plugins/Makefile
+@@ -196,7 +196,7 @@ define do_generate_dynamic_list_file
+ xargs echo "U w W" | tr 'w ' 'W\n' | sort -u | xargs echo`;\
+ if [ "$$symbol_type" = "U W" ];then \
+ (echo '{'; \
+- $(NM) -u -D $1 | awk 'NF>1 {print "\t"$$2";"}' | sort -u;\
++ $(NM) -u -D $1 | awk 'NF>1 {sub("@.*", "", $$2); print "\t"$$2";"}' | sort -u;\
+ echo '};'; \
+ ) > $2; \
+ else \
+--
+2.7.4
+