summaryrefslogtreecommitdiff
path: root/meta-xilinx/meta-xilinx-bsp/recipes-kernel
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-01-30 00:55:05 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-01-30 19:33:11 +0300
commitc60845c87403beb867c541f4271d05287f38a985 (patch)
tree077e305e62d0ef0acb5e06b22fab88fb087d5c4d /meta-xilinx/meta-xilinx-bsp/recipes-kernel
parent7c9805840d4a9d4c02c6a18e5fbfef48bd621fec (diff)
downloadopenbmc-c60845c87403beb867c541f4271d05287f38a985.tar.xz
meta-xilinx: subtree update:a9025136f5..eb4ba06eb1
David Roman (1): picozed-zynq7.dts: add marvell,88e1510 to eth phy Jaewon Lee (3): xilinx-board.inc: fixing BOARD_ARCH and BOARDVARIANT_ARCH names Adding BOARD and BOARD_VARIANT level hierarchy ultra96: Using BOARD level hiearchy for ultra96 overrides Madhurkiran Harikrishnan (1): weston: Update the weston patches to comply with weston-9.0 Philip Balister (2): u-boot-xlnx: Fix build error by applying patch from upstream u-boot. linux-xlnx: Fix build with patch from upstream kernel for gcc-10. Raju Kumar Pothuraju (1): linux-xlnx.inc: Update overlay config fragments Sai Hari Chandana Kalluri (4): Update LICENSE_CHECKSUM for kernel-module-hdmi zcu102-zynqmp.conf: Fix qemuboot for zcu102-zynqmp Cleanup QB_MACHINE for xilinx machines qemu-xilinx: Fix patch puzz warning during do_patch Varalaxmi Bingi (1): meta-xilinx-bsp: Move uboot-device-tree to meta-xilinx-tools layer Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I2c1c51b9988cb36185f3218075ea007c14f82ff8
Diffstat (limited to 'meta-xilinx/meta-xilinx-bsp/recipes-kernel')
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-kernel/hdmi/kernel-module-hdmi_git.bb2
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux-firmware/linux-firmware_%.bbappend9
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx.inc4
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx/0001-scripts-dtc-Remove-redundant-YYLOC-global-declaratio.patch51
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2020.2.bb1
5 files changed, 60 insertions, 7 deletions
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-kernel/hdmi/kernel-module-hdmi_git.bb b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/hdmi/kernel-module-hdmi_git.bb
index 6a88ac51d..b26ecd948 100644
--- a/meta-xilinx/meta-xilinx-bsp/recipes-kernel/hdmi/kernel-module-hdmi_git.bb
+++ b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/hdmi/kernel-module-hdmi_git.bb
@@ -2,7 +2,7 @@ SUMMARY = "Xilinx HDMI Linux Kernel module"
DESCRIPTION = "Out-of-tree HDMI kernel modules provider for MPSoC EG/EV devices"
SECTION = "kernel/modules"
LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://LICENSE.md;md5=498a38cdcb922b9e987bbbb46e8a9ee5"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=570506b747d768e7802376f932dff926"
XLNX_HDMI_VERSION = "5.4.0"
PV = "${XLNX_HDMI_VERSION}"
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux-firmware/linux-firmware_%.bbappend b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
index a1e4cb0ba..eb64045a8 100644
--- a/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
+++ b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
@@ -1,14 +1,14 @@
# TIInit_11.8.32.bts is required for bluetooth support but this particular
# version is not available in the linux-firmware repository.
#
-SRC_URI_append_ultra96-zynqmp = "\
+SRC_URI_append_ultra96 = "\
https://git.ti.com/ti-bt/service-packs/blobs/raw/c290f8af9e388f37e509ecb111a1b64572b7c225/initscripts/TIInit_11.8.32.bts;name=TIInit_11.8.32 \
"
SRC_URI[TIInit_11.8.32.md5sum] = "b1e142773e8ef0537b93895ebe2fcae3"
SRC_URI[TIInit_11.8.32.sha256sum] = "962322c05857ad6b1fb81467bdfc59c125e04a6a8eaabf7f24b742ddd68c3bfa"
-do_install_append_ultra96-zynqmp() {
+do_install_append_ultra96() {
cp ${WORKDIR}/TIInit_11.8.32.bts ${D}${nonarch_base_libdir}/firmware/ti-connectivity/
( cd ${D}${nonarch_base_libdir}/firmware ; ln -sf ti-connectivity/* . )
rm -f ${D}${nonarch_base_libdir}/firmware/ti-connectivity/TIInit_7*
@@ -17,12 +17,13 @@ do_install_append_ultra96-zynqmp() {
INSANE_SKIP_${PN} += "installed-vs-shipped"
-PACKAGES_remove_ultra96-zynqmp = "${PN}-wl12xx"
+PACKAGES_remove_ultra96 = "${PN}-wl12xx"
-FILES_${PN}-wl18xx_ultra96-zynqmp = " \
+FILES_${PN}-wl18xx_ultra96 = " \
${nonarch_base_libdir}/firmware/wl18* \
${nonarch_base_libdir}/firmware/TI* \
${nonarch_base_libdir}/firmware/ti-connectivity/wl18* \
${nonarch_base_libdir}/firmware/ti-connectivity/TI* \
"
+PACKAGE_ARCH_ultra96 = "${BOARD_ARCH}"
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx.inc b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx.inc
index 6b4264f54..a98fc8018 100644
--- a/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx.inc
+++ b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx.inc
@@ -56,10 +56,10 @@ KERNEL_FEATURES_append_kc705-microblazeel = " bsp/xilinx/kc705-microblazeel-feat
KERNEL_FEATURES_append_zynqmp = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', ' features/xen/xen.scc', '', d)}"
-KERNEL_FEATURES_append_zynqmp = "${@' features/xilinx/overlay/overlay_of.scc' if d.getVar('FPGA_MNGR_RECONFIG_ENABLE') == '1' else ''}"
+KERNEL_FEATURES_append_zynqmp = "${@' features/xilinx/overlay_of/overlay_of.scc' if d.getVar('FPGA_MNGR_RECONFIG_ENABLE') == '1' else ''}"
KERNEL_FEATURES_append_versal = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', ' features/xen/xen.scc', '', d)} features/xilinx/hdmi-module/hdmi-module.scc"
-KERNEL_FEATURES_append_ultra96-zynqmp = " bsp/xilinx/ultra96-zynqmp/mipi-config-ultra96.scc"
+KERNEL_FEATURES_append_ultra96 = " bsp/xilinx/ultra96-zynqmp/mipi-config-ultra96.scc"
KERNEL_FEATURES_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'virtualization', ' features/ocicontainer/ocicontainer.scc', '', d)}"
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx/0001-scripts-dtc-Remove-redundant-YYLOC-global-declaratio.patch b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx/0001-scripts-dtc-Remove-redundant-YYLOC-global-declaratio.patch
new file mode 100644
index 000000000..d5b96c2d1
--- /dev/null
+++ b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx/0001-scripts-dtc-Remove-redundant-YYLOC-global-declaratio.patch
@@ -0,0 +1,51 @@
+From e33a814e772cdc36436c8c188d8c42d019fda639 Mon Sep 17 00:00:00 2001
+From: Dirk Mueller <dmueller@suse.com>
+Date: Tue, 14 Jan 2020 18:53:41 +0100
+Subject: [PATCH] scripts/dtc: Remove redundant YYLOC global declaration
+
+gcc 10 will default to -fno-common, which causes this error at link
+time:
+
+ (.text+0x0): multiple definition of `yylloc'; dtc-lexer.lex.o (symbol from plugin):(.text+0x0): first defined here
+
+This is because both dtc-lexer as well as dtc-parser define the same
+global symbol yyloc. Before with -fcommon those were merged into one
+defintion. The proper solution would be to to mark this as "extern",
+however that leads to:
+
+ dtc-lexer.l:26:16: error: redundant redeclaration of 'yylloc' [-Werror=redundant-decls]
+ 26 | extern YYLTYPE yylloc;
+ | ^~~~~~
+In file included from dtc-lexer.l:24:
+dtc-parser.tab.h:127:16: note: previous declaration of 'yylloc' was here
+ 127 | extern YYLTYPE yylloc;
+ | ^~~~~~
+cc1: all warnings being treated as errors
+
+which means the declaration is completely redundant and can just be
+dropped.
+
+Signed-off-by: Dirk Mueller <dmueller@suse.com>
+Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
+[robh: cherry-pick from upstream]
+Cc: stable@vger.kernel.org
+Signed-off-by: Rob Herring <robh@kernel.org>
+---
+ scripts/dtc/dtc-lexer.l | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/scripts/dtc/dtc-lexer.l b/scripts/dtc/dtc-lexer.l
+index 5c6c3fd557d7..b3b7270300de 100644
+--- a/scripts/dtc/dtc-lexer.l
++++ b/scripts/dtc/dtc-lexer.l
+@@ -23,7 +23,6 @@ LINECOMMENT "//".*\n
+ #include "srcpos.h"
+ #include "dtc-parser.tab.h"
+
+-YYLTYPE yylloc;
+ extern bool treesource_error;
+
+ /* CAUTION: this will stop working if we ever use yyless() or yyunput() */
+--
+2.29.2
+
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2020.2.bb b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2020.2.bb
index 314b293ab..44fa42de1 100644
--- a/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2020.2.bb
+++ b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2020.2.bb
@@ -10,5 +10,6 @@ SRC_URI_append = " \
file://0001-perf-tests-bp_account-Make-global-variable-static.patch \
file://0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch \
file://0001-libtraceevent-Fix-build-with-binutils-2.35.patch \
+ file://0001-scripts-dtc-Remove-redundant-YYLOC-global-declaratio.patch \
"