summaryrefslogtreecommitdiff
path: root/meta-xilinx/meta-xilinx-bsp/recipes-support/opencv/opencv_3.4.3/0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:53:16 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:53:21 +0300
commit7eb438a61ba2d5b3cc7f0ac3fea1ca2e47390529 (patch)
treef3aee6c10811ebe6196859c998bd78d8dad36589 /meta-xilinx/meta-xilinx-bsp/recipes-support/opencv/opencv_3.4.3/0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch
parenta59e4ee570958d218c22cd0513fbaefcf4a27563 (diff)
downloadopenbmc-7eb438a61ba2d5b3cc7f0ac3fea1ca2e47390529.tar.xz
meta-xilinx: subtree update:874b9cee5e..569f52f275
Jaewon Lee (1): xilinx-board.inc: Introducing inc file to add BOARD/BOARD_VARIANT Madhurkiran Harikrishnan (2): weston.ini: Do not set hard requirement for input devices libmali-xlnx: Update the mali userspace libraries to 2020.2 Mark Hatle (2): libmali-xlnx: Fix the package arch Various: Packages using libGL may need to be declared SOC_VARIANT_ARCH Raju Kumar Pothuraju (1): versal-generic.conf:zynqmp-generic.conf: Add MACHINE_ESSENTIAL_EXTRA_RDEPENDS variable only for specific machines. Sai Hari Chandana Kalluri (7): Add meta-python2 in bblayers.conf xrt_git.bb: Replace deprecated boost macros perf: Fix compilation issues Fix perf variable definition and libtraceevent with binutils. The above errors are fixed by including the following patches to the kernel tree: 0001-libtraceevent-Fix-build-with-binutils-2.35.patch 0001-perf-bench-Share-some-global-variables-to-fix-build-.patch 0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch 0001-perf-tests-bp_account-Make-global-variable-static.patch opencv_3.4.3: Remove support for opencv 3.4 Update commit id and branch for components for 2020.2 release update XILINX_VER_MAIN to 2020.2 bootgen: Update commit id for 2020.2 release Sandeep Gundlupet Raju (1): kernel-module-dp: Add support for Xilinx DP drivers Vishal Sagar (1): kernel-module-hdmi: Update commit id and license md5sum for 2020.2 ch vamshi krishna (3): updating xrt commit id updating final XRT commit id for 2020.2 updating XRT/Zocl commit id for 2020.2 rbramand (1): ] CR-1076958 Put libxrt libs softlinks in the main package Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I4c6b12024c4d07388334e29177417e34fe6dea87
Diffstat (limited to 'meta-xilinx/meta-xilinx-bsp/recipes-support/opencv/opencv_3.4.3/0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch')
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-support/opencv/opencv_3.4.3/0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-support/opencv/opencv_3.4.3/0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch b/meta-xilinx/meta-xilinx-bsp/recipes-support/opencv/opencv_3.4.3/0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch
deleted file mode 100644
index f8ccd1d55..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-support/opencv/opencv_3.4.3/0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From fe27d0e2341683606704115949d16250e4cacbfa Mon Sep 17 00:00:00 2001
-From: Jason Wessel <jason.wessel@windriver.com>
-Date: Wed, 9 May 2018 13:33:59 -0700
-Subject: [PATCH] Temporarliy work around deprecated ffmpeg RAW function
- compile failure until next uprev
-
-Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
-
----
- modules/videoio/src/cap_ffmpeg_impl.hpp | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/modules/videoio/src/cap_ffmpeg_impl.hpp b/modules/videoio/src/cap_ffmpeg_impl.hpp
-index 0d360ad..566df66 100644
---- a/modules/videoio/src/cap_ffmpeg_impl.hpp
-+++ b/modules/videoio/src/cap_ffmpeg_impl.hpp
-@@ -736,6 +736,14 @@ struct ImplMutex::Impl
-
- #endif
-
-+/* NOTE This is deprecated in ffmpeg and the code should be removed */
-+#ifndef AVFMT_RAWPICTURE
-+#define AVFMT_RAWPICTURE 0x0020
-+#endif /* AVFMT_RAWPICTURE */
-+#ifndef CODEC_FLAG_GLOBAL_HEADER
-+#define CODEC_FLAG_GLOBAL_HEADER AV_CODEC_FLAG_GLOBAL_HEADER
-+#endif
-+
- void ImplMutex::init()
- {
- impl = new Impl();