summaryrefslogtreecommitdiff
path: root/meta-xilinx/meta-xilinx-contrib/recipes-bsp/reference-design
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-10-26 14:47:53 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-10-27 00:08:02 +0300
commitb6d590af3f28f1737ff681ed0ed94d812878962c (patch)
tree59cdd5c1003468ef563cd0b4d0426cf38d04f715 /meta-xilinx/meta-xilinx-contrib/recipes-bsp/reference-design
parent7bf39c061342ec43d4fe59d041858515a5afca92 (diff)
downloadopenbmc-b6d590af3f28f1737ff681ed0ed94d812878962c.tar.xz
meta-xilinx: remove subtree
The meta-xilinx layer was used for a now-deleted EVB. Neither the EVB nor the meta-xilinx layer have been updated for the Yocto override syntax change and the meta-xilinx still doesn't have a hardknott or honister branch (or corresponding support). I've asked the Xilinx maintainer back in May on when a hardknott version would be supported and I was told "about a month from now". I followed up in August and was told "work is in progress". As of today there are still zero commits in meta-xilinx since January 2021. As such, I do not believe this layer is well-maintained and we have no specific use for it anymore. Remove it until someone finds a good reason to include it and the upstream shows signs of life. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Id14ea55db2ac2779edf42e63cb57ad7d25172ad5
Diffstat (limited to 'meta-xilinx/meta-xilinx-contrib/recipes-bsp/reference-design')
-rw-r--r--meta-xilinx/meta-xilinx-contrib/recipes-bsp/reference-design/zybo-linux-bd.bb66
1 files changed, 0 insertions, 66 deletions
diff --git a/meta-xilinx/meta-xilinx-contrib/recipes-bsp/reference-design/zybo-linux-bd.bb b/meta-xilinx/meta-xilinx-contrib/recipes-bsp/reference-design/zybo-linux-bd.bb
deleted file mode 100644
index be68918cf..000000000
--- a/meta-xilinx/meta-xilinx-contrib/recipes-bsp/reference-design/zybo-linux-bd.bb
+++ /dev/null
@@ -1,66 +0,0 @@
-SUMMARY = "The reference design for zybo-linux-bd"
-DESCRIPTION = "Contains the Reference Design Files and hardware software \
-hand-off file. The HDF provides bitstream and Xilinx ps7_init_gpl.c/h \
-platform headers."
-SECTION = "bsp"
-
-DEPENDS += "unzip-native"
-
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://Projects/${HW_BD}/readme.txt;md5=e1cb7639bf00b6e730ff3a7f13714951"
-
-COMPATIBLE_MACHINE = "zybo-linux-bd-zynq7"
-
-HW_BD = "linux_bd"
-
-SRC_URI = "git://github.com/Digilent/ZYBO.git;protocol=https;nobranch=1"
-SRCREV = "63ca49fe027da49f3b0ac636bd404fd31fbbd945"
-
-PV = "+git${SRCPV}"
-
-S = "${WORKDIR}/git"
-
-HDF = "/Projects/${HW_BD}/hw_handoff/${HW_BD}_wrapper.hdf"
-
-S ?= "${WORKDIR}/${MACHINE}"
-
-PROVIDES = "virtual/bitstream virtual/xilinx-platform-init"
-
-FILES_${PN}-platform-init += "${PLATFORM_INIT_DIR}/*"
-
-FILES_${PN}-bitstream += " \
- download.bit \
- "
-
-PACKAGES = "${PN}-platform-init ${PN}-bitstream"
-
-BITSTREAM ?= "bitstream-${PV}-${PR}.bit"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-inherit xilinx-platform-init
-inherit deploy
-
-SYSROOT_DIRS += "${PLATFORM_INIT_DIR}"
-
-do_install() {
- fn=$(unzip -l ${S}/${HDF} | awk '{print $NF}' | grep ".bit$")
- unzip -o ${S}/${HDF} ${fn} -d ${D}
- [ "${fn}" == "download.bit" ] || mv ${D}/${fn} ${D}/download.bit
-
- install -d ${D}${PLATFORM_INIT_DIR}
- for fn in ${PLATFORM_INIT_FILES}; do
- unzip -o ${S}/${HDF} ${fn} -d ${D}${PLATFORM_INIT_DIR}
- done
-}
-
-do_deploy () {
- if [ -e ${D}/download.bit ]; then
- install -d ${DEPLOYDIR}
- install -m 0644 ${D}/download.bit ${DEPLOYDIR}/${BITSTREAM}
- ln -sf ${BITSTREAM} ${DEPLOYDIR}/download.bit
- # for u-boot 2016.3 with spl load bitstream patch
- ln -sf ${BITSTREAM} ${DEPLOYDIR}/bitstream
- fi
-}
-addtask deploy before do_build after do_install